USB Keyboard Encoder "Dual Strike" ArcadeForge

  • Global moderator Translator
    Translation Master
    Global moderator

  • @SmashDde , what you describe seems to be correct.
    Check if the device listing shows more than one entry/name. If yes, you must try them all.
    I used this method to setup my iPac2, and I remember only one of the strings worked.

  • @jonas @Zing

    Thanks! What could be the cause for the usb encoder to be only recognized as "keyboard" no matter what I try, though?

    Flashed the 6.1.1 image fresh onto the sd card (removed any custom partitioning and so on beforehand), made basic configuration (like WiFi so I can get SSH shell connection), and tried creating the file(s) mentioned in the /system/configs/xarcade2jstick folder (file a, file b, file a and b).
    Each try with a reboot and testing of course. Double checked using the exact same name the ls command is outputting, despite using copy and paste for it.
    Only getting "keyboard" now when configuring the buttons, which is quite frustrating.

  • Global moderator Translator
    Translation Master
    Global moderator


    What could be the cause for the usb encoder to be only recognized as "keyboard" no matter what I try, though?

    I'm not a developer, and I don't have enough technical knowledge to guarantee ... but, as far as I understand, the driver makes the device recognized as a keyboard, including the name of the file you cited makes it look like this (kbd seems to be the abbreviation for keyboard):


    As I said, I am not a developer, so I may be wrong.

  • I have an iPac-2 and just updated fresh install of 7.1.1.

    I have the same exact issue as @smashDde above. I see the devices listed. It tired making a file for all the devices displayed. (The kbd one should be the most logical) .. but nothing works. I deleted all the ones that were listed by default. Created one of the devices. Rebooted and repeated that over and over. None of the documentation indicate whether or not to delete the existing files or to create all of the device names listed by-id in the xarcade2jstick directory.

    Doesn't matter what I try, the recalbox emulation station controller setup area does NOT see a keyboard there by it doesn't let me hold a button and program the keys! But get this, I can use Joystick 1 perfectly up,down, right,left... I can press player 2 switch 1 and it effectively acts as the "A" select key on the keyboard. Basically, there is a mapping of sorts, but it's totally messed up. And with NO way to reprogram the button mapping.. The new version of recalbox is a step or three backwards. Poor documentation does not help at all I might add.😧

    If you know how to manually edit the emulation station keyboard mapping to bypass the keyboard detection thing.. that may be useful.

  • @pssadm Thanks for describing your situation as well. I have put 2-digit hours into trying to solve the seemingly problem on my end (adding custom controllers wasn't too easy anyway) but I don't think it's something you could solve by doing it different anymore.
    When I have the time and desire I will try it again with recalbox v6 - which wasn't successful the last three or four times btw but I had it working prior to upgrading to v7 - or I'll move over to some other project. At the moment I am still hoping for "the magic update that fixes this" but ...

  • @pssadm @SmashDde ,

    Last time I used my iPac2, I was still on Recalbox 6.x. Meanwhile, I had my devices stowed away, and now I reassembled my control panel just to verify if they work. I checked again with 7.1.1, and I can confirm the iPac2 does not work anymore. It behaves like a plain simple keyboard. My iPac2 controller is very old, pre-2015, no fancy firmware updates to check, but has always worked fine.
    Damn. Time to try another retrogaming distro.

  • Global moderator Translator
    Translation Master
    Global moderator


    I am still hoping for "the magic update that fixes this" but ...

    I am sorry for the problem you are facing, but unfortunately there is no magic involved: there is only the hard work of a small team of developers working hard to serve as many users as possible, but without having all the possible hardware.


    Time to try another retrogaming distro.

    It is a pity to hear that, but unfortunately I cannot give a date for the problem to be solved, I can only suggest that you support the issue that was opened by @SmashDde :

    If you check it out, you'll notice that there are another 192 issues open, and the team is doing its best.

  • @Zing Hey there. Don't get me wrong, please - I am sure, everybody involved is doing their best to bring the project forward. And I know that your problem does not get recognized or pushed top priority just because you've reported it. No way 😉
    On the other hand, if you (as a user) are stuck with something for months, more often than not with the added passion of a personal DIY project, it gets frustrating when there's seemingly nobody actively into solving it.

    I think everybody does understand the pov of the users in this as well?!

  • Global moderator Translator
    Translation Master
    Global moderator

    @SmashDde Of course, we understand the pov of a frustrated user because there is a bug, and as a user, I fully understand how bad this is.

    I just wanted to make clear the situation of the developers, and to make it clear that if more users comment on your issue it will be
    better: the team of developers is small, and the work is a lot, so they need to prioritize, and one of the priority criteria is the number of users affected.

Want to support us ?