Dragon's Lair > MAME / Daphne



  • Bonjour,

    Désolé de déterrer un vieux sujet mais j'aurais besoin d'informations malgré toutes les recherches que j'ai effectué.

    J'ai aujourd'hui une Rpi3b+ avec RecalBox 7.1 et je souhaite avoir Dragon's Lair II Tim Warp.

    Impossible de le lancer sous Daphne ( Rom + .daphne + "." en première ligne dans le .txt)
    Impossible de le lancer sous MAME (Essaie de plusieurs Roms différents dans le dossier MAME).

    Quelqu'un aurait des informations à ce sujet?

    Merci d'avance 🙂


  • Revisor

    Ton répertoire daphne contient-il bien ?

    • le fichier txt listant le ou les fichiers vidéos
    • le ou les fichiers vidéos (m2v)
    • le ou les fichiers audios (ogg)
    • éventuellement, le fichier .dat et .commands

    Les fichiers audios et vidéos correspondent au CD-vidéo utilisé à l'époque par la borne d'arcade.
    La ROM ne contenait que le code du jeu ...


  • Revisor



  • Bonjour @lmerckx,

    Merci de me répondre. En effet mon répertoire Daphne contient un dossier DL2.daphne contenant les fichiers vidéos, musiques ainsi que le fichier commands et le fichier .txt. Ils ont tous le même nom "dl2". Et dans le répertoire Daphne, j'ai également un dossier "roms", contenant la rom .zip de la région Europe.

    Merci



  • @saween,

    I hope this helps, here is what my set up looks like:

    in /recalbox/share/roms/daphne

    [ls -l]

    lair2.daphne

    in /recalbox/share/roms/daphne/lair2.daphne

    [ls -l]

    I have all my .dat, .ogg, .m2v files and:
    lair2.commands
    lair2.txt
    lair2.m2v
    lair2.ogg
    lair2.dat

    all the other files start with dl2-XXXX.dat, dl2-XXXX.m2v, dl2-XXXX.ogg
    where XXXX is some number

    In /recalbox/share/roms/daphne/roms
    [ls -l]

    lair2.zip

    Notice every lair2 file (lair.zip, lair2.commands, lair2.txt, lair2.daphne) are all exactly the same (all lowercase)



  • Hello @sroach,

    Thank you for your response.

    You can see that my folder is like your.

    in /recalbox/share/roms/daphne
    dl2.daphne
    roms

    in /recalbox/share/roms/daphne/dl2.daphne
    I have all my .dat, .ogg, .m2v files and:
    dl2.commands
    dl2.txt
    dl2.m2v
    dl2.ogg
    dl2.dat

    all the other files start with dl2-XXXX.dat, dl2-XXXX.m2v, dl2-XXXX.ogg
    where XXXX is some number

    In /recalbox/share/roms/daphne/roms
    dl2.zip

    So I don't really know.. 😕



  • @Saween said in Dragon's Lair > MAME / Daphne:

    Impossible to launch it under Daphne (Rom + .daphne + "." In first line in the .txt)

    in your first post you said:
    Impossible to launch it under Daphne (Rom + .daphne + "." In first line in the .txt)

    in your lair2.txt there is more than just the "."?

    Mine looks like..below:
    .
    00001 dl2-00001.m2v
    00002 dl2-00002.m2v
    00721 dl2-00721.m2v
    02102 dl2-02102.m2v
    04427 dl2-04427.m2v
    04477 dl2-04477.m2v
    04527 dl2-04527.m2v
    04577 dl2-04577.m2v

    with a whole bunch more line like the above.

    What exactly is happening when you click on Lair 2? Daphne not mame version.



  • @saween,

    Also I just remembered while looking at my daphna folder. I have several dlair2.zip verisons

    See screen shot
    Screen Shot 2020-11-18 at 11.01.35 AM.png

    I also found this article explaining the different versions:
    http://www.dragons-lair-project.com/tech/pages/dl2.asp

    my take is the dalir2.zip corresponds to the media files

    I seem to remember trying a few different versions of these lair2_X. I copied them to dlair2.zip and tried it

    i seem to remeber for me dlair2_211.zip copied to dlair2.zip was the one that worked for me.

    I hope this helps



  • @sroach

    In my ".txt" file, everythings is ok:
    .
    00001 dl2-00001.m2v
    00002 dl2-00002.m2v
    00721 dl2-00721.m2v
    02102 dl2-02102.m2v
    04427 dl2-04427.m2v
    04477 dl2-04477.m2v
    etc...

    When I click on DL2 in Daphne mode, I have a black screen and then come back in Daphne mode..



  • @sroach

    I downloaded another Lair2 and see:
    .
    00001 dl2-00001.m2v
    00002 dl2-00002.m2v
    00721 dl2-00721.m2v
    02102 dl2-02102.m2v
    04427 dl2-04427.m2v
    04477 dl2-04477.m2v
    04527 dl2-04527.m2v

    It's like yours now, but i think, the issue provide from the rom..



  • I agree, I think it's a rom mis-match. I think you're on the right path and will get it working.



  • @sroach Could you maybe provide the MD5 hash of your lair2.zip file? I have the same issue (I'm using 7.0.1 on Pi4). Most other Daphne games work fine.



  • @Cap

    see below.

    Screen Shot 2020-11-25 at 8.42.18 AM.png

    Let me know if that helps, or you need any others.



  • @sroach Thanks for checking! So my rom file seems to be correct, but the game is still not starting. hypseus just terminates with exitcode 1.

    I checked the command line that ES generates, which is

    LANG=en_US.UTF-8 TERM=linux SHELL=/bin/sh CONSOLE=/dev/console SDL_VIDEO_EGL_DRIVER=/usr/lib/libEGL.so SHLVL=3 PREVLEVEL=N SDL_NOMOUSE=1 PWD=/ dev=/dev/mmcblk0p1 RUNLEVEL=S elevator=deadline PATH=/sbin:/usr/sbin:/bin:/usr/bin INIT_VERSION=sysvinit- HOME=/recalbox/share/system _=/usr/bin/python SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so /usr/bin/hypseus lair2 vldp -framefile /recalbox/share/roms/daphne/lair2.daphne/lair2.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -noserversend

    When SSH-ing into the machine and executing this command, I get the same result (no traces / logs, just exit with code 1). Now the interesting thing: when I skip the ENV vars and just execute

    /usr/bin/hypseus lair2 vldp -framefile /recalbox/share/roms/daphne/lair2.daphne/lair2.txt -fullscreen -useoverlaysb 2 -datadir /usr/share/daphne -homedir /recalbox/share/roms/daphne -noserversend

    it actually works! Will investigate further.



  • Ok I got it running! It actually was the "-noserversend" argument which I had in the lair2.commands file. As soon as I remove this, DL2 runs just fine, both from command line and from ES. (I think the command line from my post above was wrong and did actually not include -noserversend).

    Interestingly, I use -noserversend in other command files and there it does not seem to cause issues. Anyway, thanks for helping!



  • @Cap Hmm interesting.. glad you got it working..

    I'll have to go in and see what command mine is kicking off and if the -noserversend make a difference on mine.



  • @Cap Great !

    How can you see the argument from lair2.commands? I don't have any SSH.



  • @Cap What's the command to delete -noserversend ?



  • @sroach I did a few checks with the roms I'm using. This is the list of roms that don't work with the -noserversend argument:

    cliff
    gpworld
    tq
    esh
    lair2
    roadblaster

    These roms work fine with the -noserversend argument:

    uvt
    lair
    bega
    cobraconv
    galaxy
    astron
    badlands
    interstellar
    mach3
    sdq
    sae

    I'm not even sure if it makes any difference whether to include -noserversend or not for hypseus on Pi. Anyway, it's working now so I'm happy. 😊 The only issue left is that sometimes the sound is out of sync with the video. Noticeable in Space Ace for example, in some scenes the sound is ahead a second or so. Not a deal breaker, though, as the button timing is correct and in sync with the video, so the games are playable.



  • @Saween There is actually no command to delete -noserversend. Instead, you can pass command line arguments to the launcher by creating an additional file in your game folder. E.g. for lair2, that would be

    ./roms/daphne/lair2.daphne/lair2.commands

    If you have no such file, then you also don't have the -noserversend argument.

    I think that you use a wrong folder name (you wrote you have your files in DL2.daphne). So the launcher will try to find a rom called "DL2", which does not exist. Be sure that the name of this folder reads "lair2.daphne". Also be sure that your rom file sits in the correct place. Its expected to be in

    ./roms/daphne/roms/lair2.zip



Want to support us ?

301
Online

80.5k
Users

21.7k
Topics

158.3k
Posts