Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Forcing videomode for Emu doesn't change the refresh rate, only the resolution



  • Hi,
    first of all many compliments for the wonderful job you are doing 🙂

    I just signed up and wanted to contribute by reporting an annoying bug I found on my Rpi4.

    I have all my SNES roms in PAL format and so I want to set a 50Hz video mode to have a smooth image.

    So I set "snes.videomode = CEA 31 HDMI" in my recalbox.conf (CEA 31 = 1080p 50Hz)

    However, I noticed that the SNES emulator still ran at 1080p 60Hz, the same mode as the Emulation Station interface.

    So, to check if the snes.videomode line was completely ignored, I set it with CEA 19 HDMI (= 720p 50Hz).
    By doing this, the SNES emulator worked ok at 720p, but at 60Hz!

    Also tried to put "global.videomode = CEA 31 HDMI", nothing

    As a last test, I put 50Hz on the ES interface "system.es.videomode = CEA 31 HDMI" and at this point my SNES emulator also started at 50Hz.

    So I think there is a bug, at least in this configuration (Rpi4 - Snes emu) that prevents you from changing the emulator refresh rate.


  • Developer
    Team
    Global moderator
    Translator

    @colpoz I believe you should change the refresh rate from within the retroarch's menu. It might be that the emulators default is 60 hz or that it is autodetected and you are using a ntsc rom.



  • @paradadf all my SNES roms are PAL, and the emulator correctly detects and runs them at 50fps (easily verified by the "show framerate" option).

    On the previous recalbox 6 on Rpi3b + the snes.videomode setting worked perfectly, even to switch from 60Hz (EmuliationStation) to 50Hz (SNES emu)

    This is why I talked about a possible bug, because before everything worked fine and now it doesn't. 😉


  • Developer
    Team
    Global moderator
    Translator

    @colpoz I'm confused. You first said you weren't getting 50 hz and now you wrote you are getting the 50 hz.



  • @paradadf to play correctly a PAL rom two things are needed

    • the EMU must recognize the PAL rom and runs it at 50fps (no problem on that)

    AND

    • the video mode output must be at 50Hz (720p@50Hz, 1080p@50Hz or similiar, the resolution doesn't matter)

    By default EmulationStation and the emu run at 60Hz, and so I set a different video mode for the snes emulator in recalbox.conf, to have a 50Hz video output when I use a SNES game.

    This setting doesn't work properly and so I get the emulator running (correctly) at 50fps and a 60Hz video output, resulting in a stuttering image.




  • Developer
    Team
    Global moderator
    Translator

    @colpoz when I start a game, my tv changes the resolution to what retroarch tells it. But maybe @Bkg2k can help here.


  • Developer
    Team
    Global moderator
    Translator

    @Secamfr that's it, thanks!



Want to support us ?

263
Online

79.7k
Users

21.0k
Topics

153.8k
Posts