Recalbox 7.0

Please help, can't save in Mupen64plus non libretro.



  • The game is Donkey Kong 64. In the libretro version the camera stutters which is a bug. I'm using the non-libretro version because the bug doesn't exist with that version, also the performance is so much better. How do I enable saving in the non-libretro version? There is no RetroArch menu, so things have to be tweaked in the config files. In the mupen64plus.cfg and inpuAutoCfg.ini located at RECALBOX\share\system\configs\mupen64, I see that there is a Mempak switch setting. I have set mempak switch = "hat(0 Down)" in both files, however pressing that button before saving doesn't work, the save doesn't exist after saving, restarting the game, and attempting to load that save.. Also, the setting in the files gets reverted back to a blank binding Mempak switch = "" in the files after exiting the emulator. How do I go about saving in this version of the emulator? Am I doing something wrong?


  • Developer
    Team
    Global moderator
    Translator

    @Lumbeechief081 you don't need to change anything in the config... Just save like you'll regularly do in a real console... reaching a checkpoint, opening the menu (or whatever) and saving.



  • @paradadf Donkey Kong doesn't actually save though when clicking save on the pause screen. I tested another game "Ocarina of Time" and "Super Mario 64" and they saved just fine using the non librertro emulator.



  • ssh in to the device and rename (like add .old to the file name) the donkey kong save file (/recalbox/share/saves/n64/) you most likley have a weird permissions issue on the current save file or its corrupt in some way.

    If you rename the save file while the game is pause, then save, it should recreate a good save file.



  • @Zaphod There is no old save file. This is a totally new save I'm trying to create for the first time. Having the share opened at (/recalbox/share/saves/n64/) the emulator doesn't create a save file when clicking save in the pause screen of Donkey Kong 64. I refresh the folder yet the save file still doesn't exist no matter how much I spam the save button in Donkey Kong. This is totally weird considering how Super Mario 64 and Ocarina of Time generates a save file.


  • Developer
    Team
    Global moderator
    Translator

    @Lumbeechief081 I‘ll test it tomorrow. You are on a rpi3 and using the USA version of the rom?



  • @paradadf Ah! So apparently this seems to be a problem with Recalbox. I tried the same rom using Batocera and the same emulator and the game saved just fine.


  • Developer
    Team
    Global moderator
    Translator

    @Lumbeechief081 I asked you about your setup because I wanted to test with same conditions, not because there is a problem. Anyway... the game works on my side and I can save without issues.



  • @paradadf I don't know why you can save but I couldn't. Are you sure that you're using the non libretro version of the emulator? And that you are also using the USA version of the rom? This was a fresh install of Recalbox and the game didn't save for me. Testing the same game using Batocera the game saved fine.



  • @Lumbeechief081
    Can you search your mupen64 ini file?
    /recalbox/share/system/configs/mupen64/mupen64plus.ini I know it LONG but what I am looking for is the SaveType listed under Donkey Kong 64. There will be Multiple entries in your file so you can do the following

    log in via SSH:
    nano /recalbox/share/system/configs/mupen64/mupen64plus.ini
    hit CTRL + w (search)
    type Donkey Kong 64 and hit enter
    check under the entry and make sure SaveType is "Eeprom 16KB"
    hit CTRL + w again and the nenter for the next instance.
    Check that each version of the rom has the seave type listed as Eeprom 16KB (if one is wrong change it)

    This sometimes happens the save file is set to 4KB or 8KB

    The alternative is to replace your ini file with a known good one. Some older ini files had it listed wrong. Not sure if this is the case but its worth looking into. It would absolutely cause this behavior.



Want to support us ?

161
Online

79.1k
Users

20.4k
Topics

149.2k
Posts