Recalbox 7.0

No Retroarch menu in FBNeo



  • Hi all, thanks for taking time to help me with this.

    I'm setting up a Recalbox image with the latest version (6.1) after using Retropie for a while (only because it had BT support back when Recalbox 4 did not).

    I'm struggling with this issue: when playing Neo Geo games, I can't access the Libretro menu with hotkey + B.

    I have already configured my 8bitdo controller, I can access Libretro when I'm playing NES, SNES, etc. but not a single hotkey combination works with Neo Geo games.

    I checked that my default emulator for the game is Libretro, FBNeo. I started with a clean gamelist.txt, I don't thinks this could be a ROM set version issue since I can play the games fine. I can also exit the game with hotkey+start with no issues.

    If I change the core to MAME2010 I can set up the dipswitch (to enable blood in Metal Slug for example) but I'm not sure if I'm missing on anything (performance, compatibility, etc) for not using the default recommended core.

    Update: playing around some more, I launched Cadillacs and Dinosaurs using libretro,fbneo and I can access the menu normally with hotkey+B
    I also noticed a difference in the loading screen: MetalSlug displays a yellow loading bar, Cadillacs and Dinosaurs doesn't.


  • CRT Hero

    @diegus83 said in No Retroarch menu in FBNeo:

    MetalSlug displays a yellow loading bar

    I might remember wrongly because i haven't used it for years, but iirc pifba displays a loading bar, which would mean you aren't using FBNeo-libretro, hence your issue.



  • You are right. FBNeo is selected as the emulator and there isn't an override set in the gamelist.xml but it is still launching the wrong core.

    I decided to move the roms to an usb drive, flash the sd and start again. I did a lot of testing of different options and I may have messed up some configuration somewhere, or corrupted my sd card.

    I copied the roms back in and now I'm getting a black screen in FBNeo but I will call that progress, I'm using the emulga romset for NeoGeo but I may need to try a different one set or bios file.

    Thanks for making it possible to bring all these amazing games back to life.


  • CRT Hero

    @diegus83 said in No Retroarch menu in FBNeo:

    I'm getting a black screen in FBNeo but I will call that progress

    Cyclone core option enabled ?
    Cpu clock > 100% ?

    A wrong romset/bios shouldn't be able to produce a black screen.



  • Interesting. I was getting a black screen with all the games I tried. I could access the RetroArch menu and try to load a new rom and I will not see any error messages, just a black screen and no sound.

    The roms/bios I was using I extracted from an RecalBox 6.0 image released by Warpgate. I like the game selection but I don't like the heavy modding done to the theme.

    I ended up deleting the neogeo.zip (1.4Mb) file from roms/neogeo and copied a new one under bios/fbneo

    The new one is 1.7Mb and can be found as part of a "RetroArch Full Bios Set" xxxxxxxxxxxxxxxx if anyone needs it.

    After doing that I tried about 10 games (including Metal Slug 1 through 5 and X) and they are working great. I can confirm they are launching in FBNeo and was able to access the soft dip menu to enable free play, blood, etc.


  • CRT Hero

    @diegus83 Thanks for the heads up, i was pretty sure a wrong bios would just close the game (so returning to ES) after a change i made a few months ago, or maybe RB is currently using an older version ? I'll look into this.



  • This post is deleted!

  • CRT Hero

    @diegus83 no need, i figured out the issue, i'm just not really happy with any of the possible workaround so i'll just keep in mind that a black screen in neogeo games can be caused when using a wrong neogeo.zip.



  • @diegus83 said in No Retroarch menu in FBNeo:

    "RetroArch Full Bios Set" on XXXXXX

    I', having a similar issue and could use some help.

    Tried with the BIOS from XXXXXXXXXX with no sucess (copied just neogeo.zip from it). I'm having the same black screen with the retroarch menu working. Other cores works for some ROMs.

    Do you have any other ideas?



  • @pepeu never mind

    editing the cyclone option did the trick for me!!!

    @barbudreadmon thanks a lot for that!


Log in to reply
 

Want to support us ?

159
Online

79.1k
Users

20.4k
Topics

149.3k
Posts