Gamecon SNES not working after 6.1 update

  • Hi everyone,
    Last week I updated recalbox to the 6.1 version.

    My main gamepad is a SNES one, wired to the GPIO ports and configured with gamecon.
    The configuration worked fine in the 6.0 version, but after the update, the controller is not detected in emulation station, and it is not listed when I put these commands in the shell:
    cat /proc/bus/input/devices
    ls /dev/input/js*

    What can I try in order to solve this?

  • Staff
    Global moderator

  • @acris said in Gamecon SNES not working after 6.1 update:


    soluce by Bkg2k :

    Hi acris, thanks for the quick help.

    I followed the instructions of that thread, and now it works as always! 😄

    These are the posts that I followed (I used Google translator to help me with the French 🙂 )
    @bkg2k said in 6.1 et manettes GAMECON:

    For those who want / can test:

    • Get the recalbox_settings file here: >!zNwXRSoQ!1y50jVuEF7rDZrRSC74zJCe7ZIaLJWiBpNPQJUjj4Oc
    • Mount the partition in writing: mount -o remount,rw /
    • Copy it to /usr/bin . To do this:
    • If you are on linux: scp recalbox_settings root@recalbox.local:/usr/bin/
    • If you are on Windows, copy it to \\recalbox\share , then connect to SSH, and type:
      cp /recalbox/share/recalbox_settings /usr/bin
      Restart your recalbox, and the GPIO mapping settings will be taken into account again

    @legui said in 6.1 et manettes GAMECON:

    Paaarfait !!! 😃
    Everything is working now!
    I specify for those who will try the manipulation, that it must first:

    • mount your root partition in writing (attention !!!)
    • back up your old file for security
    • copy the new file provided by @ Bkg2k
    • give the right to this new file
    • reboot the recalbox

    I do not specify how to do it, because that will not pose problems to those who know how to do, and will spare those who do not know to make a (big) co ** erie. For those here: be patient, the recalbox team is working hard to provide a fix as soon as possible! 😉
    Thank you again @ Bkg2k , do not hesitate if you need more tests!

    The right file permissions are set with this command:
    chmod 755 /usr/bin/recalbox_settings

Want to support us ?