Recalbox 6.1 image won't boot from EMMC on Odroid XU4

  • After upgrading to 6.1 from 6.0 through the GUI my system would not boot. No stalled video, no text, just blank screen for multiple hours. I decided to do a clean install instead and flashed the new image to my EMMC memory. Much to my surprise the same result. I checked my downloaded image against the hash and it was good, so I reflashed just to be sure. Still no joy. I reflashed an old 4.xx image to be sure my EMMC wasn't somehow corrupted during the process and everything went fine. Then just out of curiosity I flashed a micro sd card with the exact same 6.1 image that was not working on my EMMC. It hung on the spash video but I was able to SSH into the system and all appears well after disabling the splash video.
    I will continue to troubleshoot to the best of my ability here, but any insight would be appreciated. I prefer to use the EMMC if possible.

  • I also have this problem. For the time being, I have switched back to retropie...

  • Staff
    Global moderator

    It s a known bug.

  • Is there somewhere to download the 6.0 image. 6.1 has been posing too many challenges and my daughter needs to get her gaming fix.

  • I too am having the same problem. Black screen on boot and it's not getting an IP so I can ssh to either.

    I still had the older version on my computer. Just used it yesterday.

    Here is download link for you

  • Thank you thedarklord369. I have 6.0 back up and running. I also would like to thank all of the devs here for bringing us a wonderful piece of software. Although this update didn't go smoothly for me I appreciate your efforts in continuing to develop recalbox, and look forward to the next release. (Although I will be more diligent about saving install files from my working setup in the future.)

Want to support us ?