Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Roms sur NAS... configuration synology



  • Bonjour à tous,

    j'ai toutes mes roms qui sont stockées sur mon NAS Synology.
    J'ai bien copié les dossier "roms" et "saves" dans un dossier partagé du nom de "recalbox"
    J'ai suivi le tuto à la lettre du Wiki, au point de prendre strictement les mêmes noms de dossier et la même arborescence, mais ça ne fonctionne pas chez moi...

    Du coup je me pose la question de la configuration de mon NAS :

    • J'ai bien un utilisateur spécifique pour mon dossier recalbox qui possède les droits en lecture/écriture.
    • J'ai activé le partage Samba et NFS. Par contre j'ai mis pas mal de restriction sur le pare-feu et changer le port du SSH (mais je ne pense pas que celui-ci puisse avoir un rapport)

    Est-ce qu'il y a une configuration particulière de celui-ci à faire pour que le partage Samba fonctionne ou pas ?
    Sachant que depuis mon pc en Windows je n'ai aucun soucis d'accès aux fichiers présents sur mon NAS.

    Merci d'avance pour votre aide et encore désolé d'avoir une nouvelle question sur le NAS, car j'ai vu qu'il y en avait eu pas mal ici...



  • Peut être un problème de version de protocole smb...



  • @zetof mon NAS est configuré pour accepter "SMB2 et large MTU" au minimum et "SMB3" au maximum. Ce n'est pas bon ? il faudrait que je règle ça différemment ?



  • il faut peut être ajouter ",vers=2.0" à la fin des lignes de configuration dans les partages recalbox...

    mais bon, ce n'est peut être pas çà le pb...



  • @zetof j'ai essayé hier soir avec et sans, ça n'a rien changé... :-/

    je vais continuer de regarder ce soir en rentrant... mais je sèche un peu, c'est pour ça que j'en appelai à la communauté, au cas où :-)


  • Staff
    Moderator
    Team

    Tu devrais ptet essayer de redescendre en SMB2 tout court et d'ajouter ,vers=2.0

    Perso je suis resté en SMB1 par flemme et pour pas me couper du vieux matos, sachant que Window lui, négocie le SMB le plus haut de toute façon. Donc ce n'est pas forcement utile de réduire la plage du protocole utilisé.



  • J'ai eu ce même problème après la dernière mise a jour 6.0.
    Mes répertoires "Roms" "Share" "Bios" n'était plus accessible pour mon RP3.

    J'ai finalement fait un seul partage du répertoire "Share" qui contient "Roms, Save, Bios et d'autre répertoire et ça fonctionne très bien depuis cette modification de "recalbox-boot.conf"

    sharedevice=NETWORK

    sharenetwork_smb1=Share@192.168.xxx.xxx:Jeux/Share:username=xxx,password=xxx

    Je ne comprend pas pourquoi j'ai du faire cette modification mais qui chez moi a fonctionné.



  • J'ai testé vos solution et aucune n'a marché pour moi.
    J'ai désactivé le Pare-feu de mon NAS pour mes essais aussi au cas où.
    à chaque fois que je change une ligne de commande smb, je reboot le RPi et/ou j'essaye le "menu/Options de l'interface/Mettre à jour la liste des jeux" mais rien n'y fait... toujours pas de jeu... je désespère.

    J'ai tenté le NFS aussi au cas où, mais sans résultat...

    Je vous mets mes lignes de code au cas où, des fois que je sois vraiment mauvais et que j'ai mal écris une ligne, on ne sait jamais...

    sharedevice=NETWORK
    sharenetwork_smb1=ROMS@192.168.x.x:recalbox/roms:username=xxx,password=xxx,vers=2.0
    sharenetwork_smb2=SAVES@192.168.x.x:recalbox/saves:username=xxx,password=xxx,vers=2.0

    j'ai essayé aussi ça :
    sharenetwork_smb1=SHARE@192.168.x.x:recalbox/share:username=xxx,password=xxx,vers=2.0 (en modifiant évidemment mon répertoire sur mon NAS et en remettant les dossiers roms/bios/saves dans ce dossier share)

    et aussi ça :
    sharenetwork_nfs1=ROMS@192.168.x.x:recalbox/roms
    sharenetwork_nfs2=SAVES@192.168.x.x:recalbox/saves
    (j'ai activé le NFS sur le NAS et configuré l'interface de mon RPi sur le NAS en lecture/écriture)



  • Bon, problème apparemment résolu, du à un problème de mot de passe, j'ai remis un mdp faible et le montage s'est fait, j'ai bien retrouvé mes roms...


Log in to reply
 

Want to support us ?

Join us on :

296
Online

53356
Users

17793
Topics

133858
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.