Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Solved!] Cannot upgrade version after a few months



  • Hello everyone,

    I have been looking for a solution to the issue I am having, but none seems to appear.
    I have the 18.07.13 version and I cannot update it.

    I found out how to run some scripts to know what the problem is:
    bash -x /recalbox/scripts/upgrade/recalbox-upgrade.sh canupgrade

    + COMMAND=canupgrade
    + [[ -z canupgrade ]]
    + BINDIR=/recalbox/scripts/upgrade/
    + SYSTEMSETTINGS='python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc'
    + RECALBOX_SYSTEM_DIR=/recalbox/share/system
    ++ cat /recalbox/recalbox.version
    + INSTALLED_VERSION=18.07.13
    ++ cat /recalbox/recalbox.arch
    + ARCH=rpi3
    ++ python /usr/lib/python2.7/site-packages/configgen/settings/recalboxSettings.pyc -command load -key updates.type
    + UPGRADETYPE=stable
    + SERVICE_URL=https://recaleur-archive-prod.recalbox.com:9443
    ++ /recalbox/scripts/upgrade//../system/uuid.sh --uuid-file /recalbox/share/system/uuid
    + UUID=eecaedf4-1b47-42cf-9343-d43ff68c3319
    + [[ stable == \b\e\t\a ]]
    + [[ stable == \u\n\s\t\a\b\l\e ]]
    + '[' canupgrade == canupgrade ']'
    + [[ stable == \s\t\a\b\l\e ]]
    + /recalbox/scripts/upgrade//recalbox-canupgrade.sh --from-version 18.07.13 --service-url https://recaleur-archive-prod.recalbox.com:9443 --arch rpi3 --uuid eecaedf4-1b47-42cf-9343-d43ff68c3319
    curl: (6) Couldn't resolve host 'recaleur-archive-prod.recalbox.com'
    + exit 6
    

    If I try to enter the site http://recaleur-archive-prod.recalbox.com/ is not available.

    I saw that some people ran into the same trouble before. But I wonder if something changed between versions or if I have a bad configuration.

    Can anyone point me in the right direction?

    Thanks!


  • Staff
    Team
    Moderator
    Translator

    @rodri hi... it seems you‘ve missed our announcements and the fact that you can‘t upgrade from anything before version 6.0 (which is the current latest release). So you‘ll have to do a clean instsllation.



  • Try to a new install, because the upgrade don´t work online.

    Choose your hardware:

    https://archive.recalbox.com/

    Remember to backup your roms before to install a new version on sdcard to put again after.



  • @paradadf said in Cannot upgrade version after a few months:

    @rodri hi... it seems you‘ve missed our announcements and the fact that you can‘t upgrade from anything before version 6.0 (which is the current latest release). So you‘ll have to do a clean instsllation.

    I thought something like that might have been the issue. Thanks!

    @dam said in Cannot upgrade version after a few months:

    Try to a new install, because the upgrade don´t work online.

    Choose your hardware:

    https://archive.recalbox.com/

    Remember to backup your roms before to install a new version on sdcard to put again after.

    Yes, thanks for the reminder, I have both the roms and the theme to backup. I was trying to avoid that, because everything is on the same SD card.



Want to support us ?

264
Online

61749
Users

18638
Topics

140048
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.