Recalbox 7.0

Problem when adding new system to recalbox 6.0



  • Good companions, I followed a tutorial to add more systems to the recalbox in this case the SNES MSU- 1
    This being the line that I added

    <system>
    <fullname>SNES MSU-1</fullname>
    <name>snesmsu1</name>
    <path>/recalbox/share/roms/snesmsu1</path>
    <extension>.st .ST .smc .SMC .sfc .SFC .fig .FIG .zip .ZIP</extension>
    <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE% -ratio %RATIO% %NETPLAY%</command>
    <platform>snesmsu1</platform>
    <theme>snesmsu1</theme>
    <emulators>
    <emulator name="libretro">
    <cores>
    <core>snes9x</core>
    </cores>
    </emulator>
    </emulators>
    </system>

    All right up there, I appear in the MENU, the games also, in advanced configuration of the emulator also appear the "core"
    but when you give it "launch game" it pretends to load it but it returns me to the list of the games again. If I move the roms from snesmsu1 to snes if they work then it's not a problem for the roms ..
    I'm using recalbox 6.0 in RPI 3b +
    HELP 😞

    Pd: Translated from Spanish with google translator


  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 have you compared it with, for instance, satellaview entry on es_system.cfg? Satellaview should look like exactly what you need besides the names.

    I don‘t remember if you‘d need to explicitly force the core within recalbox.conf, otherwise configgen wouldn’t know what to do. But I suppose you could do it from the ES Menu.

    Which file extension does msu1 games use?



  • @paradadf With MSU-1 I made a clone of the SNES entry by varying fields like "snes" with "snesmsu1". it also happens to me with CPS
    I take this line as a reference

    ORIGINAL

    <system>
    <fullname>FinalBurn Alpha</fullname>
    <name>fba_libretro</name>
    <path>/recalbox/share/roms/fba_libretro</path>
    <extension>.zip .ZIP .fba .FBA .7z .7Z</extension>
    <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE% -ratio %RATIO% %NETPLAY%</command>
    <platform>arcade</platform>
    <theme>fba_libretro</theme>
    <emulators>
    <emulator name="libretro">
    <cores>
    <core>fbalpha</core>
    </cores>
    </emulator>
    </emulators>
    </system>

    CPS MODIFICADA

    <system>
    <fullname>CPS</fullname>
    <name>cps</name>
    <path>/recalbox/share/roms/cps</path>
    <extension>.zip .ZIP .fba .FBA .7z .7Z</extension>
    <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE% -ratio %RATIO% %NETPLAY%</command>
    <platform>cps</platform>
    <theme>cps</theme>
    <emulators>
    <emulator name="libretro">
    <cores>
    <core>fbalpha</core>
    </cores>
    </emulator>
    </emulators>
    </system>

    But it gives me the same result, it appears in the menu and in the list of games too. but when you give it a game, it does not load it.


  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 one step at a time. Please use the satellaview entry as a template for your snes msu1, as only the words „satellaview“ would need to be changed, nothing else.

    And try to force the core either from ES or directly editing recalbox.conf.



  • @paradadf Ok I'm going to do that. What line do I have to edit in recalbox.conf?



  • @paradadf The same symptom appears in the menu but does not load the games.
    they only work by modifying the systems already added.
    but keeping this line specific to any system.

    <name> *** </ name>

    Example.

    <system>
    <fullname>SNES MSU-1</fullname>
    <name><name>satellaview</name>
    <path>/recalbox/share/roms/snesmsu1</path>
    <extension>.bs .BS .smc .SMC .sfc .SFC .zip .ZIP</extension>
    <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE% -ratio %RATIO% %NETPLAY%</command>
    <platform>snesmsu1</platform>
    <theme>snesmsu1</theme>
    <emulators>
    <emulator name="libretro">
    <cores>
    <core>snes9x</core>
    </cores>
    </emulator>
    </emulators>
    </system>


  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 you must change the name too (snesmsu1). That line looks weird though... it starts with something double; you must have copied it wrongly.

    Which extension do msu1 games have? What’s the launcher? You‘ll need to change that too.

    What happen when you edit metadata on the gane you want to start and you try to force the emulator and core to libretro and snes9x respectively?

    If the previous steps don‘t work, try adding the following lines to recalbox.conf:

    snesmsu1.emulator=libretro
    snesmsu1.core=snes9x
    

    Double-check those lines are only present once in recalbox.conf.



  • @paradadf something like this appears

    Configurations generated by Recalbox

    snesmsu1.emulator=libretro
    snesmsu1.core=snes9x
    snesmsu1.flatfolder=0
    snesmsu1.sort=0


  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 that looks good.



  • @paradadf But still, the games do not load me. I mean if I move the roms from snesmsu1 to snes if they work. or from cps1 to fba_libreto also work.




  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 did you correct the name? And for the third time... which file extension do the msu1 games use?



  • @paradadf thank you very much for the time spent 🙂 I could solve it, just reinstall recalbox again and start with the process from scratch. now if I load the games in the separate system "SNES MSU-1"


  • Developer
    Team
    Global moderator
    Translator

    @jaimebm1229 glad it worked. Have fun playing!



  • @jaimebm1229 Can you demonstrate how you did to add the system? thx



  • @paradadf said in Thanks again 🙂



  • @ricardo-dicky
    I did a clean install of recalbox
    Use the putty program to stop recalbox

    IP: ***
    Login: root
    Password: recalboxroot

    Stop or start Emulationstation
    /etc/init.d/S31emulationstation stop
    then enter
    mount -o remount, rw /

    then run WinSCP

    IP: ***
    Login: root
    Password: recalboxroot

    get on the route
    /recalbox/share_init/system/.emulationstation
    and extract to the PC es_systems.cfg
    create the systems you want to add
    and copy it on this route
    /recalbox/share/system/.emulationstation

    last since putty starts recalbox

    Start start Emulationstation
    /etc/init.d/S31emulationstation start

    Possibly this badly written since I use the translator 😞



  • @jaimebm1229 thx man... 😉



Want to support us ?

126
Online

79.1k
Users

20.3k
Topics

149.0k
Posts