Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Non officiel] Recalbox PC x86_64 avec les drivers Nvidia !!


  • Banned

    @biboucover tu as reconfiguré ta manette dans EmulationStation ?


  • Staff
    Moderator
    Netplay

    @biboucover merci pour ton retour comme a dit voljega a tu bien configurer ta manette?
    si le problème persiste merci de faire une archive support de ta recalbox ça se passe dans le web-manager tu lance quelque jeu avant même si il ne ce lance pas.



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    @chris256 very good !!!
    you have a little more detail on the performance of your pc? how to operate the menu before and after for granted I test on a game of gamecube kind zelda wind waker thank you very much for your test and back

    OK. I'll try to test it this week-end and give feedback here.



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    @chris256 very good !!!
    you have a little more detail on the performance of your pc? how to operate the menu before and after for granted I test on a game of gamecube kind zelda wind waker thank you very much for your test and back

    Hello ! So I tried to do the performance evaluation that you asked.

    When I do the first start, I end up to a black screen. Here is what I get from the log: lvl0: Error creating SDL window! Couldn't find matching GLX visual and here is the complete log.

    At the black screen, I login via ssh, edit the file to allow nvidia driver and reboot. Now ES starts well.

    About the fluidity in menu, it is perfect. I also tested Mario Sunshine. It is very fluid, even setting internal resolution to 1080p (3x).

    However I have a big issue when launching retroarch-based games (as the nes or snes games available in realbox such as 2048 for nes): loading time is of about 20 seconds with black screen. Then the game seems to work fine. Quite strange. Did you encounter this issue?

    Do you plan releasing a new version based on latest beta? Or maybe do you wait the final release of recalbox for compiling a new version? Or may it be directly included in official final version?

    Please tell me if you need more information.

    PS: my card is an nvidia 750Ti.

    Thanks!


  • Staff
    Moderator
    Netplay

    @chris256 hello then in a first time you will connect in ssh to create a conf file for nvidia what will theoretically solve the problem of GLX
    once connect in ssh tape this:

    nano / usr / share / X11 / xorg.conf.d / 50-card.conf

    you add this:

    Section "device"
    Identify "card0"
    Driver "nvidia"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    in a second temp checked this:
    ls /usr/lib/xorg/modules/extensions/libglx.so*
    you must have two files in this directory one libglx.so and one libglx.so.410.73
    if the command rolls back file not found
    type this command:
    cd /usr/lib/xorg/modules/extensions/
    ln -sf libglx.so.410.73 libglx.so



  • Thanks @strodown for your reply! I don’t have access to the TV right now but I’ll try later. Just to be sure: do I have to reinstall and at the first boot do the ssh manipulation that you described or should I just do it on the existing install on which nvidia driver is activated? Also, is the purpose to make it work without nvidia driver enabled or to solve the long black screen when launching games?


  • Staff
    Moderator
    Netplay

    @chris256 the goal is to correct the concerns and to keep the diver nvidia it is not necessary to redo an intallation you can modify since the installation already existing
    ps: the first command has spaces
    nano /usr/share/X11/xorg.conf.d/50-card.conf



  • @strodown said in Recalbox PC x86_64 avec les drivers Nvidia !!:

    /usr/share/X11/xorg.conf.d/50-card.conf

    Hello again. The file /usr/share/X11/xorg.conf.d/50-card.conf does not exist. Do I create it?


  • Staff
    Moderator
    Netplay

    @chris256 yes



  • @strodown It seems that this folder is read only (nano says [ Error writing /usr/share/X11/xorg.conf.d/50-card.conf: Read-only file system ]). I tried mount -o remount, rw /usr/share/X11 but I have error mount: mounting rw on /usr/share/X11 failed: Invalid argument (sorry I am not very skilled at this)



  • @chris256 Sorry, mount -o remount,rw / did the trick


  • Staff
    Moderator
    Netplay

    @chris256 nn only mount -o remount, rw /


  • Staff
    Moderator
    Netplay

    @strodown no pb



  • @strodown I also confirm that file libglx.so.410.73 is missing so I dit the instruction that you asked. I am rebooting right now...



  • @strodown After reboot I have Booting Recalbox forever on screen so I rebooted in verbose mode and I have xinit : giving up unable to connect to X server: Connection refused server error. Here is the log.

    In the directory I have those files:
    lrwxrwxrwx 1 root root 16 Jan 20 20:49 libglx.so -> libglx.so.410.73
    lrwxrwxrwx 1 root root 29 Nov 22 14:17 libglxserver_nvidia.so -> libglxserver_nvidia.so.410.73
    lrwxrwxrwx 1 root root 29 Nov 22 14:17 libglxserver_nvidia.so.1 -> libglxserver_nvidia.so.410.73
    -rw-r--r-- 1 root root 14997128 Nov 22 16:14 libglxserver_nvidia.so.410.73


  • Staff
    Moderator
    Netplay

    @chris256 delete the 50-card.conf file I can not help anymore because libglx.so.410.73 is not present in this driver version. desolate for the moment it will be necessary to wait the time that I create the new image on the last beta in date still thanks for your tests



  • @strodown OK. Top bad. I’’try to check this topic regularly. If I can be of any help, please tell me!



  • Un grand merci à toi strodown...super taf !

    Pour ma part je suis agréablement surpris du résultat vu ma config :

    CM : MSI X399 SLI Plus
    CPU : AMD Threadripper 1900X
    RAM : 4x8Go Corsair Vengeance LPX 3200Mhz
    GPU : EVGA GeForce 1060 6Go

    J'ai peu le temps de tester ce soir mais j'affiche ES sur ma TV sans problème, pas de lenteur...et les petits plus de la bêta avec la nouvelle manette reconnue pour configuration immédiate. Il n'y a plus le bug du clavier invisible. Pour le moment RAS...c'est mon fils qui va être heureux :)


  • Staff
    Moderator
    Netplay

    @zeke good job merci du retour comme jeux test je propose zelda wind waker sur game cube
    si tu peut vérifier si les FPS sont stable il faut activer l’option dans le menu de dolphin hotkey et R2



  • Bonjour à tous,

    Malgré le petit souci détaillé plus haut pour les systèmes sous retroarch, j'ai continué à investiguer côté gamecube et je me suis rendu compte qu'avec ma config actuelle (AMD Phenom II 965 et carte graphique Nvidia 750Ti), j'ai des ralentissements importants par moments (qui se traduisent notamment par des micro-coupures dans le son). Changer la résolution n'a aucun effet (c'est pareil en résolution native ou en 1080p), ce qui me ferait penser que c'est dû au processeur, qu'en pensez-vous ?

    En cherchant un peu, j'ai vu que pour 70 euros je pourrais, sans changer de carte mère, passer à un AMD-FX-8350. Pensez-vous que dans ce cas les jeux gamecube passeraient sans problème ? À moins qu'il vaille mieux à l'heure actuelle carrément changer aussi la carte mère ?

    Voici un lien pour un comparatif entre ces CPU.

    Je suis preneur de tout conseil.

    Merci d'avance !



Want to support us ?

274
Online

58885
Users

18423
Topics

138605
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.