Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Testers wanted: major system upgrade (Pi3b+, KODI 17 and much more ...)

  • Staff

    Picodrive est par defaut car il est fonctionnel sur toutes les boards notamment moins puissantes que rpi3 ou genesis posé des problemes
    Perso sur ttes les roms testés sur picodrive jai pas eu de probleme de son

  • @jass76 Ca me fous la rage, d'essayé des milliers de fois, pour finir en ecran noir et led rouge! A chaque fois après etcher, ou win32, il me dit 1 ou 2 fois, formater partition machin, j'annule, et je lance le raspberry et rien....

  • Staff

    @alex592 Il ne sert a rien de flasher X fois si le resultat est le même ;)
    Il est possible que ta SD soit abimée. Un test avec une autre SD serait plus constructif.
    Et pour la Xieme fois:

    • Formatter une SD avant de la flasher avec Etcher ne sert strictement à rien hormis à l'user un peu plus. Le flash écrase tout ce qu'il y a sur la SD, y compris les partitions et les formattages précédents.
    • Il est normal que windows demande de formatter après le flash, puisque le flash va écrire une partition avec un systeme de fichier non reconnu par windows. Bien entendu, il ne faut surtout pas formatter :)

  • @acris
    Ne pas tenir compte de ce que j'ai écrit sur picodrive, il semblerait que ce soit genesisplus qui bug/"ajoute" des sons parasites sur certaines roms (outrun master system), que je prenais pour des sons d'ambiance manquants.

  • Hi,

    I was playing around with the christmas beta on my RPI3B+, trying to load some kodi addons, I got the error with twitch:
    ffmpeg[5ECEE3E0]: https protocol not found, recompile FFmpeg with openssl, gnutls or securetransport enabled

    Not sure if I missed something somewhere.

  • @voljega Pour l'instant, le seul effet de bord est sur la gestion des mises à jour que j'ai désactivé. Cela fonctionne plutôt bien pour mon utilisation.

  • Salut,
    Problèmes rencontrés avec RPI3B+ et version Xmas:

    • Roms Dreamcast ne fonctionnent plus (fonctionnaient avec la version Beta précédente)
    • Scrapping ne marche plus
    • un fichier gamelist.xml.xml (double extension) apparait dans les dossiers roms (le fichier est rempli avec beaucoup de ligne vides puis quelques noeuds xml pour finir.
      Merci pour votre boulot. Vivement la stable !

  • Bonjour à tous

    je tente de configurer la NeoGeo CD sur la version Beta sortie à Noël.

    J'ai créé un dossier neogeocd dans le dossier Roms, ai placé les bios neogeo.zip et neocdz.zip dans le dossier bios.

    Rien n'est détecté. Mes jeux sont au format chd, aussi je me pose la question : est-ce que mon paramétrage est foireux ou alors est-ce le format de fichiers qui n'est pas bon ?

    Quelqu'un pourrait-il me donner quelques pistes ?

    Merci d'avance et meilleurs voeux à tous :)

  • Hi, and thanks a lot for this awesome work.

    Here's my configuration :
    Board : PI 3B+
    Version : 2018.12.24.Christmas.Beta
    SSD : 8GB
    HDD : 1TB
    AC : Official Raspi (2.5a) - I never have any lightning.

    Bugs reported so far :

    • Impossible to connect a Xbox One V2 (BT compatible) gamepad. It loads infinitely, and the pad stops itselfs. The system stays stuck on trying to connect.
    • Impossible to connect a PS4 gamepad. It loads then says "impossible to connect". This pads works without any problem on my Pi 3B with the stable version of July.
    • System freezes when I try to delete a game from the interface.
    • If I delete games coming with the release (i.e. DOOM), it comes back after a while. I tried through network and through the interface
    • Sometime, crashes when I unplug a pad connected with USB.
    • The bug on Nes stills here. I need to modify the retroarch config file to avoid cropped image.

    Hope this will help ! Thanks again !

  • Hi,
    Board PI 3B+
    Version : 2018.12.24.Christmas.Beta
    i'm trying to upload dreamcast bios
    with md5sum on recalbox
    e10c53c2f8b90bab96ead2d368858623 dc_boot.bin
    0a93f7940c455905bea6e392dfde92a4 dc_flash.bin

    but when i'm connecting on web interface for bios management I have
    dc_boot.bin e10c53c2f8b90bab96ead2d368858623 with ok tick
    dc_flash.bin d6e11a23f1fa01cddb5dfccf7e4cc8d7 with wrong tick

    this is not the same md5 but the dc_flash is good, i made a md5 before uploading it to recalbox and after and it's still 0a93f7940c455905bea6e392dfde92a4. Maybe a false positive on web interface ?
    But games doesn't start

    thanks !

  • Hey,
    My little feedback regarding this beta:

    • I had a hard time figuring out how to link my PS4 controller with the Recalbox. The solution was to unpair from the PS4 (go to settings, devices, then find your controller and unpair + delete it from another controller. Actually it's good to leave the console plugged so you will be sure that the controller is completely forgotten if when pressing PS button console doesn't turn on) before reseting and pair with Recalbox.
    • Wifi is working but super long (like 1'30) when SSID+key are entered and you close the menu
    • Ethernet is not working, I checked the wire, it's ok. Even with Kodi it's not recognized.

    Tested on:
    RPI 3 B +
    Samsung EVO Plus memory card 128GB
    BERLS Micro USB 5V 3000mA

  • @lexx @dalittlebosssam @kara45 I've got same issue for kodi even if you use "nfs" or "upnp" to select your storage.
    I tried first "upnp" but scrapping wasn't possible (the panel to select "The Movies Database" wasn't display)
    So I switched on a "nfs" share. Scrapping was available and start but crashed when finish.
    SSH connection is ok from my side.
    Using : RPI 3b+, 2018.12.24 Christmas.Beta, Powersupply 5V/3A, X-Box one wired pad,NAS Synology to mount "share"

  • @caxelair

    Thanks a lot for the tip, it worked for my PS4 controller ! I paired it back to my PS4, then forget it, and now it's working back on the 3B+ !

  • Staff

    @caxelair @Apoc

    all controllers used on other devices MUST be reset, it's not a bug, it's not an recalbox's issue but a user's issue

  • @apoc Happy to help mate ;)

    Btw, it worked on my v1 PS4 controller, don't know if yours was a v1 or a v2 (check if you have a light bar above the touch button, if yes v2)

    @acris sure, we know but in the tuto it's not specified. Plus, I never said it was a bug ;)
    So for you to be aware that the reset buton doesn't unpair all the time. ;)

    Edit: This 4min limit between 2 posts is a pain :'(

  • @acris I hadn't any problem with the PI 3B when I did that. Only the 3B+ had this issue. I always used the reset button back of the pad to do it.

    @caxelair both are V2 pads it seems !

  • @apoc Wonderful, so it works for both versions ;)
    Thanks for your feedback.

  • As I can't edit my original post, here some new feedback:

    • the scraper is not working which is quite frustating because we have the confirmation screen that everything is OK
    • GB/GBC/MD/NES/SNES are super smooth
    • n64 a bit laggy (on Super Smash Bros)
    • no lag with the ps4 controller

  • Hello. Great work! I love my Recalbox🕹. Why it takes much longer than other retrogaming systems for a stable release for RP3b+? Or is it a complete revision of all code, not just only for the RPI3B+ compatibility? 🤔

  • @caxelair I only tried PSX games, mostly FF7, and I had some "little" problems of pad freezing, hotkey button changing the shaders every time I pushed it etc. All that happened only after using the retroarch menu for configuration.

Want to support us ?





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.