Recalbox 7.0

Can't get IPAC 2 to work properly



  • Hi folks,
    I've been building myself a full size cabinet which uses a Pi 2 using the latest Recalbox 18.04.20. For controls I'm using an IPAC 2 (2 players with each 6 buttons) and a USB gamepad.

    I configured the IPAC like in the keyboard encoder wiki meaning:

    • created the empty files via SSH
    • set controllers.xarcade.enabled=1

    Inside Emulationstation the buttons and sticks work just fine. I can select 2 Ipac controllers inside the settings. I configured the buttons via the controller setup and it all works like it should. Inside a game however... it doesn't.

    My example would be Metal Slug running on fba libretro. I boot up the game and can't insert coins (which would be select). Also the hotkey isn't working so I can't access retroarch's settings. However I can exit by pressing 2 specific buttons (select P1 and P2) at the same time.

    If I use the USB pad it works fine (though I have to switch P1 controls to the gamepad inside Emulationstation for this to work). And if I use this to configure the buttons via the retroarch menu (hotkey + b) it also works. Until I exit the game at which point it forgets all the settings I made.

    Is there something I missed? I searched this forum far and wide but couldn't find anything that helped me.
    I even checked the button configuration using the winipac configuration tool. All the buttons I use are set to the same keys as listed here: https://github.com/recalbox/recalbox-os/wiki/Keyboard-encoder-configuration-(EN)

    It drives me nuts... I hope you guys can help me.


  • Banned

    @nightfall Revert to default configuration with WiniPAC.
    (Don't mind the tab about key configuration)
    Also be sure to try the two possible names for the empty files.



  • I tried it with the default configuration as well (the only thing I actually had to switch was the hotkey and start for P1) and I also created both empty files. Though none of it worked


  • Banned

    @nightfall did you also configure your control in Emulation Station ?



  • Yeah I did. Though if I try to configure it by "Hold a button on the controller" it just says keyboard. So what it ultimately does it overwrites the config if I try to set up both player 1 and 2.

    Though even if I configure player 1 (as stated above) it just works inside Emulation Station.


  • Banned

    @nightfall hmmm strange, from what I remember I had connected a pad, got to the configuration menu with it and configured the ipac from there, but it is still on a old version of recalbox (pre 4.0)



  • As I said, the pad works perfectly fine. It's just the keyboard encoder that troubles me. And it's driving me insane.



  • So nobody got any more ideas?



  • @nightfall need a support archive



  • @substring sure thing. I uploaded one at https://www91.zippyshare.com/v/KBRzoos5/file.html

    I tried again over the weekend but I can't get it to work. Tried a SNES game for a change but still no luck. Won't respond to any input.
    Hope you can help?



  • @substring I take it all back. Finally figured out what was wrong.
    Somehow I screwed up the touch and created multiple files which I couldn't delete. Once I cleared the folder and created a new file for me input it finally worked.
    Thanks anyway 😉



  • @nightfall freat ! the wiki is not that bad afterall 🙂



Want to support us ?

168
Online

79.1k
Users

20.4k
Topics

149.3k
Posts