Problème avec Nespicase+...



  • Bonsoir à tous !

    Alors voici mon petit problème : je possède un boitier Nespicase+ et un rpi3. J'ai installé sur ma SD la dernière version de recalbox (18.04.20) et le but est de faire les bonnes fonctionnalités des boutons de la nespicase+ (on/off et reset) et c'est là que je cale :

    Je branche la prise d'alimentation, recalbox se lance (d'ailleurs j'adore les intros console "made in recalbox", bravo au passage), je lance un jeu au hasard donkey kong classic sur la Super Nintendo (jeux par défaut dans le répertoire SNES).

    Voici mes manips et résultats :

    • J'appuie sur la touche Reset du nespicase+ (appui court), rien se ne passe alors que je pensais reseter le jeu.
    • J'appuie sur la touche Reset du nespicase+ (appui long), recalbox redémarre et pour moi c'est logique.
    • Dans le menu principal, bouton Power enfoncé (logique puisque je l'ai allumé), j'appuie sur ce même bouton pour éteindre proprement (faire comme un quitter/éteindre le système), rien ne se passe.
    • J'appuie à nouveau sur Power et là Recalbox s'éteint mais bon mon Power est enfoncé comme allumé quoi, pas logique.

    Que dois je faire pour allumer normalement mon nespicase+ et donc lancer recalbox, l'éteindre correctement avec le bouton power du nespicase+ ??

    Question identique pour le bouton reset à savoir reseter en plein jeu (appui court) sachant que l'appui long fonctionne (recalbox redémarre).

    Merci d'avance et merci de m'avoir lu.

    Edit : je laisse la partie de mon fichier recalbox.conf que j'ai actuellement.

    ;system.power.switch=ATX_RASPI_R2_6
    ;system.power.switch=MAUSBERRY
    ;system.power.switch=REMOTEPIBOARD_2003
    ;system.power.switch=REMOTEPIBOARD_2005
    ;system.power.switch=WITTYPI
    ;system.power.switch=PIN56ONOFF
    system.power.switch=PIN56PUSH
    ;system.power.switch=PIN356ONOFFRESET
    system.power.switch=PIN356PUSHRESET

    Pour infos, il y a un interrupteur sur un des PCB de la nespicase+ "SAFE SHUTDOWN switch" il était par défaut sur OFF, je l'ai mis sur ON (fallait le faire ou pas ???)



  • Hello retitouille

    Techniquement cela doit fonctionner, mais d'après le GitHub de retroflag il faut l’installation d’un script tiers supplémentaire.

    https://github.com/RetroFlag/retroflag-picase



  • @zokho salut,

    Ce sujet m'intéresse. Cela signifie qu'il est possible d'utiliser les boutons on/off et reset du boitier nesPi avec recalbox sans modification hard ? Merci



  • @b0bba oui j'ai solutionné le problème.



  • Bonsoir,

    Alors merci à ceux qui m'ont répondu et particulièrement un grand merci à un membre de la team recalbox qui m'a répondu sur Facebook via Messenger. Voici la manip pour qui ça intéresse :

    Normalement votre recalbox redémarre et les boutons de la nespicase+ sont fonctionnels.

    Pour ma part, j'ai lancé un jeu, appui sur RESET : recalbox redémarre ==> OK.
    Bouton POWER, ça éteint proprement recalbox ==> OK.

    Merci encore à la team recalbox pour l'aide apportée.



  • @retitouille tu n'as fais aucune modification hard ? Pas de soudure, pas de modifier de câblage gpio ?

    J'ai un boîtier nespi et je souhaite pouvoir utiliser le bouton réset pour faire un redémarrage propre


  • Moderator

    @retitouille said in Problème avec Nespicase+...:

    Bonsoir,

    Alors merci à ceux qui m'ont répondu et particulièrement un grand merci à un membre de la team recalbox qui m'a répondu sur Facebook via Messenger. Voici la manip pour qui ça intéresse :

    Normalement votre recalbox redémarre et les boutons de la nespicase+ sont fonctionnels.

    Pour ma part, j'ai lancé un jeu, appui sur RESET : recalbox redémarre ==> OK.
    Bouton POWER, ça éteint proprement recalbox ==> OK.

    Merci encore à la team recalbox pour l'aide apportée.

    ==> finalement, il suffisait juste de lire le mode d'emploi fourni avec le NesPi Case+, en somme... ;-)
    (c'est moi qui t'ai aidé sur FB)



  • @b0bba aucune modif hard, ni soudure, ni modif dans le fichier recalbox.conf faire uniquement la manip que j'ai décrit plus haut.



  • @fab2ris en gros oui lire le petit papier fourni avec le nespicase+ bon pour la partie putty je ne savais pas donc tu m'as bien aidé quand même donc merci beaucoup.


  • Themer

    @b0bba said in Problème avec Nespicase+...:

    J'ai un boîtier nespi et je souhaite pouvoir utiliser le bouton réset pour faire un redémarrage propre

    attention c'est valable pour le nespicase+, pas pour le premier nespicase



  • @voljega said in Problème avec Nespicase+...:

    @b0bba said in Problème avec Nespicase+...:

    J'ai un boîtier nespi et je souhaite pouvoir utiliser le bouton réset pour faire un redémarrage propre

    attention c'est valable pour le nespicase+, pas pour le premier nespicase

    Ah mince c'est pour ça que je je pigeais pas. On est OK que pour le premier nespi, ça ne fonctionnera pas sans modif ?


  • Themer

    @b0bba je ne suis pas un spécialiste du sujet mais oui sur le premier d'après ce que je me souviens avoir lu ici, il y a une modif hardware obligatoire je crois


  • Moderator

    @voljega said in Problème avec Nespicase+...:

    @b0bba je ne suis pas un spécialiste du sujet mais oui sur le premier d'après ce que je me souviens avoir lu ici, il y a une modif hardware obligatoire je crois

    Qui est franchement pas facile à faire quand on sait à peine manier un fer à souder...



  • j'ai réussi a faire marcher les boutons power et reset , mais dès que je met le clé usb en facade cela ne marche plus , pourquoi ?



  • @recalfred , tout est rentré dans l'ordre, il suffisait d'aller dans le recalbox conf avec la cle usb de connectée.



  • Je up pour l'auteur: ou as tu acheté ton boitier Nespicase+?



  • @mydriaze said in Problème avec Nespicase+...:

    Je up pour l'auteur: ou as tu acheté ton boitier Nespicase+?

    Salut !

    Mon nespicase+ je l'ai acheté sur kubii.



  • @retitouille said in Problème avec Nespicase+...:

    kubii
    Super, merci! J'ignorais qu'ils en vendaient!



  • Bonjour,

    Je viens de recevoir mon nespicase plus.
    J'ai dans un premier temps lancer le script depuis un ssh putty AVANT de switcher sur la PCB le safe shutdown a ON...
    J'ai donc arreter mon PI mis le safe shutdown à ON et relancer
    wget -O - "https://raw.githubusercontent.com/RetroFlag/retroflag-picase/master/recalbox_install.sh" | bash
    Mais cela ne fonctionne pas, le reset ou le power n'a aucune action :(

    Si quelqu'un a une idée ?

    Merci


  • Moderator
    Team

    Le nespi+ sera intégré proprement à la prochaine release de recalbox


Log in to reply
 

Want to support us ?

Join us on :

489
Online

26163
Users

13542
Topics

102744
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.