x64 system running 18.04.20 doesn't work too well



  • I recently upgraded from 18.03.30 to 18.04.20 and I have 3 main issues:

    • No sound - volume always resets to 0 and my HDMI card selection resets to Auto
    • No storage - everytime I use WinSCP to load something I'm told I'm out of memory
    • Crashes - Plagued with crashes surrounding keyboard and usb controller. Regularly the devices don't work on power up and when they do (or i unplug them and reneter them) on the very first key press i get Booting 'Recalbox' screen which never goes away

    My system is a 64bit core 2 DUO (E6750) with a GT710 and 4GBs of RAM, 3TB HDD

    Because of issue 2 above I would like to roll back to 18.03.30 but I can't find a compiled recalbox.img.xz to download - any ideas?


  • Moderator
    Team

    @shamanmogz your only problem is that your share device is not detected, which seems confirmed by both 1st issues. Can you mae a support archive ?



  • @Substring

    I tried running the script in WINSCP's console and got the following:

    /recalbox/scripts$ /recalbox/scripts/recalbox-support.sh
    /recalbox/scripts/recalbox-support.sh: line 43: lsmod: command not found
    /recalbox/scripts/recalbox-support.sh: line 50: ifconfig: command not found
    /recalbox/scripts/recalbox-support.sh: line 59: blkid: command not found
    BusyBox v1.25.1 (2018-04-20 08:03:10 UTC) multi-call binary.

    Usage: rm [-irf] FILE...

    Remove (unlink) FILEs

    -i	Always prompt before removing
    -f	Never prompt
    -R,-r	Recurse
    

    Unable to init SDL: No available video device
    /recalbox/share/saves/recalbox-support-20180428220047.tar.gz

    I'm not very linux savy so apologies if i'm missinng something obvious



  • @Substring

    I used the web base manager to run the script : https://file.ac/HUuSHVBzgdE/


  • Moderator
    Team

    @shamanmogz as i thought : it couldn't find the share on your hard drive



  • @Substring

    I'm not sure what you mean by that - or more importantly I'm not sure how to fix it.

    As far as I know it was working in 03.30 for a few weeks, I was playing a few roms - then the update started making it act up. I did a fresh image burn using etcher on the hard drive (internally attached on another PC). The fresh burn of the image was done in the exact same way as the first time. Why would this version loose the share on the hard drive?


  • Moderator
    Team

    @shamanmogz the joys of x86, a much more complex architecture than a raspberry pi ...i could suggest you test a script i planned to upgrade which i supposed to solve such problems



  • @Substring I'm happy to run any scripts for you providing i can run them using WINSCP's console (or i can try PUTTY)



  • @Substring I'm at home this evening if you have any scripts you want me to run.


  • Moderator
    Team

    @shamanmogz Run a SSH shell and :

    mount -o remount, rw /
    wget -O /recalbox/scripts/recalbox-part.sh https://gitlab.com/recalbox/recalbox/blob/c251d7eb56c5d12622c5189e48d23dc9ec79775b/board/recalbox/fsoverlay/recalbox/scripts/recalbox-part.sh
    

    Then type reboot. Once rebooted, change the language to something different than english or just check the available size in system options and report back. I won't be online this evening



  • @Substring Thanks for helping out, I appreciate your fit this in around your other life duties.

    I tried the commands as requested:

    Using username "root".
    root@recalbox's password:

    mount -o remount, rw /

    wget -O /recalbox/scripts/recalbox-part.sh https://gitlab.com/recalbox/recalbox/blob/c251d7eb56c5d12622c5189e48d23dc9ec79775b/board/recalbox/fsoverlay/recalbox/scripts/recalbox-part.sh

    --2018-04-30 20:28:13-- https://gitlab.com/recalbox/recalbox/blob/c251d7eb56c5d12622c5189e48d23dc9ec79775b/board/recalbox/fsoverlay/recalbox/scripts/recalbox-part.sh
    Resolving gitlab.com... 52.167.219.168
    Connecting to gitlab.com|52.167.219.168|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: '/recalbox/scripts/recalbox-part.sh'

    /recalbox/scripts/r [ <=> ] 33.10K --.-KB/s in 0.006s

    2018-04-30 20:28:14 (5.63 MB/s) - '/recalbox/scripts/recalbox-part.sh' saved [33898]

    Sadly even after a reboot (via command or by making a change to the language causing a reboot) it did not work.

    Something that is interesting - I have noticed that the SHA-256 and MD5 for the WINSCP connection changes after every reboot - but i guess this is to be expected if it's a new live instance running every time.



  • @substring ok my bad - i didn't realise that the commands you gave me wouldn't run the script as well.

    Using the commands:

    • cd /recalbox/scripts
    • chmod +x /recalbox/scripts/recalbox-part.sh
    • sh ./recalbox-part.sh

    I get the following:

    ./recalbox-part.sh: line 1: syntax error near unexpected token newline' ./recalbox-part.sh: line 1:<!DOCTYPE html>'

    This looks like the wget did something wrong (or i did), so I followed the link to get the correct .sh file and using vi edited the recalbox-part.sh above. I now end up with:

    ./recalbox-part.sh <boot|system|share_internal|prefix x|previous x>
    boot: the recalbox boot partition
    system: the recalbox system partition
    share_internal: the recalbox share internal partition
    prefix x: the disk of the partition x (without the partition number)
    previous x: the partition before x on the same disk

    I think this is far as i can go without more help (i have 1% linux skill)


  • Moderator
    Team

    @shamanmogz damn i should have hit the "download" button for the link



  • @Substring need me to run it again or slightly differently?


  • Moderator
    Team
    Moderator
    Translator



  • @Substring & @paradadf I re-ran the scripts augmenting the commands from my previous attempt and got the following results:

    # sh ./recalbox-part.sh boot
    /dev/sda1
    # sh ./recalbox-part.sh system
    /dev/sda2
    # sh ./recalbox-part.sh share_internal
    /dev/sda3

  • Moderator
    Team

    @shamanmogz it should be fine by now



  • @Substring

    Afraid not, I tried making a change as you suggetsed and rebooting the machine, but still I get Storage N/A and settings don't persist.



  • @Substring I've listed my drives and get:

    # cat /proc/mounts
    proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
    sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
    none /dev devtmpfs rw,relatime,size=1978844k,nr_inodes=494711,mode=755 0 0
    /dev/sda2 / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
    devpts /dev/pts devpts rw,relatime,gid=5,mode=620,ptmxmode=000 0 0
    tmpfs /dev/shm tmpfs rw,relatime,mode=777 0 0
    tmpfs /tmp tmpfs rw,relatime 0 0
    tmpfs /var tmpfs rw,relatime 0 0
    tmpfs /run tmpfs rw,relatime 0 0
    tmpfs /recalbox/share tmpfs rw,relatime,size=131072k 0 0
    /dev/sda1 /media/usb0 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=utf8,shortname=mixed,flush,errors=remount-ro 0 0
    

    or:

    # blkid
    /dev/sda2: LABEL="RECALBOX" UUID="3638b519-b279-4f9a-981c-cce4de83472f" TYPE="ext4"
    /dev/sda1: LABEL="BOOT" UUID="7DD8-6D51" TYPE="vfat"
    


  • @substring If it's easier I'm happy to roll back to 18.03.30 and wait for the next release for this fix



Want to support us ?

Join us on :

205
Online

27395
Users

14103
Topics

106974
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.