Problem with recalbox on pi3 via NOOBS



  • I have just installed debian and recalbox , on pi 3 . As the debian boots correctly , recalbox doesnt boot at all and my monitor goes off while it boots , it means it gets no sygnal .
    What should i do
    Bellow my configs :
    recalbox-boot.conf:

    sharedevice=INTERNAL
    global.videomode=default

    config.txt:

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    comment to get jack audio

    #hdmi_drive=2

    Using /etc/modules is deprecated and no longer supported on 4.4 kernel

    So manually enable audio

    dtparam=audio=on

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    #hdmi_force_hotplug=1

    uncomment for composite PAL

    #sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    #avoid_safe_mode=1
    disable_overscan=0
    overscan_scale=1
    sdtv_mode=2
    hdmi_group=1
    hdmi_mode=16

    any suggestions ?



  • @xristoskon have you tried our img ?



  • no cause i want multi boot system , have u got an multi image ?





  • @xristoskon said in Problem with recalbox on pi3 via NOOBS:

    I have just installed debian and recalbox , on pi 3 . As the debian boots correctly , recalbox doesnt boot at all and my monitor goes off while it boots , it means it gets no sygnal .
    What should i do
    Bellow my configs :
    recalbox-boot.conf:

    sharedevice=INTERNAL
    global.videomode=default

    config.txt:

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    comment to get jack audio

    #hdmi_drive=2

    Using /etc/modules is deprecated and no longer supported on 4.4 kernel

    So manually enable audio

    dtparam=audio=on

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    #hdmi_force_hotplug=1

    uncomment for composite PAL

    #sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    #avoid_safe_mode=1
    disable_overscan=0
    overscan_scale=1
    sdtv_mode=2
    hdmi_group=1
    hdmi_mode=16

    any suggestions ?

    I have some ploblem with my recalbox in multiboot.



  • May be related to some newer pi3 boards, that's what the raspberry guy told me



  • @Substring Also for me, Recalbox via NOOBS does not work at all! If I use your img file downloaded from here everything is fine!
    But, if I use NOOBS to install RECALBOX with other o.s. (or even alone!) does not work !!
    The result is a white (or sometimes gray) screen. I tried every possible combination of the config.txt file but with no result! I think the problem is in the same image of Recalbox for noobs ... 😢
    I use Raspberry Pi 3 (not new B+ model obviously!).



  • @maxmoro77 i'm not sure how you installed recalbox with noobs, i haven't had any problem so far



  • I have exactly the same issue. I had working triple boot with PINN, Libreelec, Recalbox and Raspbian. since last manual reinstall from PINN, I have Screen issue with the screen resolution. The OS seems to boot because there is sound from the HDMI but the resolution is out of range.



  • @substring I downloaded the last version of NOOBS (2.7.0) from raspberry site:
    https://www.raspberrypi.org/downloads/noobs/
    Recalbox is not compatible with this version of NOOBS.....
    Now I found an old version (NOOBS 2.4.5) and whit this one all works fine....



  • @maxmoro77 raspberry told me they "disabled" recalbox until we're compatible with 3b+. This could be linked



  • Exact same issue here...



  • Had the same issue with the same dualboot, solved it with using the 2.4 version of Noobs.


Log in to reply
 

Want to support us ?

Join us on :

309
Online

30958
Users

15100
Topics

113644
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.