Another (but fully detailed) 8BITDO NES30 PRO topic



  • Hi,

    I'm fully aware of the number of posts existing about this controller and Recalbox, but I wanted to add my detailed tests and explainations on this issue : "Unable to pair controller" message.

    What I've tried :

    3 DIFFERENT MACHINES : (Intel NUC i3, Intel NUC i5, Raspberry Pi3)

    8BITDO NES30 PRO controller with both the 2.0 and 4.0.1 firmwares. (My controller was delivered with the new packaging and had 4.0.1 firmware from factory)

    I've tried :

    • Manual BT reset (3 sec on pair button ?)
    • Manual factory reset (8 sec on power button according to the official documentation, and not on start as stated on the github)
    • Firmware downgrade / upgrade

    Still the same, ES can see the controller, it displays it as '8Bitdo NES30 Pro" but when I try to pair it it says unable to pair.

    If i've tried it on MULTIPLE systems, computers, with many firmwares, I can easily say that if anyone with this controller, on the current stable version of Recalbox, "forget all BT controllers" and try to pair a NES30 Pro, it should fail the same, and so it SHOULD NOT be ignored (and I don't say it is).

    Thanks for your work,


  • Moderator
    Team
    Moderator
    Translator

    @maldorhan

    1. The wiki can be edited by anyone... if you have a source or you know for sure something is wrong, please do us a favor and correct it.
    2. I have two of those controllers and “sadly” I can’t reproduce all the problems people have. And I’ve used and upgraded the controller and firmware many times.
      This is the reason why I believe many people just can’t follow instructions and quite often, they have some kind of special setup that we are not aware of.

    I hope someone can help you.



  • @paradadf

    1. First of all thanks a lot for your answer. I'll make sure to edit the wiki if I find any reliable information that can help people, as I did in the past with Intel BT firmware which is now integrated in RB.

    2. Are you telling me that you own a 8bitdo NES30 PRO, and that on a fresh Recalbox setup (meaning you forget all of your BT controllers), are able to pair it ? If you ASSURE me that you can freshly pair the exact same controller with the exact same firmware within the very same version of Recalbox, then I'd go back to retry everything on all 3 of my test systems until I find out the problem, but can you? I'm on it for days and with fresh installs and differents systems so it would be extremely weird, but possible :)

    Thanks again and be sure that I dont put the blame on anyone here, i'm just trying to help giving details on this (real) issue.



  • @paradadf

    PAIRING DONE ! Thanks a lot to Substring who told me to check the logs !

    Here's the solution for whose that could help :

    Log : [ 1200.79] Enter PIN Code: Enter PIN Code: Creating device failed:

    So I followed the manual pairing procedure described here (command line) : https://github.com/recalbox/recalbox-os/wiki/Connect-bluetooth-controller-manually-(EN)

    I entered the PIN code 0000

    And it worked ! (PAIRED)

    Thanks guys and that would be nice if it could help other people too!


  • Moderator
    Team
    Moderator
    Translator

    @maldorhan
    For the sake of completion... yes to the second point.



  • @paradadf Well then for some reason it asked for a PIN code on my side and not on yours, might be because the hardware of my controller is more recent than yours.

    Thanks for the "completion answer" anyway! On my side I'm glad that it wasn't just a "I can't read instructions" issue ;)


  • Moderator
    Team
    Moderator
    Translator

    @maldorhan actually, the manual pairing was mentioned a lot on older bt controller problem topics, so I assumed you tried it. Anyway, happy playing a new year!



  • @paradadf On old controllers maybe but I didn't find any post where both 8bitdo nes30 pro controllers issues AND the manual pairing solution because of a PIN code hidden request were mentioned together did you? And even then, if you think that "find and analyse the log, find out about a hidden PIN code request on a brand new 8bitdo controller and log in through SSH to manually type it" means that I "cannot read instructions" when again it's apparently not a known issue/solution for these specific controllers, then the whole forum should be useless because we're pretty far from the user's manual there, well it isn't useless.

    Imma stop here, happy playing too and maybe it will be useful to other people, thanks again to the DEVS for their amazing work and support!


  • Moderator
    Team

    @maldorhan It's most of time a controller issue that should not happen. This is why there is the "manual solution" when we can't find a way to properly reset the pairing infos on the pad. Still, i'm pretty sure it's a pad problem afterall, ad the 8bitdo documentation is desperately short ...



  • @substring said in Another (but fully detailed) 8BITDO NES30 PRO topic:

    Still, i'm pretty sure it's a pad problem afterall, ad the 8bitdo documentation is desperately short ...

    Yes I totally agree, the included manual in the box, the one on their English website and the one in English on their Japanese website are all differents, there's also many important undocumented differences depending of the firmware, different hotkeys, different reset button, different or lack of blinking, ... maybe they'll focus on improving that now they have fully released their switch support


  • Moderator
    Moderator
    Team

    @maldorhan hey,

    Your issue is very weird! I have 2 Nes30 Pro pads with 4.01 firmware and never had difficulties to pair them. I first tried with the internal BT of my RPI3, then with an usb BT dongle. I just had to reset BT pairing on pads, and restart association in ES.

    Anyway I'm glad it works for you and thank your for all your explanations and details. @Substring is right, the 8bitdo documentation is very, very poor...



  • @oyyodams yes indeed but the one I got came with the new switch support packaging and last firmware from factory, so it seems very recent, maybe there's a new BT chip or something new hardware wise that triggers that PIN code request, well anyway it's "fixed" but new owners may come across this issue too.



Want to support us ?

303
Online

24254
Users

12897
Topics

97649
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.