[4.1-stable] Loading roms from a network shared folder does not work with 4.1 commands.



  • Hi,

    I just tried to load my roms from a network shared folder according to you wiki.

    Unfortunately this does not work as described. I tried the recommended way for "Recalbox version >= 4.1". I edited the recalbox-boot.conf file (sharedevice=INTERNAL -> sharedevice=NETWORK) and tried the commands:

    sharenetwork_smb1=ROMS@192.168.0.101:recalbox/roms:username=recalbox,password=PASSWORD,vers=2.0

    and

    sharenetwork_cmd1="mount -t cifs //192.168.0.101/recalbox /recalbox/share -o user=recalbox,password=PASSWORD=0,gid=0,rw"

    Both are not working or does to have an effect. I don't get any return from the console. I can login with the user recalbox to the share with another PC and have read/write access.

    I'm also able to mount the share manually to i.e. /media/share to recalbox.

    mount -t cifs //192.168.0.101/recalbox/roms /media/roms -o user=recalbox,password=b7TBVx5RDB58I22f4oQK,uid=0,gid=0,rw

    Can someone confirm and has a workaround? Can I safely use the old way for "Recalbox version <= 4.0.x"?

    Greetings and marry xmas
    Sebastian

    P.S.:
    Your wiki is not correct.

    sharenetwork_cmd1=mount -o port=2049,nolock,proto=tcp 192.168.0.1:/Documents/recalbox /recalbox/share

    This command does not work in general without quotes.



  • Damn, I'm so stupid...

    sharenetwork_smb1=ROMS@192.168.0.101:recalbox/roms:username=recalbox,password=PASSWORD,vers=2.0

    Is not meant as command, but as a property in the recalbox-boot.conf also...

    But this fixed my problem, neither. The share is not mounted because this functionality is not working if you use the WLAN interface... -.-

    This should really be mentioned in the wiki!


  • Staff
    Developer
    Global moderator
    Team

    @m0nkey You're right. Share over wifi will be available soon, in a future version.



  • i had also my own struggle with this guide https://github.com/recalbox/recalbox-os/wiki/Load-your-roms-from-a-network-shared-folder-(EN) - very nice but wlan does not work.

    But I solved it with a workaround:

    try the implementation as shown in version 4.0.1 (mount the nas share before starting emulationstation)
    Edit /etc/init.d/S31emulationstation - this way

    start)
    ifconfig wlan0 up
    mount -a
    enabled="$systemsetting -command load -key system.es.atstartup"
    videoMode="$systemsetting -command load -key system.es.videomode"
    if [ "$enabled" != "0" ];then
    echo $videoMode | grep -qE ...

    at the end of the system start you need then a restart of the S31emulationstation-service.

    Edit the /recalbox/share/system/custom.sh which is referenced by /etc/init.d/S99custom
    and put there the line

    /etc/init.d/S31emulationstation restart

    Don't forget an "chmod u+x /recalbox/share/system/custom.sh"
    so that it can be executed.

    Background: anything in the binary of the emulationstation activates wlan0. But then it is too late for mounting the share of the nas. So when we restart the service "mount -a" can be executed correctly because wlan0 is up. Maybe we need no "ifconfig wlan0 up" because it should be brought up by a configuration-file which is loaded before but sure is sure 😉
    this worked for me!



  • @st-effen editing init files is definitely not recommended as they are overwritten at upgrade



  • This doesn't work for me either.

    Changed recalbox-boot.conf (shareddevice=NETWORK) then added:

    sharenetwork_smb1=F RAID 5 Array 2/Games/roms/Super Nintendo@192.168.2.69:recalbox/roms/snes:username=username,password=password

    Save and go back into Recalbox and scrape SNES and nothing.

    What am I doing wrong?


  • Staff
    Developer
    Global moderator
    Team

    @chiukian Hi,

    Please read and follow the wiki again.

    1. This is sharedevice and not shareddevice
    2. Your sharenetwork_smb1=F RAID 5 Array 2/Games/roms/... syntax is not correct


  • @oyyodams said in [4.1-stable] Loading roms from a network shared folder does not work with 4.1 commands.:

    Please read and follow the wiki again.

    This is sharedevice and not shareddevice
    Your sharenetwork_smb1=F RAID 5 Array 2/Games/roms/... syntax is not correct

    Hi oyyodams,

    sharedevice is correct (typo above)

    What is wrong with the syntax? (forgive me I'm not too familiar with these type of commands)

    My roms are on a server in a shared folder called "F RAID 5 Array 2" inside that folder is /Games/roms/(system specific folders of roms ex: Super Nintendo)

    Am I supposed to have the same folder structure on my server as recalbox in the /share folder? (/share/roms/snes)

    In the wiki example, the shared folder name is "ROMS' and it looks like they link that to the recalbox folder /roms

    Is recalbox looking inside the network ROMS folder for the same folder names inside the /share/roms directory?

    Last thing. My server is running SMB 3.1.1 per the PowerShell so does that mean it this shared network folder won't work on recalbox 4.1 at all?


  • Staff
    Developer
    Global moderator
    Team

    @chiukian you must write something like sharenetwork_smb1=ROMS@192.168.0.1:recalbox/roms:username=recalbox,password=recalbox

    replace:

    • 192.168.0.1 with the IP of your server
    • recalbox/roms with yhe path on your server
    • the username and the password


  • I have a question about wired mounting, the wiki says
    sharenetwork_<nfs|smb><[0-9]>=<SHARE|ROMS|SAVES|BIOS>@<NAS>:<shared folder>:<options>

    Mounting It worrks for me if I use SMB
    sharenetwork_smb1=SHARE@xxx.xxx.xx.x:racalbox:username=recalbox,password=recalbox

    but when I try the eqivalent with NFS
    sharenetwork_nfs1=SHARE@xxx.xxx.xx.x:racalbox:username=recalbox,password=recalbox

    it will not mount. I have NFS enabled for my recalbox share. Any idea why it does not work?



  • @oyyodams said in [4.1-stable] Loading roms from a network shared folder does not work with 4.1 commands.:

    @chiukian you must write something like sharenetwork_smb1=ROMS@192.168.0.1:recalbox/roms:username=recalbox,password=recalbox
    replace:

    192.168.0.1 with the IP of your server
    recalbox/rom with yhe path on your server
    the username and the password

    I figured this out finally.

    sharenetwork_smb1=ROMS <- This is the ROMS folder on the pi in the recalbox /share folder

    @192.168.0.1:recalbox/roms <- This is the shared folder on your server.

    But in order for this to work, you need to have the same folder structure as the /share folder on your pi.

    So basically create a share folder called roms. Then inside that folder use the same folder names for each system on the pi and place the roms in there, then it will work.

    Thanks



Want to support us ?

316
Online

81.5k
Users

22.3k
Topics

161.6k
Posts