[DOS] Pb jeu CD (et où trouver les logs?)



  • Bonjour,

    Je découvre recalbox que j'utilise sur un rpi franchement installé.

    Je cherche à faire fonctionner dune en version CD, j'ai lu ce que j'ai pu trouver mais je ne trouve pas réellement de réponse.

    J'ai créé un dossier /recalbox/share/roms/dos/dune-cd.pc

    A l'intérieur de ce dossier pour les commandes du dosbox.bat j'ai suivi ce qu'il y a ici :

    Lancement sous DOSBox

    Exécutez le fichier DUNE.BAT.
    Pour la version CD, lancez le fichier INSTALL.EXE sur l'image disque. Après l'installation, allez dans le répertoire créé sur le disque dur virtuel et exécutez DUNE.BAT.

    Source a-f

    • dosbox.bat

    IMGMOUNT d .\dune-cd.iso -t iso
    CD D:
    .\INSTALL.EXE
    C:
    CD DUNECD
    .\DUNE.BAT

    • dosbox.cfg

    [render]
    frameskip=0
    aspect=false
    scaler=hq3x

    • dune-cd.iso

    A chaque fois, ça charge, je vois le logo de dosbox puis ça revient sur le menu de selection des jeux.

    J'ai bien tenté de faire différents reglage mais sans succes.

    J'en suis à me poser la question s'il ne faut pas plutot au préalable installer le jeu et copier les fichiers ensuite.

    Bref, s'il y a des logs ça m'aiderait pour mon debug, ne serait-ce que pour visualiser ce qu'il se passe.

    Merci à vous et bravo pour ce que vous faites ! :)



  • Perso ce que je fais à chaque fois qu'il y a une install via CD, c'est 2 étapes:
    1/ installation depuis le CD
    2/ lancement définitif depuis le "disque dur"

    à chaque fois j'ai cette arborescence:

    ../JEUX.pc/

    • §source_cd/ -> dossier avec l'ISO du CD dedans
    • dosbox.bat -> config

    Etape 1/
    dans dosbox.bat j'ai

    imgmount D "~\source~1\FICHIER.iso" -t iso
    d:
    setup.exe (ou install.exe suivant l'arbo de l'ISO)

    Je lance, ça install, puis ça revient sous ES

    Etape 2/
    je modifie dosbox.bat comme suit:
    imgmount D "~\source~1\FICHIER.iso" -t iso
    c:
    \vers\le\jeux.exe

    et ça marche à chaque fois.


  • Moderator
    Team



  • @acris je vais tester la commande pause pour tenter d'avoir un peu de logs pour debugguer.

    @unik314r c'est un peu mieux, il y avait une erreur dans mon fichier
    J'appelais cd d: alors qu'il fallait mettre d:

    Merci à toi.

    Seulement maintenant, je ne retourne plus du tout à l'écran de démarrage. Ça reste bloqué sur un écran noir avec la flèche de la souris en haut à gauche, et l'icône recalbox en petit centre en bas de l'écran.

    Comme si le système était en attente de quelque chose ou que ça installe (c'est long la première étape chez toi ?)

    Je vais tester via dosbox directement demain.


  • Themer

    @b0bba faites l'installation sur votre pc, pas sur recalbox



  • D eD neiBon en fait c'était le fichier cfg qui foutait la grouille

    Je l'ai récupéré ici link text

    J'imagine que ça devait être pour une version précédente de recalbox.

    Donc ça fonctionne super bien

    imgmount D ".\cd\dune-cd.iso" -t iso
    D:
    INSTALL.EXE
    C:
    CD DUNECD
    DUNE.BAT

    A noter que la commande pause permet Be debugguer


Log in to reply
 

Want to support us ?

Join us on :

208
Online

26179
Users

13547
Topics

102799
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.