Recalbox 7.0

Switching image from LCD to HDMI when connected



  • Hello everyone!
    I just registered because I am losing my mind over a problem here and for hours I can't find a solution.

    My approach:
    I am using a Raspberry Pi3 with Recalbox (and Debian jessie and also LibreElec) and finally bought the official Raspberry 7" Display. Everything finally works fine with it but:
    I would like to change the picture to my TV when a HDMI cable is connected and I am booting. I finally managed to do this on Debian with display_default_lcd=0. But it just uses this command for Debian and not Recalbox or LibreElec.

    Is there a solution to use this config also for Recalbox? I tried typing it in the recalbox.conf but this was no solution, it is still booting on the LCD Screen. There must be but I think I'm just too stupid or now to tired to find it.

    As you can guess I am an extrem newbie in Linux and all concerning it. You would help me all lot, thanks in advance. And thank you for all the amazing work you are doing here.


  • Banned

    @nijate For now there isn't any solution working about that, it require some custom script which doesn't fully work.



  • @nijate there is someone else having the very same problem as you and whom i answered yesterday.

    If you.re using NOOBS, edit the /boot/config.txt to disable "display_force_hdmi", something like that.

    The next problem is regarding N64 which runs at 640x480 in the default settings as well as dreamcast. They will look bad on the 7" i'm afraid if they even run ...



  • @substring said in Switching image from LCD to HDMI when connected:

    @nijate there is someone else having the very same problem as you and whom i answered yesterday.

    If you.re using NOOBS, edit the /boot/config.txt to disable "display_force_hdmi", something like that.

    The next problem is regarding N64 which runs at 640x480 in the default settings as well as dreamcast. They will look bad on the 7" i'm afraid if they even run ...

    Well I tried all of these things. As I mentioned display_default_lcd=0 was the clue for Debian but could not be used for Recalbox or Libreelec. Hm.

    I have to say I'm kind of happy with the N64 output. I put n64.videomode=default in the recalbox.conf and now everything displays fine. The only problem is: The image is on the left side of the screen and not in the middle. Well depends. On a few games (and seemingly different cores used) it is in the middle. I really don't get a clue why, haha. But it doesn't bother me, because the resolution is 4:3 nontheless and as soon as one plays you don't notice the screen anymore. But graphics and speed is superb!

    Thanks anyways. I hope there will be a solution soon, it would be too nice. 🙂

    @voljega Thank you. Well, I just have to wait till someone with true knowledge of scripts and coding has the same problem as me and just writes a script, hehe.



  • @nijate here is the topic i was thinking about : https://forum.recalbox.com/topic/11194/n64-écran-7-raspberry/8 but it's in French. @Jidem says he solved such problemes, and you should take a look at his profile to find his posts mentionning the solution



  • @nijate try to put this line in config.txt file and and it will be good
    display_default_lcd=0

    If it's work, tell us.



  • @substring Thank you, i will try that on the weekend. That troubleshooting is so time consuming.

    @jidem I did exactly that as written twice. But it just works for Debian. If i boot Recalbox it stays at the LCD Screen. Don't know why.

    and thanks guys!



  • @nijate jidem was talking about the recalbox config file.

    I have a dualboot recalbox too : you had to do the flip screen trick in both .config ?
    So you have to do the display_default_lcd=0 in both config. I put that early in the .config file, but I'm not sure this have an effect.

    And... This works. You have to boot on it but this work.

    I think this should be written in 160 bold underlined font somewhere in the faq because I hunted for that information almost a week ! 🙂
    (or maybe this should be an advance recalbox setting ?)

    (oh, and "merci mec", @Jidem \o/
    I'm trying to script-cut the 7'' screen power while outputing on HDMI now).



  • @coincoin Merci pour le commentaire! J'avais un peu mis de côté ce truc là...je suis autre chose en ce moment et je l'avais mis sur ma TO DO List sans jamais avoir pris le temps de tester! lol
    Tu peux me dire exactement comment se comporte le Pi avec cette ligne?
    D'avance merci!



  • @jidem Bah ça boot avec la sortie HDMI si c'est branché, sinon, ça boot sur le LCD.
    Je me prennais la tête franchement en me disant "mais si j'essaye, ça va sortir re-inversé verticalement" mais non !

    Donc il suffit de coller la ligne qui va bien pour inverser l'écran, et celle -là pour que ça marche parfaitement. Maintenant, le truc casse-pied, c'est le petit écran qui est allumé en noir pendant la sortie HDMI, je crois que je vais être obligé de bricoler un interrupteur comme toi, mais j'ai pas envie...

    -edit- ah si : au début, y a NOOB qui sort àl'envers sur le 7''. Tu choisi recalbox et après ça sort en HDMI dans le bon sens.



  • @coincoin tu déconnes!!!!! Ça marche??? Je suis presque certain d'avoir essayé sans succès! 😉 Tu l'as rajouté en dernière ligne du config.txt?
    Je m y remet tout de suite du coup! Merci de ton retour!



  • @jidem bah in fact I turned on the screen inversion line as soon as I saw a .config file.
    I put it in the .config of the recalbox, rasbian and at some point in NOOB but I can't find the menu (it was in a boot interface: maybe at some point on the recoveries?).

    So far, I've only put the display_default_lcd=0 in the. config recalbox but it works like I told you. If @Nijate says it's booting on HDMI by changing Rasbian's. config, I believe it (I'll try, but I'm looking for something else here).



  • @coincoin tu veux dire que tu as mis la ligne dans recolbox.conf?
    Ou le config.txt du boot?



  • @jidem ahahah, I'm a pgm 🙂

    At the very beginning, when it boot, you press shift when you see the raspberry on the 7 ".
    There, there is a screen in which you can change the. config (by default pressing the e key).
    You put on the front line
    display_default_lcd=0

    Below the disable_overscan, I put the lcd_rotate = 2

    And then my rasbian comes out on TV.

    On the other hand, there is no way to get NOOBS outputing on HDMI. I really suck at Linux, but I guess it has its own .config?


  • Developer
    Team
    Global moderator
    Translator

    This is an english topic so please change back to english.



  • @coincoin so dualboot with raspbian?
    Because on recalbox only, without another system, it seems not working!



  • @paradadf sorry...thanks adrenaline! 😉



  • @jidem just a question, how many gpio ports you used for the 7'', just 5v/GND as every online tutorial says ?

    I used all 4, like described on the documentation you get with the screen. Maybe, those 2 more I have are command / data ports ?



  • @paradadf sorry.
    I will edit and translate my posts soon.



  • @coincoin good idea!
    I use just 5V/GND but please tell me where I must plug the others gpio.



Want to support us ?

103
Online

79.1k
Users

20.3k
Topics

149.0k
Posts