@dstroy: With param -v it just says:

OpenSSH_7.9p1, LibreSSL 2.7.3
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 48: Applying options for *
debug1: Connecting to recalbox port 22.
ssh: connect to host recalbox port 22: Connection refused

And I'm using the default authentication with user/password. No advanced security stuff activation.