Joystick Xin-Mo non fonctionelle dans certain jeu FBA !



  • Salut à tous,

    comme nombreux d'entre nous, je suis passé en 4.1 avec mon p'tit Pi3b. J'ai un kit Xin-Mo 2 joysticks + 18 boutons. Reconnu sans soucis depuis longtemps sur Recalbox.

    J'ai remis toutes mes ROMS FBA en prenant, bien sur, dans un pack v0.2.97.39 ! 😉

    Problème, sur la rom de "Chase HQ", parfaitement OK avant, mes boutons fonctionnent mais pas mon joystick !? 😮

    Un petit HotKey+B durant le jeu, joystick fonctionnel sous RetroArch et plus largement sur tous le reste..

    Une idée ?

    [ EDIT 1 ] Même soucis sur "Hang-On" ! 😞

    [EDIT 2] J'ai essayé de modifier : ## Set retroarch input driver (auto, udev, sdl2), mais rien n'y fait..



  • Pas d'idée ? 😉

    @acris @rockaddicted @Substring ? 😉



  • @colonel-v4 salut
    il y a un sujet "identique" pour FBA (pas libretro FBA, on est d'accord ?)

    Apparemment un sushi cote configgen. Tu peux me faire une archve de supoprt pour confirmer stp ?



  • @Colonel-v4 , @Substring Salut, le sushi en question concerné l'encodeur DragonRise.
    L’alternative actuelle est de passez directement à FBA Libreto où le problème s'évanouit aussitôt.



  • @Substring @Lilo , salut à vous et merci ^^

    Alors, autant pour moi, je parlais de FBA Libretro ! 😉

    Lilo, tu me confirmes que le soucis sur l'autre topic n'est pas le même que moi du coup ?

    Substring, je te fais l'archive, pas de soucis.

    [EDIT] => https://file.ac/5-swntxOTDE/ pour l'archive support ! 😉



  • @Substring

    J'ai refait une réinstallation "propre", j'ai juste configuré le wifi et le Xin-Mo puis remis juste une ROM sur FBA Libretro (ChaseHQ).

    Même soucis.. 😞

    Archive support : https://file.ac/EMBOnzOqFB4/

    Encore merci ! 😉

    [ EDIT 1 ] Je viens de me dire.. Ça vient de mon kit arcade ou pas ? Alors j'ai testé mon adaptateur SFC pour mes manettes SNES officielles, idem ne fonctionne pas. Par contre, avec mes manettes PS3 officielles, au PAD, idem mais ça fonctionne en utilisant le stick analogique ! 😮



  • Perso je pense avoir les mêmes joy et button que toi, et le même souci. Je suis allez dans " input" et j'ai reconfiguré en passant par " reconfig all " , donc detection des axes analogique ET numérique, et là, plus de souci dans hangon, ni chase HQ, ni OutRun. En fait les stick analogique et numérique n'était plus configuré sur le même et unique joystick présent. (En fait je pense que ça touche les jeux qui étaient pourvu d'un volant ou dérivé). J'ai tjs un souci mais plus celui là. Je ferrai un nouveau poste, ne trouvant pas ma réponse. (En gros, lorsqu'il te demande de configurer un axe (Up/down etc etc), tu fais tous avec le stick joueur 1). Tu sauvegardes et chez moi ça passe... Edit: (je parle d'input de retroarch)



  • @rafistole sur type retropad ou analog retropad ?



  • Un ou l'autre, ça na pas l'air de changer grand chose. Par contre en fouillant pour vous répondre j'ai fichu le bazar. Ma technique fonctionne tjs mais je dois la refaire à chaque fois, je n'arrive plus a sauvegarder la config... Zut, j'avais fait le tour de mes soucis, ma borne était prête à déménager à sa bonne place. Qu'est-je fais encore.



  • Bon ben ça à été difficile, mais j'ai réussi à nouveau à le faire sauvegarder. (Mais je ne sais trop comment).

    Je confirme donc, que dans mon cas, je n'ai plus de souci, ni dans Chase HQ ou Outrun, ou dérivé.



  • @Colonel-v4 Je confirme que le problème est d'un autre type concernant FBAlpha.
    Content que ça semble résolut pour Libreto je pense que ça aurait été plus embêtant.
    Pour ma part, se suis directement passé à Libreto et tout est impecable! ^^



  • @Substring @rafistole , c'est la galère totale ! 😞

    Bon alors effectivement, la ""solution"" :

    1. Démarrer le jeu dans FBA Libretro
    2. HotKey + B => SETTINGS => INPUT => USER 1 BINDS => BIND ALL
    3. Suivre ce qui est demandé pour affecter les boutons / joysticks
    4. QUICK MENU => RESUME pour retourner dans le jeu, pas besoin de redémarrer le jeu ou RetroArch.

    Manip qui fonctionne à l'instant T, je n'arrive pas à sauvegarder quoique ce soit.. De plus si l'on change de manette, forcément, tout est à refaire..

    PS : Je sauvegarde là (USER 1 Save AutoConfig + Save Current Config) mais je ne sais pas si c'est bon ?

    @rafistole , (rien à voir mais..) y'a pas un soucis avec ChaseHQ ? Même à fond tout le temps sans obstacle, en 60s ma barre noir représentant ma voiture sur la droite n'avance pas ! Il me faut bien 2 crédits avant d'espérer toucher ma victime ! 🙂

    Merci à vous pour votre aide ! ++

    [EDIT]

    @Substring , Type retropad ou analog retropad ==> Aucune différence lors de mes tests, du coup je laisse de base sur Retropad.

    @Lilo , Merci pour l'info, c'est "résolu" sans vraiment l'être.. Ça me ferait presque regretter la version précédente de RetroArch ! 😞



  • Bonjour à tous,
    J'ai exactement le même problème sur Arkanoid et Power Drift sur FBA Libretro (v4.1)
    Effectivement, si je veux configurer mes manettes, le système me sépare les axes analogique et numérique
    J'ai regardé comment @rafistole a corrigé son PB, mais je ne trouve pas l'option "reconfig all" dans input 😞

    Merci


    Désolé, j'avais pas vu la réponse de @Colonel-v4 . Par contre, impossible de sauvegarder la config (Error saving autoconfig file) 😞



  • @Ryo-Saeba , j'ai eu cette erreur une fois, j'ai remis par défaut les boutons USER1 puis reparamétré le tout. Peut être une coïncidence mais depuis j'arrive à sauvegarder.. Même si cela n'est pas pris en compte à chaque redémarrage de jeu.. 😞

    Ce qui me rassure, c'est que depuis la 4.1, je ne suis pas le seul à avoir ce soucis !

    @Substring @rafistole , une idée ? Quelques choses à tester ? 😉



  • @colonel-v4 non, en plus je ne vais pas être dispo de la semaine



  • Ça marche, merci @Substring , j'espère semaine prochaine pour une résolution de ce ptit soucis ! 😉

    @rafistole , une idée pour la sauvegarde ?



  • @Colonel-v4

    Je viens de redémarrer ma borne et Chase HQ a fonctionné du premier coup. De plus concernant CHQ, n'oublies tu pas de changer de vitesse? En première je ne dépasse pas 200 km en deuxième j'atteins les 300 km. (Comme OutRun il y a une boite de vitesse (attention il existe deux versions d'OutRun, une avec boite de vitesse deux rapports et une version sans boite....)

    Alors pour le problème récurent de non sauvegarde. Comme dis plus haut j'ai galéré jusque tard le soir (ou tôt le matin). J'avais préparé un pâté de marche à suivre que j'ai remplacé par mon avant dernier poste. Colonel v4 à très bien résumé. La première étape.
    Ce que j'ai fait au moment ou ça a re-sauvegarder, (mais j'ai fait tellement de chose ce soir là), c'est que j'ai effacé (sauvegardez les au cas ou), les fichiers suivants:

    Dans Share/system/configs/retroarch

    • retroarchcustom.cfg

    Dans Share/system/configs/retroarch/input (Fichier autoconfig je pense).

    • Xin-Mo Xin-Mo Dual Arcade.cfg (pour ceux qui ont les joy Xin-Mo)sinon à effacer aussi sans doute).

    Dans Share/system/configs/retroarch/cores

    -retroarch-core-options.cfg

    SI dans un de ces répertoire il y a d'autres fichiers, virez les aussi.

    Ensuite je ne sais plus si j'ai redémarré la box ou pas. Mais si vous la redémarrez vous devrez peut être repasser par la config joy de recalbox je ne sais plus si je l'ai fait à ce moment. Mais j'ai été reconfigurer le "bind all" , ensuite dans le même menu, j'ai choisi " user 1 save autoconfig " (je pense qu'il cré à nouveau le fichier " Xin-Mo Xin-Mo Dual Arcade.cfg" se trouvant dans input (voir plus haut).

    Ensuite, dans le doute je pense avoir cliqué dans le menu "Quick Menu/control/Save core et game remap file" et là je pense que ça a fonctionné.

    Je précise que j'en ai fait des manips ce soir là, je ne garanti rien, si ce n'est que chez moi, la sauvegarde fonctionne. De plus si vous changez de joy, je ne sais pas si ça fonctionne encore, perso se sont des boutons arcade zippy fixés et qui ne bougerons plus.

    Mais je pense sincèrement que la soluce se trouve du côté d'un fichier qui n'autorise pas la sauvegarde. De temps en temps, je voyais en essayant de sauvegarder un nom différent du nom de la config prise en compte. Ou carrément un " fail to saveconfig blabla blabla".

    Je vais essayé de surveiller ce poste pour vous aider, mais je vous rappel que je ne suis pas un pro du sujet. Je donne surtout des pistes plus qu'un "tuto".

    EDIT: Si ça ne fonctionne pas j'ai peut être aussi viré les fichiers suivant (je colle une conversation tirée d'ici pour retrouver ces fichiers) :

    Début...

    acris Moderator
    Team
    il y a environ 4 mois

    @Substring @Dimitri-Dewals

    ce dont parle @substring est la manipulation suivante qui permet de charger un core remap pour l'ensemble des jeux sans utiliser la fonction dans recalbox.conf

    avoir recalbox 4.1 unstable

    Mini tutoriel :

    le core remap s'effectue dans retroarch
    Lancer le jeu accèder au menu de retroarch : (hotkey+B)

    Mais avant il faut vérifier / activer ses paramètres :

    settings > Configuration
        load remap file automatically > ON
        Save Configuration on Exit > ON
    

    puis

    Quick Menu > Controls
        Modifier USER 1
        Choisir Save Core remap file après modification
    

    /!\Attention si tu modifies pour un seul jeu, la même configuration sera utilisé sur TOUS LES JEUX de l'émulateur.
    Renouveler la manipulation pour l'ensemble des emulateurs supportants cette option.
    Seuls les core libretro pour retroarch peuvent utiliser cette option, il n'est pas possible de faire la même manipulation pour les emulateurs standalones tels que N64, Dreamcast, PSP etc...

    Les fichiers remap per core (*.rmp) sont stockés dans /recalbox/share/system/.config/retroarch/configs/remaps/nom_du_core/nom_du_core.rmp.

    Lien: https://forum.recalbox.com/topic/4536/sauvegarder-config-retroarch/25
    Fin...

    (J'ai utilisé le programme WinSCP pour atteindre les fichiers .rmp et j'ai tous viré) je pense que recalbox les créés quand on sauvegarde en cliquant sur save core. Et du coup ça ne charge pas la bonne config. En virant tout, il n'avait plus le choix.

    Si vous n'avez plus l'option : load remap file automatically > ON
    Il faut passer par setting/user interface/ et mettre show advanced setting sur ON
    Etrangement j'avais perdu l'option¿¿¿



  • Je vois que Ryo Saeba obtient un "(Error saving autoconfig file)" Je pense qu'en virant le fichier se trouvant dans input, ça pourrais te décoincer cette sauvegarde impossible.



  • Désolé @rafistole mais ça ne fonctionne toujours pas.

    J'ai bien supprimé les fichiers suivants :

    • retroarchcustom.cfg
    • retroarch-core-options.cfg
    • DEFAULT.cfg (qui est dans Share/system/configs/retroarch/input)

    J'ai redémarré la box, je n'ai pas eu à passer par la case config, et malheureusement toujours pas moyen de sauvegarder la config user 1 😞
    Et du coup, obliger de mapper à chaque fois que je lance Arkanoid ou Power Drift par exemple.
    Pourtant j'ai pu sauvegarder le Core Game, et il se charge bien lors du lancement du jeu.
    Cela marchait pourtant très bien dans la version 4.02. Mais je ne vois pas ce qui a pu changer, toutes les options semblent identiques.
    Il y a juste un petit truc : impossible de mettre en français retroarch. Cela fonctionnait très bien en 4.02 mais en 4.1, si j'essaie d'aller au delà de "English", cela plante et je me retrouve sur la liste des jeux FBA_libretro



  • Je ne savais même pas qu'on pouvais changer la langue, il est en anglais et pour moi, c'est bien comme ça.

    Et sinon tu utilises quoi comme bouton? Manette, arcade, etc ? As tu essayé de viré les fichier *.rmp (que tu ne peux atteindre que via un soft).?

    je ne sais trop quoi dire; désolé.



Want to support us ?

346
Online

81.4k
Users

22.3k
Topics

161.5k
Posts