High bluetooth latency on 8bitdo controller



  • I'm using a NES30Pro and the bluetooth latency is all over the place and makes games unplayable. Latency is fine when plugged in with USB.

    I've tried it with the onboard bluetooth, and then with a USB dongle.
    However I did not disable the onboard bluetooth when the dongle was in. How can I do that to see if that makes a difference? I tried setting the "controllers.bluetooth.enabled=0" in the conf but then the USB dongle didn't work either.


  • CRT Fan

    Hi,

    The first bluetooth used is the USB dongle, before internal bluetooth in all case.
    I think there is a line in boot.txt for disable the internal (saw that in a post from @Substring), but it is not needed.

    Are you in 4.1 ?
    What is your usb dongle ?
    Are your Nes30pro firmware up to date ?

    idarius


  • Moderator
    Team

    @ignign0kt You need to add an overlay to disable the onboard BT on a pi3. Anyway, if you plug a dongle, this will be the main BT adapter



  • @idarius Yeah I'm on 4.1, using a SoundBot SB340, and newest 8bitdo firmware.
    Not sure what else to try.
    The only thing I've left to try is to use an pre-2.0 8bitdo firmware because if I recall correctly the latency wasn't as bad as it is now

    @Substring Ah ok, as long as the onboard wouldn't interfere with the performance of the dongle than I won't bother disabling it.


  • Moderator
    Team

    @ignign0kt said in High bluetooth latency on 8bitdo controller:

    as long as the onboard wouldn't interfere with the performance of the dongle

    well, I can't say



  • @substring I did try the dtoverlay to disable, but that didn't work -- bluetooth is still on

    I did notice/realize though that I'm on 4.1.0-DEV. If that could have any impact, is there a way to "upgrade" to the stable 4.1 without re-installing from scratch?


  • Moderator
    Team

    @ignign0kt please read the 4.1.0 FAQ on the forum



  • I reinstalled 4.1 stable and now my USB dongle isn't working at all ;
    Just says working for 5-10 seconds and doesn't find anything

    edit: when i add the dtoverlay to the config file, the dongle doesn't work either. I'm guessing that disables BT system wide and not just the onboard BT?

    Anyway the latency after installing the stable release is more acceptable now.

    Thanks


  • Moderator
    Moderator
    Team

    Hi @ignign0kt,

    I have a very, very old BT dongle (can't remember the reference) which was working with Recalbox 4.0.2. This dongle doesn't work at all with version 4.1, for an unknown reason. I can see it, but no joystick can be associated with this dongle anymore. Anyway even if my pads can be associated with the internal BT of my RPI 3, I've juste purchased a new CLS BT dongle 4.0, and this one works very well.

    Just my 2 cents to say that some old BT dongles don't work with Recalbox 4.1 ;)



Want to support us ?

Join us on :

255
Online

26179
Users

13547
Topics

102799
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.