N64, Mayflash, ingame no response of n64-controller



  • Hello,

    I have a mayflash-adapter (recognized as "Product: USB GamePad | Manufacturer: USB GamePad" (output of dmesg)).

    I didn't configure any keys on startup, in my recalbox-controller-config (in GUI), there is only the ps3-controller listed as #0.

    When I call "cat /proc/bus/input/devices" it gets listed with event-files like that:

    I: Bus=0003 Vendor=0079 Product=1879 Version=0110
    N: Name="USB GamePad USB GamePad"
    P: Phys=usb-3f980000.usb-1.5/input0
    S: Sysfs=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1/0003:0079:1879.0002/input/input0
    U: Uniq=
    H: Handlers=js0 event0
    B: PROP=0
    B: EV=1b
    B: KEY=ffff 0 0 0 0 0 0 0 0 0
    B: ABS=30027
    B: MSC=10
    

    Also the "jstest /dev/input/js0" outputs

    Joystick (USB GamePad USB GamePad) has 6 axes (X, Y, Z, Rz, Hat0X, Hat0Y)
    

    and resonds correctly to the buttons/stick.

    I also changed recalbox.conf to

    global.inputdriver=udev
    ...
    n64.configfile=dummy
    

    and updated the /recalbox/share/system/configs/mupen64/InputAutoCfg.ini to the following

    [USB GamePad USB GamePad]
    plugged = True
    plugin = 2
    AnalogDeadzone = 2096,2096
    AnalogPeak = 21283,21283
    Mempak switch =
    Rumblepak switch =
    mouse = False
    A Button = button(9)
    B Button = button(2)
    C Button R = axis(3-)
    C Button L = axis(3+)
    C Button D = axis(2+)
    C Button U = axis(2-)
    DPad D = hat(0 Down)
    DPad L = hat(0 Left)
    DPad R = hat(0 Right)
    DPad U = hat(0 Up)
    L Trig = button(6)
    R Trig = button(7)
    Start = button(1)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)
    Z Trig = button(8)
    

    But when I start any n64 game, only the ps3-controller has any function. It feels like the n64 controller isn't present (but works in shell test).

    @Chrischan told me what to do, I followed his instructions but I'm missing something...

    I'm on recalbox 4.0.2, raspberry 3

    thanks guys and girls!


  • Moderator
    Team

    Hello

    you need to add your gamepad N64 as player 1 in Emulationstation Menu > gamepad options
    and you need to add combo keys to exit
    in /recalbox/share/system/configs/mupen64/mupen64plus.cfg

    look
    https://forum.recalbox.com/topic/6352/probleme-manette-dragonrise-inc-avec-émulateur-nintendo-64/7

    need you archive support : https://github.com/recalbox/recalbox-os/wiki/Recalbox-support-(EN)


  • Moderator
    Team

    @bury Well, first of all, congratulations for such a nice report ! We hardly get to see some posts that well organized and accurate :)

    One dumb question : if you only plug your N64 pad, no other, does it work as expected ?



  • Thanks for your answers and sorry for answering that late, but I wasn't at home yesterday.
    And @Substring also thanks for your appreciation. I'm also a developer and linux admin, so I think I know what the helpers/developers want to know ;) Thanks!

    Okay, in the GUI the n64 controller doesn't appear at all. Only when I push a button the screen "3 controllers detected. Press any key to configure...." appears (3 because of 1 ps2, mayflash with 2 n64 ports). But I shoudn't configure n64 controller in the GUI because after that no rom starts.

    So in controller-config, there's only the ps3 controller. So I cant't test the hint of @acris .

    But in shell, n64-controllers are recognized and working.

    Ok, I just wanted to try your hint @Substring , and realized teh following: I rebooted with just the n64 controller. When I tried to navigate in es homescreen the controller-config-popup appears. I can't skip it since the n64 has no hotkey configured. A usb keyboard (pressing esc) also doesn't help. So when I tried to press some buttons on the n64, in the fade-in-animation of the controller name, I saw, that the first characted is one like utf8_encoding problem. It is a sqaure-character in first char like so:

    0_1502010714136_IMG_9645 Kopie.jpg

    (three gamepads because I tried first with only the n64, couldn't skip the configure-popup and then rebooted and tried it with an usb keyboard).

    So I think there may be a name-mismatch between OS-Name and ES-recognition-Name so that es thinks, there is no config. May be a controller fault...?

    Any ideas?

    In the meantime I play BanjooKazooie with ps3-gamepad. Also works fine - more or less!

    Thanks!


  • Moderator
    Team

    @bury As Acris asked, we're missing your support archive. Run /recalbox/scripts/recalbox-support.sh and upload the archive somewhere :)



Want to support us ?

Join us on :

292
Online

27379
Users

14097
Topics

106912
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.