N64 Games Not Playing Since Fitting Screen



  • I'm betting it's something stupidly simple that I have not yet done... I replaced my coot\config with the code at the end of this post allowing me to rotate the screen etc (sorry I don't know the tags to use for code :( ) as I have just mounted the pi on a 7inch screen.

    It's rotated just fine but I have two problems regardless of rotation:

    1. The rainbow splash screen is still shown
    2. N64 games just come up with a black screen and then exit. Everything else seems to work just fine... they also worked fine when connected to a TV via the HDMI port

    .

    boot\config.txt

    ##if you plug your tv at the same time as your rpi and that
    ##the rpi switches from the hdmi or give a low resolution
    ##because tv had no enough time to initialize it.
    boot_delay=3

    ##Disable rainbow at startup
    disable_splash=1

    ##Overclock
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512
    avoid_safe_mode=1
    kernel=zImage

    ##1=no HDMI, 0=HDMI optional
    hdmi_ignore_hotplug=0

    ##Composite mode
    #dtv_mode=0 #Normal NTSC
    #sdtv_mode=1 #Japanese version of NTSC no pedestal
    sdtv_mode=2 #Normal PAL
    #sdtv_mode=3 #Brazilian version of PAL 525/60 rather than 625/50

    ##Overscan
    disable_overscan=0

    ##No rotation
    #display_rotate=0
    #overscan_left=4
    #overscan_right=-14
    #overscan_top=10
    #overscan_bottom=-14

    ##180° rotation
    display_rotate=2
    overscan_left=-11
    overscan_right=6
    overscan_top=-14
    overscan_bottom=-8

    ##Aspect ratio
    sdtv_aspect=1 # 4:3
    #sdtv_aspect=2 # 14:9
    #sdtv_aspect=3 # 16:9

    ##Resolution
    framebuffer_width=320
    framebuffer_height=240

    ##Activate overscan scaling (important: has to be last entry!)
    overscan_scale=1



  • I've made some progress by editing the recalbox config file to use the default n64 video mode - it works (bonus) but it's crammed to the left side of the screen in a 4:3 ratio. Is there a way of at least shifting the display to be more central??

    ##N64 emulator is configured to display a screen with a 640x480 resolution (native n64 resolution)
    ##So you must use one of these video modes (DMT 4 HDMI,CEA 1 HDMI).
    ##If your screen is not compatible with one of these video modes, please check the recalbox's wiki.
    #n64.videomode=DMT 4 HDMI
    #n64.videomode=CEA 1 HDMI
    ##If you are using a CRT screen, please change the setting above with this one :
    n64.videomode=default

    EDIT: N64 works but PSX has stopped working... fml



  • N64 works but PSX has stopped working... fml



  • There's no edit function... (lol just found it making this - duh!)

    Added psx.videomode=CEA 4 HDMI to the recalbox config

    changed boot\config.txt

    ###Aspect ratio
    sdtv_aspect=1 # 4:3
    #sdtv_aspect=2 # 14:9
    #sdtv_aspect=3 # 16:9

    to
    ###Aspect ratio
    #sdtv_aspect=1 # 4:3
    #sdtv_aspect=2 # 14:9
    sdtv_aspect=3 # 16:9

    and now the psx works, doesn't fill the screen anymore but it is central which is nice, still can't get the N64 screen central


Log in to reply
 

Want to support us ?

Join us on :

216
Online

29644
Users

14860
Topics

111944
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.