écran noir raspberry pi zero w



  • Bonjour à vous

    Je viens vous voir car j'ai un petit soucis avec ma recalbox.
    J'ai un raspberry pi zero w et j'ai installé la recalbox dessus selon les étapes que Simba51 nous conseille ici : https://forum.recalbox.com/topic/6853/raspberry-pi-zero-w-rien-s-affiche/27

    Alors ma recalbox se lance bien, le wifi ronronne.
    Seulement les soucis viennent après :

    • j'ai l'impression qu'Emustation se ferme dès que je lance une Rom
    • l'image à l'écran part en vrille selon les fonctions que je demande ( saute, m'affiche des trait verticaux, etc etc) puis s’éteint au bout d'un moment.

    je précise que je construit tout ça pour en faire une console portable, donc il est alimenté avec une batterie de téléphone a travers un régulateur qui envoi donc au raspberry pi 5.4V ( directement soudé sur le RP Zero w )
    la nappe de l'écran est un peu abîmée aussi.

    du coup je me demande si mon soucis peut venir d'un défaut au niveau de l'alimentation ( 5.4V 2A) ?
    ou de l'écran ?
    Ou si c'est purement logiciel ?
    est-ce qu'il y a des crashfile que nous pourrions analyser ?

    Merci à ceux qui m'aideront :)


  • Moderator
    Team

    Bonjour
    Il faudrait plus de detail sur lecran utilisé

    As tu teste ton materiel sur ta tv.



  • Bonjour Acris

    l'écran est celui-ci :
    http://www.ebay.fr/itm/291785250466?ul_noapp=true

    directement soudé au régulateur reglé a 5.4V via son drivers pour l'alimentation et la masse
    l'av1 est soudé directement sur un des deux "trou" TV du raspberry pi.

    j'ai désactivé le HDMI du coup pas pu retesté depuis. Je l'avais testé avant d'attaquer les soudures sur batterie et écran.

    Pour reactiver les ports HDMI c'est dans conf.TXT ou recalbox.conf ?
    Je pense que mon écran déconne, pour ça qu'il s'eteint ou m'affiche les traits, mais les roms qui se lancent pas doivent etre un second probleme



  • heuuuu ton av1 ne doit pas être soudé sur l'un ou l'autre le carré si je ne me trompe c'est la masse et le rond c'est la video.



  • le carré est la vidéo, le rond la masse sur le "zero w" et la masse et l'alimentation de mon écran est relié a la masse et l'alimentation du régulateur qui envoie du 5.4V
    idem pour le raspberry son alim et sa masse sont branché dessus.



  • @acris

    j'ai réactivé le HDMI safe que le tuto m'avait dit de commenter.
    Visiblement ça fonctionne sur la TV. Le temps que le raspberry lance le jeu est super long, mais ça marche.

    Après sur l'écran TFT. C'est sur pour l'écran qui "saute" et les traits c'est un faux contact dans la nappe reliant le drivers a l'écran. Mais pourquoi l'ecran s'eteint au bout d'un moment ? ( de plus il n'a pas l'air bien cadré. Pb résolution ou autre? )


  • Moderator
    Team

    Le temps que le raspberry lance le jeu est super long, mais ça marche.

    ça dependra de l'emulateur et du jeu....

    Pour la configuration des écrans TFT il y a différentes tutoriels qui pourront t'orienter :
    https://github.com/recalbox/recalbox-os/wiki/TFT5-Screen-HDMI-(EN)
    https://github.com/recalbox/recalbox-os/wiki/Utility---Use-of-fbcp-for-small-TFT-screen-%28EN%29
    https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-CRT-with-composite-(EN)
    https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-DVI-screen-(EN)

    Si aucun de ses liens t'aident, peut être que @ian57 pourra t'orienter.
    https://github.com/recalbox/recalbox-os/wiki/TFT-Screen-DPI-Bus-(EN)
    https://github.com/recalbox/recalbox-os/wiki/TFT-Screen-SPI-Bus-(EN)


  • Team

    @acris @yuurei il s'agit d'un écran en composite... du coup les tutos pour spi, spi ne sont pas du tout applicable.
    Par contre, il faut sûrement adapter la résolution envoyée... car en 3.5" je pense pas que tu dépasses le 480x320 qui est un ratio un peu bâtard 3/2 et pas 4/3. IL faut que tu vérifies ta résolution native de l'écran. Ensuite tu peux tenter de configurer plus finement :

    # uncomment for composite PAL (color)
    sdtv_mode=2
    #sdtv_mode=0    Normal NTSC
    #sdtv_mode=1    Japanese version of NTSC – no pedestal
    #sdtv_mode=2    Normal PAL
    #sdtv_mode=3    Brazilian version of PAL
     
    sdtv_aspect=1  #4:3
    #sdtv_aspect=1  4:3
    #sdtv_aspect=2  14:9
    #sdtv_aspect=3  16:9
     
    #force tv mode
    hdmi_group=1
    hdmi_mode=8 #240p  60Hz
    

    ceci dit , pour le même prix tu as un écran TFT 320x240 en spi qui sera bien plus propre au niveau de l'affichage... le composite c'est caca :)



  • Bonjour,
    sans vouloir pourrir le post, tu dis :
    ceci dit , pour le même prix tu as un écran TFT 320x240 en spi qui sera bien plus propre au niveau de l'affichage... le composite c'est caca :)

    Tu aurais des liens stp ? J'ai du mal à m'y retrouver dans les écrans compatibles ou pas...

    PS: j'ai déjà lu les liens au-dessus sur les SPI...



  • @acris said in écran noir raspberry pi zero w:

    Le temps que le raspberry lance le jeu est super long, mais ça marche.

    ça dependra de l'emulateur et du jeu....

    Tétris sur GB noir et blanc. On va pas dire que c'est ce qui mange le plus de ressources.

    @ian57 said in écran noir raspberry pi zero w:

    @acris @yuurei il s'agit d'un écran en composite... du coup les tutos pour spi, spi ne sont pas du tout applicable.
    Par contre, il faut sûrement adapter la résolution envoyée... car en 3.5" je pense pas que tu dépasses le 480x320 qui est un ratio un peu bâtard 3/2 et pas 4/3. Il faut que tu vérifies ta résolution native de l'écran. Ensuite tu peux tenter de configurer plus finement :

    # uncomment for composite PAL (color)
    sdtv_mode=2
    #sdtv_mode=0    Normal NTSC
    #sdtv_mode=1    Japanese version of NTSC – no pedestal
    #sdtv_mode=2    Normal PAL
    #sdtv_mode=3    Brazilian version of PAL
     
    sdtv_aspect=1  #4:3
    #sdtv_aspect=1  4:3
    #sdtv_aspect=2  14:9
    #sdtv_aspect=3  16:9
     
    #force tv mode
    hdmi_group=1
    hdmi_mode=8 #240p  60Hz
    

    ceci dit , pour le même prix tu as un écran TFT 320x240 en spi qui sera bien plus propre au niveau de l'affichage... le composite c'est caca :)

    Si tu as un lien vers l’écran et que c'est du 3"5 pouces, je suis preneur !

    je viens de tester avec la conf indiqué, ça marche pas mieux.


Log in to reply
 

Want to support us ?

Join us on :

305
Online

28119
Users

14407
Topics

109067
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.