Problème général :(



  • Bonjour,

    Je suis sous RP3, recalbox 4.0.1, jeux sur USB.
    La plupart de mes émulateurs ne fonctionnent pas, sauf quelques jeux mame (metal slug).
    Tout fonctionnait lors d'une précédente intallation avec les mêmes jeux, les mêmes bios...

    quelques pistes :

    • quand je veux sauvegarder dans ghost n gouls par ex, il me dit "can't save"
    • mon mini ampli est branché en JACK, mais à chaque redémarrage le son rebascule en HDMI
    • quand je change une resolution dans Retroarch (mame) ça fonctionne, mais quand je quitte puis relance le jeux, ça revient à l'ancienne résolution
    • la mise a jour ne fonctionne pas
    • quand j'édite le choix de l'amulateur avec SELECT quand je suis sur un jeux, au redémarrage suivant il a oublié !
    • je ne peux pas sauvegarder le fichier recalbox.conf il me refuse l'écriture

    Ca resemble à un problème d'écriture ? j'ai essayé la commande mount -o remount,rw share/ mais ça ne change rien 😞

    question bonus ; où trouve-t-on le dossier script ? j'aimerais mettre un script sur un bouton mais rien dans /share <- c'est bon j'ai trouvé ça, via cyberduck

    merci !



  • root@192.168.0.25's password:

    mount -o remount,rw share/

    mount: can't find share/ in /proc/mounts

    dir

    -sh: dir: command not found


  • Translator
    Translation Master

    @lainbebop
    To get write rights execute the following:
    mount -o remount,rw /


  • Staff
    Developer
    Global moderator
    Creator
    Team

    Il faut vérifier si la partition share est en lecture seule :

    la commande mount permet de le voir



  • j'ai déjà essayé ça ne fonctionne pas 😞



  • @lainbebop donne-nous le résultat de la commande mount en SSH stp



  • alors soit comme plus haut (can't find share/ in /proc/mounts)
    soit aucune réponse dans cyberduck ou terminal
    quand je n'ai pas de réponse, je me dis que ça marche, mais non, impossible de modifier le fichier, il me dit lecture seule !

    EDIT : juste "mount" ? si c'est le cas, j'essaie dans 10min, là je refais un formatage de la SD (j'utilise le soft conseillé sur mac, carte sandisk ultra 16GO...)


  • Staff
    Developer
    Global moderator
    Creator
    Team

    @lainbebop oui juste mount... ça donne la liste des partitions et des points de montage.



  • Ok, j'essaie ça dès que le formatage est fini 🙂
    le pb venait peut être de là aussi, les précédents formatages prennaient 3 secondes, je faisais "quick format" alors que là en Overwrite ça prend du temps...



  • /dev/root on / type ext4 (ro,relatime,data=ordered)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=242524k,nr_inodes=60631,mode=755)
    proc on /proc type proc (rw,relatime)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /dev/shm type tmpfs (rw,relatime,mode=777)
    tmpfs on /tmp type tmpfs (rw,relatime)
    tmpfs on /var type tmpfs (rw,relatime)
    tmpfs on /run type tmpfs (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    /dev/mmcblk0p6 on /boot type vfat (ro,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
    /dev/mmcblk0p8 on /recalbox/share type ext4 (rw,noatime,data=ordered)
    /dev/sda1 on /media/usb0 type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=utf8,shortname=mixed,flush,errors=remount-ro)



  • un truc bizarre, nouvelle install, je map mes boutons.

    Je selectionne ensuite le support USB pour les rom, avec déjà des rom dessus.

    Et là, il me change mon mapping !!

    mais toujours rien ne fonctionne...

    En fait il s'avère que tout déconne quand j'utilise le support USB. je viens de remettre le support sur INTERNAL, et même apres le reboot, je retrouve mon mapping, le son sort sur le JACK, bref ça a l'air d'aller...

    Une idée ?



  • j'avance dans ma résolution :
    j'ai mis quelques rom sans les gamelist.xml, et des rom qui ne marchaient pas marchent !

    Je pense qu'en copiant tout d'un bloc ça a du merder quelque part, peut être les gamelist qui ne sont pas compatibles ?



  • Il y a un truc que je pige pas.
    Tu es sur usb et tu penses que c'est ta carte Sd qui a un dysfonctionnement?


  • Staff
    Developer
    Global moderator
    Creator
    Team

    @lainbebop

    /dev/mmcblk0p8 on /recalbox/share type ext4 (rw,noatime,data=ordered)
    

    tout à fait normal... du coup je ne vois pas trop ou est le soucis.



  • gamelist.xml ou recalbox.conf miteux sur ta clé USB.

    Les mappings sont aussi stockés sur la clé 😉



  • @ian57 je ne comprends pas? Qu'est ce qui est normal? A quoi sert cette commande ?
    Merci



  • Ian57 annonce que ton média de stockage (USB) est bien monté dans recalbox
    Par contre relis bien substring il a pas tord tu as tes réglages (anciens) dans ton disque dur qui restent. Et ils perturbent ton installation.
    J'ai eu le même problème.
    Résolu en réinstallant recalbox, et en vidant le DD de tout sauf les rom save screenshot et j'en passe... j'ai branche le DD.
    Recalbox a créé des nouveaux fichiers sur le DD et plus de problème...
    Édit : j'ai dit DD mais c'est valable pour clés usb



  • @godhunter74 je n'ai copié que mon répertoire rom, ce qui veut dire que ce qui fait bugger est les fichiers gamelist.xml?
    Je vais les ajouter un par un on verra bien



  • @lainbebop ne copie pas les gamelist.xml, je parie que ca va marcher



  • @Substring
    Yes pour l'instant ça fonctionne même si je n'ai pas encore tout ajouté!

    Une idée de ce qui pourrait merder dans les gamelist.xml ?

    J'ai pas envie de tout rescrapper, j'avais tout fait avec je ne sais plus quel logiciel en tapant des lignes de commande sur mac 😭


Log in to reply
 

Want to support us ?

231
Online

80.5k
Users

21.6k
Topics

158.2k
Posts