Ps4 Controller on Recalbox 4.1.0



  • I'm having issues trying to get my PS4 controller to work on Recalbox 4.1.0 using both a CSL dongle and the internal Bluetooth.

    If i try to pair it most times it will say "no controller found" almost right away but sometimes if you keep trying over and over it picks up a MAC address, sometimes 2 if i have previously paired the controller to the Pi 3.

    alt text

    Once it pairs it will say it has paired

    alt text

    But once you do this it won't work, there is no controller found in the button configuration and only "DEFAULT" listed in the controllers settings. Also pressing the PS button to pair up to the Recalbox after it has pair will just lead to the controller flashing white, it never does anything different.

    I have tried resetting 2 controllers, forgetting the bluetooth controllers, tried the internal BT as well as my CSL dongle, tried to set it up manually in SSH, nothing works. I even took my controller back to the store as i thought it might be faulty but nope.. the second controller won't work either.

    Please help :(



  • I've just tried with the new controller and also with a fresh install of the latest unstable release. Still not working in the GUI and SSH.

    Output from SSH:

    hcitool scan

    Scanning ...

    hcitool scan

    Scanning ...

    hcitool scan

    Scanning ...

    hcitool scan

    Scanning ...

    hcitool scan

    Scanning ...

    /etc/init.d/S32bluetooth stop

    rm: can't remove '/recalbox/share/system/bluetooth/bluetooth.tar': No such file or directory
    tar: removing leading '/' from member names

    /etc/init.d/S32bluetooth start

    hcitool scan

    Scanning ...

    hcitool scan

    Scanning ...

    /etc/init.d/S32bluetooth restart

    /etc/init.d/S32bluetooth: line 9: 1708 Terminated start-stop-daemon -S -q -m -p /var/run/test-discovery.pid --exec /recalbox/scripts/bluetooth/test-discovery > /dev/null 2>&1
    tar: removing leading '/' from member names

    hcitool scan

    Scanning ...

    Each time I'm scanning I'm pressing the share+PS button to pair it. Each time it just flashes white and doesn't work. It's a brand new controller and fully reset. For now, i have a long USB cable so i'm using that but i would like to get this sorted out if possible as i don't want to be constantly charging my battery in the controller. Won't do it any good.



  • Ok, I've made some small progress...

    It's just randomly started seeing my controller after i took out the new OS SD card and put my old one back in.

    It now shows the MAC and name correctly in the list.

    alt text

    But once paired, like before... it does nothing and the PS button if pressed afterwards will not do anything. DEFAULT is the only listed inputs and configure controller shows 0 controllers found.

    :(



  • Reset the controller and also selected "forget bluetooth controllers" and it's now saying no controllers found again...

    I really don't know, I've been trying to do this for 5 hours now... I don't knbw what else to do. I need help.

    Anyone?


  • Moderator
    Team

    Developers are not available this weekend,
    You will have help on Monday.
    https://www.recalbox.com/blog/blog-2017-04-16-hfs3
    please dont up again your post.

    for @Substring my original ps4 controller pair without problem with internal BT and it use only with recalbox.



  • still not working



  • @dreamscape
    I can recommend a clean reinstallation of whole Recalbox 4.1.0 and then try with Pi 3's just internal Bluetooth only.
    On my Pi 3 it works great with the PS4 controller. - Also installed it at a friend where both PS4 and PS3 controller work perfectly.



  • I have tried with one upgrade install and then 2 fresh installs from the master build image

    https://archive.recalbox.com/updates/v1.0/unstable/

    Nothing works. It will not see it no matter what i try. PS3 controller works flawlessly, plug in USB press PS button and disconnect and it works perfectly on the bluetooth.


  • Moderator
    Team

    @dreamscape we'va talked on irc already, your controllers may have a firmware that doesn't work with linux yet


  • Moderator
    Team

    You need to connect in usb port for this gamepad.



  • @Substring

    Do you have detailled info which controllers will not work?
    Is it maybe the "2016" version, which has the lightbar on another place?
    https://www.psu.com/feature/31122/New-PS4-Controller-vs-original-DualShock-4--what’s-the-difference

    I'm thinking about buying a second controller for my Recalbox, so if the fault is by 2016 version of PS4 controller, I would try to get the "old" version.

    Thanks


  • Moderator
    Team

    @lhari84 said in Ps4 Controller on Recalbox 4.1.0:

    Do you have detailled info which controllers will not work?

    None at all. But it should be the same compatibility as Lakka



  • My PS4 controller worked fine, until I cleared the controllers. Now I am having your problem.



  • I have 2 controllers. After all midnight trying to connect my second controller (Sony Ps4 Wireless v1) i recognized all I can try is useless. But now, connect my raspb, a usb bluetooth stick and my first controller (Sony Ps4 Wireless V2) and it works!!

    Sorry for my bad English, i'm new in this forum and only wanna help.
    Hope everyone can play with the v2 controller, i think that they will fix the v1 connection in the next versions.


  • Moderator
    Team

    @imkeisozo I don't have any PS4 controller. How do you make the difference between v1 and v2 ?



  • I can tell only visual thing.
    In the v2 the buttons are grey and in the v1 are totally black.
    But in software i have 0 idea
    alt text
    The V2 is in the left.


  • Moderator
    Team

    @imkeisozo any model number on the sticker on the back that would differ ?



  • @substring yes, sorry
    V2: CUH-ZCT2E (this works)
    V1: CUH-ZCT1E


  • Moderator
    Team

    @imkeisozo Great thank you


  • Moderator
    Team

    @imkeisozo Just checked with @supernature2k : his v1 pads do work using the internal BT on 4.1


Log in to reply
 

Want to support us ?

Join us on :

366
Online

25422
Users

13333
Topics

101015
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.