Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Wrong Date



  • @Substring I managed to update to 4.1, then i deleted the 2 files /etc/timezone and /etc/localtime. I updated to the test branch but it still have the wrong date:

    date
    Tue Jan 1 11:52:28 ART 1980

    😞


  • Themer

    @cagiraudo

    Did you do it on SSH mount -o remount,rw / and then deleted the files?

    if he did and continued it is strange.

    So you do not waste any more time, you can do is to manually edit these files by accessing them with winscp /etc/localtime edit link and /etc/timezone editing with notepad++



  • @azvarel
    I did mount -o remount,rw / before deleting those files, i confirmed they deleted before updating.

    I don't get the second part, do you want me to manual edit the localtime and timezone files? I use linux, but i will be able to do it, but i don't get what change should i do

    I made cat to those files and had:
    cat timezone
    America/Argentina/Cordoba

    ls -lh localtime
    lrwxrwxrwx 1 root root 14 Dec 31 22:19 localtime -> /var/localtime

    cat localtime
    TZi����0�{R@�ɰ��@�0�}��������@�����x
    ���@�Z�����@��@_07��0ȁ�@�����0ΰ5�d0��l0�2@�柰�C��0�@������S0��R@��50��4@�J$o�#���$��%7�'!0'�)�@)�:�_0+�W 7�ư8��Gw �G H���I�a �������
    ��
    ����LMTCMTARTARSTWARTTZi�����r����������0�����{R@�����ɰ������@�����0�����}����������������@�����������������x
    �������@�����Z���������@������������������@����
    0����7������0����ȁ�@�����������������0����ΰ����5�����d����0����������l0�����2@�����柰�����C������0�����@������������������S0������R@������50������4@�J$o�#���$��%7%�'!0'�)�@)�:�0+�W 7�ư8��Gw�G H���I�a �������
    ��
    ����LMTCMTARTARSTWART
    ART3


  • Themer

    @cagiraudo

    List of timezone (I do not know what city / region you are, I can not say straight)
    https://en.wikipedia.org/wiki/List_of_tz_database_time_zones

    To see my timezone I can use (in terminal) the command:

    `cat /etc/timezone
    America/Recife

    The answer was accurate, I'm in America/Recife timezone.

    To change to the timezone from Recife to Cordoba we will check the name of this time zone doing:

    ls /usr/share/zoneinfo/America/Argentina

    Now look in the list displayed by the desired timezone. We can also search using a search keyword, for example "Cordoba", with the command:

    ls /usr/share/zoneinfo/America/Argentina | grep Cordoba
    Cordoba

    See that in the case I looked for the word "Cordoba" and gave very well. The response to the command indicates that the file named "Cordoba" exists.

    Well, now that we already know the correct file name, let's change the contents of /etc/timezone using your favorite text editor, as in:

    vi/etc/timezone

    or

    gedit /etc/timezone

    or

    mcedit /etc/timezone

    Then change from America/Recife to America/Argentina/Cordoba.

    Now to update using the TZ variable do:

    export TZ = America/Argentina/Cordoba

    Let's check with:

    date


  • Themer

    Editing localtime

    mv /etc/localtime /etc/localtime.old
    ln -s /usr/share/zoneinfo/America/Argentina/Cordoba /etc/localtime
    date



  • you're not supposed to manually edit anything, the update should have added /etc/timezone and /etc/localtime as symlinks to /var/timezone and /var/localtime, both of the latter files are set at recalbox root


  • Themer

    @Substring I know it is not the correct way to do it, but it was this way that I solved it before the gitlab update that you gave me and when I came back to the unstable version, again correct that way and it is working, as I described here https://github.com/recalbox/recalbox-os/issues/1264



  • @azvarel yeah, but i need a way to make it work for everyone, without putting hands in the engine



  • @Substring @azvarel BREAKING NEWS. It is a firewall problem, at least i think so. I changed to another wifi (sharing it with my cellphone) and the date magically updated, no more 1980, it bring me back to 2017.

    So... i know it isn't recalbox problem, but, have you any idea what could it be? Recalbox is conected to internet, it sayed "Conected" and i can update and everything.

    The first time i installed recalbox i have a similar problem that it was connected but it said Not Conected because my firewall was blocking the pings https://forum.recalbox.com/topic/7448/wifi-working-but-still-not-conected, i disabled the firewall (at least i think i did) and the ping worked ant the status now says Conected. Maybe it has something to do with that.



  • @cagiraudo now yourrouter/isp blocks NTP 😉


Log in to reply
 

Want to support us ?

125
Online

78.5k
Users

20.1k
Topics

147.6k
Posts