Recalbox Freezes at Start



  • Hey all,

    Odd problem here. I've been using recalbox for a while now. No issues whatsoever. I decided to try to install the 4.1.0 unstable, but ever since the the system would freeze. I've tried 100s of different methods and tried to isolate each different part with no success, so I turn to the experts for some additional guidance.

    More specifically, when I reinstall Recalbox, it works, but it appears that everytime I try to switch over to read from external usb, I reset and it freezes. No access via SSH, no sound.

    Equipment, Rpi 2, Sandisk 32 GB card with various external flash drives that i've tested.

    I've Tried different power sources and adapters
    Different TV sets
    Different cables.
    Different External SD Card
    Reinstalled recalbox dozens of times.
    Updated the system.

    Any other tips for now?

    Thanks!



  • Hi,

    What do you mean "freezes" ? When does it happen ? While booting ? Playing ? Staying idle for a while ?

    Have hou tried using an img instead of upgrading ?



  • @Substring thanks for the response and sorry for the vague details.

    What happens is once recalbox boots into emulationstation, it freezes (or at least appears to). There is no background music and I cannot control emulationstation (or load kodi on X) with any controller, wired or wireless.
    Additionally, even though the light on my USB flash drive is indicating power, and it appears to be reading/writing based on the flashes when recalbox boots, once emulationstation loads it doesn't seem to read from the USB. I assume this because emulationstation states 1 game in SNES, the game included in recalbox instead of the many of games on the USB. Somehow this is the culprit, but I don't know how to proceed.

    I even reformatted the flash drive (FAT32) and started from scratch.

    I have used the 4.0.1 img, but cannot find the img for 4.0.2.



  • @sag508 there is no .img for the 4.0 branch ...

    Does the same happen without your USB key ?



  • @Substring gotcha on the 4.0 branch...but yes, the same thing happens without the key.

    After trying reinstalling from scratch, and literally changing 1 setting and copying 1 directory at a time, it appears to be an issue when system.power.switch=PIN356ONOFFRESET is uncommented. Not 100% sure yet.

    I do have 2 push buttons wired into the GPIO that worked fine. I may have to investigate further to see if some kind of wiring issue happened. Usually when there is an issue I get a SSH job error at boot and emulationstation never starts.

    This is the first time I've ever seen it freeze. It may be some kind of coincidence that I started the update at the same time.



  • @sag508 can you still log on a local tty ?



  • @Substring I am not sure what TTY is. I was not able to connect to it through Putty through wifi.

    I set up two flash drives, with identical settings and files, with the exception being 1 having PIN356ONOFFRESET enabled, and one disabled. I started with disabled one first and it booted with no issues. I removed the USB drive, rebooted again with no issues. I finally loaded the enabled one. It booted to the splash screen. It first said "LOADING", then it changed to "PLEASE WAIT..." It then crashed to a black screen. I disconnected the power from the wall and reconnected. It booted fine. I pushed the reset button and booted fine again. I hit the power button to shut down and hit it again to boot. It crashed like before. I hit the power button again and it loaded fine. After a series of starts, resets and power offs and I am unable to reproduce the freezing or crashing.

    I now suspect the "crashing" was actually a shutdown script being executed, but can't explain the freezing. Nor can I explain why I am unable to reproduce the problem. Things appear to back to normal.



  • @sag508 by local tty i mean : plug a usb keyboard, press F4 to quit ES then ALT+F2 to open a terminal



  • @Substring gotcha. I do not have a USB keyboard to use, so I can't use TTY.



  • @sag508 can you at least reach network shares and write inside ?



  • @Substring negative on reaching network shares.

    OK i think i finally nailed down the issue. I think i need to start with a fresh USB drive. I changed the original recalbox directory to something different (i.e. recalbox-old) and allowed recalbox to set it up after a new install. I then just copied ROMS, Saves, BIOS, Cheats and the themes directories to the new recalbox directory. Doing it this way netted zero issues (although I had some issues with syncing my bluetooth controllers, but it eventually resolved itself after all updates and setting up was done.)

    This seemed so trivial, especially since my entire experience with Linux involved 3 college credits 10 years ago. If this makes sense on why I had all of these issues, please accept my apologies for wasting your time.



Want to support us ?

217
Online

80.4k
Users

21.5k
Topics

157.4k
Posts