Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

N64 emulator does not launch when certain gamepad is connected



  • Hey everybody,

    I'm using recalbox 4.0.2 on a raspberry pi 3 and I have encouterd some difficulties with the n64 emulator.
    When I'm playing with my xbox 360 gamepad everything works fine. But i recently bought some generic usb controllers (https://www.amazon.de/gp/product/B017DD4B9C/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1) and if one of these controllers is connected to the pi I cannot launch games with the n64 emulator.
    I can navigate to the list with all the games but if I want to start a game there is this short recalbox loading screen and then I return to the list to select a game.

    All the other emulators seem to work...

    Any ideas on how to fix this problem would be highly appreciated 😉





  • Thanks for your reply!
    Yeah I think it should be the RetroUSB SNES pad.

    The funny thing is I can configure the controller normally and even play games on other emulators with the controller connected.

    When the SNES-pad and the xbox-controller is connected to the pi I cannot launch the n64 emulator and if I unplug the SNES-pad I can launch it normally without rebooting the pi or anything.

    So I'm really confused...

    EDIT: on the german amazon link some people even mention that they use this gamepad for recalbox and it works fine...



  • @qawert when both pads are plugged, which pad is the 1st players ? the x360 one or the other ? Just out of curiosity, try forcing the x360 pad first and tell me if it worked.

    If not, I'd need you to do a few commands to check what failed



  • @Substring thanks for your reply!

    I tried forcing the x360 pad to be controller one and it's still the same problem



  • @qawert ok. So by SSH, relaunch ES /etc/init.d/S31emulationstation restart then make a pastebin of the output once you launched the rom that crashed.



  • @Substring

    /etc/init.d/S31emulationstation restart

    lvl0: System "favorites" is missing name, path, extension, or command!

    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    Traceback (most recent call last):
    File "/work/output/target/usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", li ne 151, in <module>
    command = generators[system.config['emulator']].generate(system, args.rom, playersControll ers)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenGenerator.py", line 2 0, in generate
    mupenControllers.writeControllersConfig(playersControllers)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenControllers.py", line 40, in writeControllersConfig
    config = defineControllerKeys(player)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenControllers.py", line 70, in defineControllerKeys
    config['Z Trig'] = setControllerLine(controller.inputs['x'], "Z Trig")
    KeyError: 'x'



  • @qawert you don't have the X key mapped on a pad



  • @Substring haha ok I alway used the x-button as the hotkey... Didn't knwo this could be a problem but now I'm a bit embarassed. 🙂

    Thanks so much for helping me out!



  • @qawert use select as hotkey 😉



Want to support us ?

150
Online

78.5k
Users

20.1k
Topics

147.5k
Posts