Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Can the web based recalbox manager be bypassed?



  • Hi,

    I just ran the update (postponed for a long time) and I'd like to be able to upload files via Windows explorer, but when I enter the recalbox's IP address, it automatically opens the web based manager, which seems to have a problem with a bunch of file formats, not showing many on the system and not letting me upload many more. Any ideas how to bypass this? I've also tried ftp clients, but they seem very slow and unreliable.

    Thanks in advance.


  • Global moderator
    Team

    Hello
    you need to use winscp, or other software or shared network.

    you must be disabled recalbox manager in recalbox.conf

    ## Recalbox Manager (http manager)
    system.manager.enabled=0
    


  • @trantornator in Windows explorer use like address \\ip_of_your_raspi or \\recalbox not http://ip_of_your_raspi



  • Hi guys,

    I changed the system manager settings in the config and was able to deactivate the web interface, but it is still not showing up on my network through windows explorer. I can still log in through Putty and and WinSCP. Any way to get a more direct connection going than through ftp? Is there some setting in recalbox that would add a necessary permission, perhaps? I'd like the speed and accessibility that copying over my home wifi would achieve.



  • @trantornator If u have tried \\recalbox in address bar on windows explorer and it does not work, then check in recalbox.conf that Samba share

    ## Samba share
    system.samba.enabled=1
    

    is enabled.
    After that if still dont work make sure that client for Microsoft networks protocol and file and print sharing protocol are enabled in your Windows OS.

    Something like that:
    Client for Microsoft Networks



  • @Pepe Which directory is the config file in, for me to edit it via telnet? Now that I've deactivated the web based interface, I can't find the config file. 🙂



  • @trantornator in putty session /recalbox/share/system/recalbox.conf



  • @Pepe sorry to be a pain, but is there an editor installed in recalbox's command line? I tried a sudo command but it didn't work and couldn't recognize any editing commands under the help menu



  • @trantornator u don't need sudo, you logon as root.
    Take a look at this:
    https://github.com/recalbox/recalbox-os/wiki/Root-access-on-terminal-(EN)

    Once connected use nano to edit recalbox.conf:
    nano /recalbox/share/system/recalbox.conf
    Save changes if needed with: Crtl+o.
    Exit with: Crtl+x.



  • @Pepe, I checked and the samba system is set to 1 and my network print and file sharing settings are also on (and have been the whole time). Still not being found by Windows Explorer under either \recalbox nor the IP address.
    Two other devices, a Chromecast and a Fire Stick are both showing up and accessible.



  • @Pepe, I just turned off my firewall and it's working. Thanks for all the help, I now know a lot more about how this thing works. Hopefully I can help someone else in the future. 🙂



Want to support us ?

170
Online

78.4k
Users

20.0k
Topics

147.4k
Posts