Pantalla descolocada y franjas negras



  • Hola, soy nuevo en el foro y no se si este es el lugar para poner la consulta... He conectado mi raspberry a una pantalla plana de PC con un adaptador HDMI-vga y cuando arranca recalbox se ve genial y a pantalla completa, pero cuando pongo un juego se desplaza la pantalla, ya sea poniendo a 4:3 o a 16:9... A veces salen franjas negras a los lados, desplazado a la izquierda y lo que siempre pasa es que se "come" la pantalla en la zona de arriba... He leído sobre overscan y cambiado algunos valores pero no consigo que se vea bien. Por favor, si alguien sabe como resolverlo agradecería mucho su ayuda, gracias de antemano.


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Bienvenido. Te aconsejo siempre buscar en la wiki porque esta llena de tutoriales para resolver este tipo de inconvenientes.

    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    Ajusta el global.videomode en tu recalbox.conf haciendo uso de tvservice (como se indica en el enlace anterior). Muchas veces tambien es el mismo monitor/televisor que modifica la imagen, o sea que revisa mejor si se te ofrece la posibilidad de ajustarla.



  • @paradadf en el menú del monitor tiene varias opciones para ajustar automáticamente la imagen, moverla hacia arriba y abajo y lateralmente, pero aún así en algunos lados había franjas negras y arriba se cortaba la imagen. Leí algo sobre el overscan y en el menú recalbox lo intente configurar pero no se resolvía (no se si lo haría correctamente). Voy a ver el tutorial del enlace y para ver si algo se soluciona, ya comentaré que tal ha ido y por cierto, muchísimas gracias por la ayuda



  • Perdón pero no he tenido mucho tiempo y he vuelto a retomar el proyecto de mi bartop. He cambiado alguna línea de la configuración de recalbox pero sigo con el mismo problema y no se muy bien que hacer, por favor necesito que alguien me ayude con el problema.0_1486582439422_1486582399773549861172.jpg 0_1486582490883_1486582480062708109739.jpg 0_1486582549444_1486582527606-840534309.jpg


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Conectado por SSH:
    https://github.com/recalbox/recalbox-os/wiki/Root-access-on-terminal-(EN)

    ejecuta:
    tvservice -s
    tvservice -m CEA y tvservice -m DMT

    copia y pega la respuesta aqui, utilizando tres apostrofes ``` antes y despues del codigo para cuestiones de formato.



  • @paradadf he hecho fotos a lo que me salía en la pantalla, a ver si así vale para que me podáis ayudar0_1486590352148_IMG_20170208_224254.jpg 0_1486590367439_IMG_20170208_224333.jpg 0_1486590381146_IMG_20170208_224415.jpg



  • Faltaba esta0_1486590610294_14865905925711539733248.jpg


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @aj9 te ha faltado la de CEA, pero da igual

    Entra a recalbox.conf para editarlo (lo podes hacer escribiendo la ip de recalbox en tu navegador) y edita la linea que dice global.videomode y dejala asi:
    global.videomode=DMT 4 HDMI
    luego reinicia.



  • @paradadf esta solucionado!!!! Muchísimas gracias, eres un crack! Ya se ve bien, con la pantalla centrada. Ya estaba desesperado y no sabía cómo se podía solucionar porque había leído muchas configuraciones de overscan, casi ni me lo creo. De verdad muchas gracias
    0_1486665371456_1486665355603735200026.jpg


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @aj9 me alegro que haya funcionado. Siempre es un gusto haber podido ayudar. Pero ojo, esa informacion estaba en la wiki (en ingles, lo se... pero mientras nadie ayude traduciendo no queda de otra).



  • @paradadf perdona que te moleste pero vuelvo a tener el problema de la pantalla descolocada... Dejé a mi hermano la micro SD para otra raspberry y me la formateo, no se como se apañó... Me volví a bajar recalbox y metí alguna rom y la pantalla sale desplazada, hice lo que me dijiste la otra vez, poner CEA 4 HDMI y sigue igual...
    0_1492167589928_IMG_20170414_122945.jpg

    0_1492167607000_IMG_20170414_123007.jpg

    0_1492167625401_IMG_20170414_123025.jpg

    0_1492167644133_IMG_20170414_123206.jpg

    0_1492167700249_14921676505921276742430.jpg



  • Perdón, me refería a que pongo DMT 4 HDMI y guardo pero al reiniciar vuelve a salir CEA en vez de DMT, lo hago desde el navegador con la IP de la raspberry



  • Ya me sale centrada, al final lo conseguí! Pero ahora no me sale a pantalla completa, tengo el overscan activo que leí q por eso podría ser... Alguna idea?



  • This post is deleted!

  • Staff
    Developer
    Team
    Global moderator
    Translator

    @aj9 revisa si tu monitor no tiene algun ajuste automatico de imagen. Muchas veces es tan simple como presionar un boton. Si no lo tiene, activa el overscan (creo que ya esta traducido como sobreescaneado en la 4.1) y reinicia. Si aun asi seguis con bordes negros tendras que ajustarlo manualmente en la config.txt.



  • Lo del botón lo probé está mñn y no hacía nada y el overscan está activado. Voy a comprobar si metiendo valores manualmente se agranda la imagen. Muchas gracias de nuevo por todo



Want to support us ?

242
Online

80.3k
Users

21.5k
Topics

157.2k
Posts