Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

GPIO not working, Dreamcast emulator recalbox 4.1



  • Hello,

    I tested today guilty gear on dreamcast emulator using recalbox v4.1. USB controller a Bluetooth PS4 controller work ok. But if I use gpio no button or stick is working.

    GPIO works fine in MAME and FBA libreto

    Thx



  • @LeSoquiaque hi

    Maybe because the game can't be played with a dpad ? I didn't try with gpio, but the ~/configs/reicast/emu.cfg should be filled



  • Hi,

    This is the information from files,

    emu.cfg

    [input]
    evdev_device_id_1 = 0
    evdev_device_id_2 = 1
    evdev_device_id_3 = -1
    evdev_device_id_4 = -1
    evdev_mapping_1 = /recalbox/share/system/configs/reicast/controllerP1.cfg
    evdev_mapping_2 = /recalbox/share/system/configs/reicast/controllerP2.cfg
    joystick_device_id = -1

    controllerP2.cfg

    [compat]
    btn_trigger_left = None
    btn_trigger_right = None

    [emulator]
    mapping_name = GPIO Controller 1
    btn_escape = None

    [dreamcast]
    btn_b = None
    btn_a = None
    btn_x = None
    axis_y = None
    btn_start = None
    btn_y = None
    axis_x = None

    Thx



  • I change my sdcard with fresh 4.1 installation, only gpio and all games work ok in dreamcast. Any idea what happened?



  • @LeSoquiaque no idea, bad compilation ? Wrong packages ? Someone who is not used to buildroot and Recalbox can make mistakes on rebuilding



  • @Substring the image I use in both cards is the same. Anyway problem solved, than you.



  • @LeSoquiaque ,
    Sorry for my stupid English, I did not quite understand, you said that when reinstalling everything worked, is that it? I just installed and found problem in 2 emulators PSP and Dreamcast, in the PSP does not move down and also to the right and no button quits the emulator, In dreamcast I can move sideways but no button works, impossible to continue in the other Emulators everything works perfectly, I using the PS3 wireless controls also works normal on PSP and Dreamcast, do I need to reinstall the package again? Thank you ....



Want to support us ?

169
Online

78.5k
Users

20.1k
Topics

147.5k
Posts