Recalbox ne démarre pas depuis réglage sur disque dur externe



  • Bonjour à tous,

    Recalbox ne démarre plus depuis que j'ai été dans les réglages et choisi mon disque dur externe comme source.

    J'ai déjà réinstallé complètement Recalbox et effectué une seconde fois ce réglage, ça a de nouveau créé le même problème.

    Recalbox commence à démarrer puis s'arrête subitement. Je n'ai donc pas le temps d'accéder via ssh ni de revenir sur mon réglage.

    Je précise que mon disque dur externe fonctionne très bien dans Kodi.

    Que puis-je faire ou tester sans devoir de nouveau tout réinstaller?

    Merci d'avance pour vos suggestions.


  • Moderator
    Team

    Ton disque doit mettre trop longtemps à s'initialiser, ou alors il a des partitions bizarres. Si tu débranches ton disque, même problème ?



  • ou un fsck.fat32 est en cours



  • @Substring Effectivement, si je débranche le disque externe, recalbox démarre. C'est tout bête, mais je n'avais pas fait ce test. Merci pour l'idée mon brave.
    Bon, maintenant, comment puis-je utiliser ce disque pour stocker les roms?



  • @foups J'ai mis toutes mes roms sur mon disque dans le dossier Recalbox/roms en respectant les dossiers de chaque émulateur.
    Je démarre Recalbox sans le disque puis, une fois démarré, je rebranche le disque puis je fais Reglages/jeu/mettre à jour la liste des jeux -> ils n'affiche toujours pas mes jeux. ?!?
    J'aurai encore besoin de vos lumières.

    Le disque est en ntfs, et son nom apparaît bien dans les réglages système/disque externe.


  • Moderator
    Team

    Le chemin est /recalbox/share/roms

    Si tu viens de recalbox 3 larborescence nest pas la meme.

    Ton disque dur etant en ntfs il est trop lent pr etre monté.

    Voir lastruce maxtry en faisant une recherche sur le forum.



  • @foups Il y a du mieux.
    J'ai fait la mise à jour de Recalbox.
    Maintenant quand je démarre le Raspberry avec le disque dur branché, il commence à charger Recalbox (écran blanc avec l'image Recalbox "chargement..."), je vois le disque dur travailler (en lecture/écriture (ce qu'il ne faisait pas avant).
    Mais le chargement de Recalbox s'arrête sur l'écran noir avec la petite icône recalbox blanche en bas et le num de la version (4.0 rpi3 build 23 2016/10/31).
    Le disque reste allumé mais ne travaille plus.



  • @foups Je n'y arrive toujours pas.
    J'ai bien suivi les 2 procédures suivantes:
    https://github.com/recalbox/recalbox-os/wiki/Auto-mount-of-usb-in-place-of-share-partition-(EN)

    et

    https://github.com/recalbox/recalbox-os/wiki/Use-an-external-usb-storage-device-on-recalbox-(EN)

    Le dossier share ne se crée toujours pas sur mon disque externe dans recalbox
    Après plusieurs tentatives infructueuses, j'ai creusé un peu plus du côté du fichier fstab:
    Je n'ai pas la ligne "/dev/mmcblk0p7 on /recalbox/share type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)" que je dois commenter.

    La procédure me dit d'ajouter "/dev/sda1 /recalbox/share vfat defaults,rw 0 0". Ce que j'ai fait dans un premier temps. Mais après j'ai vu que mon disque n'est pas en vfat mais bien en fusblk, j'ai donc ajouté cette ligne "/dev/sda1 /recalbox/share fuseblk defaults,rw 0 0"

    J'ai également ajouté le format fuseblk au fichier usbmount
    Mais là, ça me dépasse. Je bloque.

    (Je suis sous Recalbox 4 avec un Raspberry 3)



Want to support us ?

Join us on :

235
Online

27395
Users

14104
Topics

106999
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.