Recalbox 7.0

Ecran noir au démarrage avec convertisseur HDMI-> DVI : j'ai tout essayé mais ça ne marche pas !



  • Bonjour,
    je sais que le sujet n'est pas nouveau mais j'ai le problème d'écran noir au démarrage de mon pi2 avec recalbox 4.0.0 (même pas d'affichage de la mire arc-en-ciel au démarrage).
    J'ai lu tous les topic sur le sujet, testé toutes les modifications :

    • hdmi_drive=2 commenté ou hdmi_drive=1,
    • pas mal de résolutions via les paramètres hdmi_group=2 et hdmi_mode=xx,
    • bidouillé d'autre paramètres du fichier config.txt,
    • et bien sur modifié le recalbox.conf pour positionner le global.videomode=default (voire avec les DMT XX HDMI correspondant au paramètres positionnés dans le config.txt),
      bref j'ai presque tout essayé et rien n'y fait.

    Ma config :

    Le plus rageant dans l'histoire c'est que le RPI avec une autre distrib (Raspbian au hasard) fonctionne sur cet écran avec ce cable et cet adaptateur.
    Depuis que j'ai installé Recalbox sur le RPI ... plus rien.

    Quelqu'un a t-il une idée je commence à désespérer ?

    Merci par avance.

    Nico


  • Global moderator
    Team

    Bonjour @nico33
    au vu des modifications que tu as faite, ça serait mieux de repartir de 0 et recommencer pas à pas avec l'aide de la communauté.

    Tu n'as pas donné d'information sur ta mirossd mais il est conseillé pour recalboxOS d'avoir une scandisk class 10 de 8Go/16Go minimum.

    Dans un 1er temps :

    • reformate ta microsd en fat32 avec sdformatter (sous windows 7) ou minitool partition wizard (formater fat32 as primary) (sous windows 8-10)
    • Vérifie bien dans l'explorateur windows que ta partition soit en fat32.
    • Télécharger la dernière version de recalbox 4.0.0b5 , il est important d'avoir le système à jour.
    • Décompresse et copie TOUT le contenu de l'archive à la racine de la microsd.
    • Conserve dans le dossier OS sur la microsd uniquement le dossier recalboxOS-rpi2
      Je te conseille de faire l'installation complète à partir de ta TV en hdmi.
    • Une fois fait nous pourrons modifier les 1ers fichiers.

    Connecte toi en ssh via putty ou configure winscp avec putty

    • Partition en écriture : mount -o remount,rw /boot
    • editer /boot/config.txt , commente cette ligne : #hdmi_drive=2 sauvegarde et reboot.
    • editer recalbox.conf , modifier global.videomode=default, sauvegarde et reboot.
      Branche ton cable hdmi/dvi et dis nous ce qui ne va pas.
      Si toujours des soucis, via ssh execute la commande suivante : /recalbox/scripts/recalbox-support.sh lire tuto et upload l'archive.


  • Il y a un coup à jouer avec Raspbian dans le pire des cas : dumper l'EDID de ton écran.

    Tu as l'arc-en-ciel au boot ou pas ? L'écran de noobs ? Tu as vu la procédure d'installation de recalbox dans Noobs ?



  • Bonjour,

    merci pour vos réponses.

    La description de mon problème et de mes manip était peut-être un petit peu trop synthétique mais j'ai bien effectué les modifications par étapes ciblées (même les reformatage et réinstallation complète sur TV en HDMI).
    Petite info complémentaire : je bosse sur Mac OS.

    Les seuls manip que je n'ai pas essayé sont :

    • la conservation du dossier RPI2 uniquement,
    • le recalbox-support.sh,
    • la récup de l'EDID de l'écran avec Raspbian (et oui j'avais l'écran arc-en-ciel au démarrage de Raspbian).

    J'essaie de tester tout ça ce soir et je vous tiens au courant.

    Merci.



  • si tu as l'écran arc-en-ciel, faudrait tester le mode passe partout dans le config.txt, j'ai oublié le nom de l'option ... safe qqc ... Et si tu as vu noobs à l'install, c'est très important aussi

    Tu peux nous faire un pastebin de ton config.txt stp ?



  • Bonjour,

    après quelques manipulations et quelques moments de désespoirs, j'ai fini par trouver la source de mon problème.
    En essayant un faire fonctionner l’écran avec Raspbian (même symptômes que la Recalbox dans un premier temps), j'ai modifié un paramètre video via VNC : l'overscan !

    Et effectivement en désactivant l'overscan j'ai pu bénéficier de mon écran en DVI sur Raspbian (enfin !).

    Du coup de retour sur ma Recalbox, j'ai de nouveau édité le fichier config.txt pour positionner l'overscan à 0.
    Et avec les autres modifications effectuée au par avant ... miracle !

    Donc je récapitule pour ceux qui rencontreraient le même type de problème :

    1/ Dans le fichier recalbox.conf (celui qui est également accessible depuis l'interface web de la Recalbox) :
    global.videomode=default

    2/ Ensuite dans le fichier config.txt :

    • editer /boot/config.txt (attention bien suivre la proc dans la reponse d'Acris au dessus),
    • commenter la ligne : #hdmi_drive=2
    • modifier la valeur du paramètre overscan (mettre overscan=0 à la place du overscan=1 présent dans le fichier),
    • sauvegarde et reboot.

    Normalement avec ça l'écran fonctionne.

    Merci à Acris et Subs pour leur aide.



  • Bonjour j'aurais une question en rapport avec le problème d'écran. Ou trouver le fichier /boot/config.txt dans winscp. J'ai bien recalbox.conf. mais je trouve pas /boot/config.txt Merci d'avance


  • Global moderator
    Team

    Ben à la racine dans le dossier boot.
    Voir le wiki pr la configuration complete de winscp.
    Merci deviter de remonter des sujets resolus.
    Creer ton propre sujet.



Want to support us ?

135
Online

79.1k
Users

20.3k
Topics

149.1k
Posts