Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

External drive recognized but ignored



  • I just installed a dual boot recalbox image a la Matt Huisman (http://www.matthuisman.nz/2015/11/recalbox-kodi-dual-boot-images.html) for raspberry pi 3. It is the most up to date version of recalbox as best I can tell. I have everything set up and I can change my storage device to external. When I do that, I reboot as I should so that it can create the share folder on the external device (based on what I've read). However, when I go back into it, it is still not looking at the drive, but instead still reflects the microSD storage. It displays the drive as the storage type, but it is not actually looking at it. I know I read that recalbox can now support NTFS, but I have tried it multiple times on both an NTFS drive and an exfat flash drive formatted with SDFormatter...both do the same thing - they show like they're being used but they aren't actually being looked at. I've rescanned my games after changing the device and that hasn't helped.

    One thing to note is that the recalbox is not actually creating the share file structure on the external device when it reboots (as I think it should). I have gone in and manually copied the file structure to the devices thinking that could be it, but nothing has changed.

    This is truly frustrating because it is my first go at anything raspberry pi and everything I've seen online about this particular setup seems so straight forward but this is just not working.

    Any ideas?

    Thanks,

    Jason

    alt text


  • Banned

    @jwoodford Kodi is already integrated into Recalbox so maybe just use the official release instead of some random double boot made by some random guy which is even speaking of Lakka in his post ?

    Also it's much better at least for performances to use a Fat32 formatted HDD



  • @voljega Can you please tell me how to get back to Recalbox once I get into Kodi? I had the standalone installed from this site but could not for the life of me find out how to get back to Recalbox. The reason I liked this dual boot was because it allowed me to put the shortcut to Recalbox on the shortcut menu.

    I'd need it to be easy to do because I am setting this up for my wife to have access to some things while she is away on travel nursing assignments. I'm pretty tech savvy but she needs things K.I.S.S. lol.

    Thanks,

    Jason


  • Banned

    @jwoodford sadly I'm not using Kodi so I don't know, but someone should be able to help you.
    Did you read the wiki ? (At least manual and HowTo pages) it should be in there somewhere



  • @voljega Well, I reloaded just the installer from Recalbox and was able to figure out how to get back to Recalbox from Kodi this time. In hindsight, I don't know how I missed it in the first place. Recalbox does now properly look at the drive I tell it to for external storage in the sense that it shows the proper data usage/availability. However, it is still not creating the share file folder on either external device I have tried and it will not read the games I've loaded into the folder structure I copied from recalbox either. I've rescanned games list and made sure the files are in the same locations as the sample games provided.

    Surely I'm not the only one with this issue, am I?

    Jason


  • Banned

    @jwoodford it won't work anyway if it doesn't manage to create the share folder on the hdd by itself.

    I think someone had the same problems as you maube @rockaddicted or @subs will be able to help you



  • why sould I bother with some forks ?

    anyway, @jwoodford i need the output of a ls -la /boot



  • @subs I'm sorry, but I'm having a hard time understanding that. Forks? Are you asking me to provide you with something?

    Thanks,

    Jason


  • Team

    @jwoodford a fork of a software is a copy with modifications. He referred to the fact that you have or had installed a dualboot image (not the official recalbox image). So he is not willing to give support for that image. If you need help with that particular image you better ask the one who made it.

    Now about ls -la /boot: What subs asks you to do is to connect to your recalbox via ssh (if you are using Windows check out PuTTy, if you are using linux you should know what's todo). The when you have a ssh connection to your recalbox enter ls -la /boot into the shell. Then past the output here.



  • @Robsdedude doh 😮 You understand me ? 😄



  • Old topic but just wanna reply.

    I have the same problem. it's never have been solved for me the easy way. Every time on every build, even the newest builds from Recalbox.

    Every time i have to do the settings by hand. Set: Maxtry=15 in the file etc/init.d/S11share

    Then the External Drive WD Elements 2TB formatted NTFS is recognized in Recalbox and puts the share folder named Recalbox on it. Then the problem is solved for me.


  • Global moderator
    Team

    Hmm Ntfs is very very slow. You need MBR boot not GPT boot.
    You need format fat32 for recalbox 4.0.2.

    But if it s ok with your ntfs hard drive very good.



Want to support us ?

110
Online

78.5k
Users

20.1k
Topics

147.5k
Posts