4 Player Zero-Delay Encoder Setup Help



  • Hello,
    I am needing some help configuring a 4 player Zero-Delay Encoder setup.
    I have 4 Zero-Delay Encoders that are being displayed as Dragonrise Inc Encoders.
    lsusb lists each device
    BUS 001 Device 007: ID 0079:0006
    BUS 001 Device 009: ID 0079:0006
    BUS 001 Device 010: ID 0079:0006
    BUS 001 Device 011: ID 0079:0006

    I can go through Menu > Controller Settings > Configure a Controller and configure each encoder
    Under input P1 through P4 the only information i can see is
    #0 Dragonrise INC. ...ick
    #1 Dragonrise INC. ...ick
    #2 Dragonrise INC. ...ick
    #3 Dragonrise INC. ...ick

    When loading up an emulator for example Snes players 1 and 2 configurations go out of whack. As in the buttons configurations that were previously setup up dont stick. For example Player 2 A,B,X,Y buttons become split up over player 3 and 4 randomly .

    Arcade games through Mame or Flibretro has the same issue except player 3 seems to only be able to access the Emulator menu i.e take screenshots, access menu etc. This player cannot play a game.

    Can someone help me set this up correctly to identify each Player and configure each player to work across all emulators. I was thinking i need to manually set each players configuration in a file somewhere but i have no idea where to start.

    Any help will be greatly appreciated


  • Moderator
    Team

    Hello
    can you type command line in ssh : /recalbox/scripts/recalbox-support.sh
    upload zip archive http://www.zippyshare.com/





  • i wonder if retroarch is not lost in all those pads ... 4 times the same one, no idea how it can sort everything out.

    Could you make a pastebin of #/configs/retroarch/retroarchcustom.cfg ?



  • @subs said in 4 Player Zero-Delay Encoder Setup Help:

    i wonder if retroarch is not lost in all those pads ... 4 times the same one, no idea how it can sort everything out.

    Could you make a pastebin of #/configs/retroarch/retroarchcustom.cfg ?

    I think you are right. Need to find a way to define each pad with some type of identifier that will point the correct configuration to each one.

    Heres the pastebin

    http://pastebin.com/gP1RhAYu



  • @acidrs give a try ti the sdl2 driver instead of udev. You have to edit the recalbox.conf. Can't remember the real name of the var, something like input.driver



  • @subs said in 4 Player Zero-Delay Encoder Setup Help:

    @acidrs give a try ti the sdl2 driver instead of udev. You have to edit the recalbox.conf. Can't remember the real name of the var, something like input.driver

    Ok ive changed to the sdl2 driver the var is
    global.inputdriver=sdl2

    Im going to do a fresh install as the system is giving me some funky behaviour after updating to the Recalbox 4 beta 5.
    Selecting any game loads the wrong game, im also getting an issue where after loading a game the main emulationstation menu loads back up after a couple of seconds with the game still loaded in the background.


  • Team

    Did you modified anything in /etc/init.d ? Seems like your are having two emulationstation started ...



Want to support us ?

Join us on :

376
Online

30875
Users

15088
Topics

113602
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.