NES30 pro - B Button and Hotkey the same?!



  • Hey there,

    I just bought a 8bitdo NES30 Pro to use it with my Raspberry PI with RecalboxOS. Now I got a problem. I have to configure the controller and I want to use the Connect Button as Hotkey, but everytime I wanna configure it, it assigns the 'B' Button as Button 1 and the Connect-Button also. So it's used twice. And of cause both doing the same. So everytime I press B the menu of the emulator opens up...

    What am I doing wrong? Is the controller faulty, or is it just not possible, to use the connect button as Hotkey?

    Already flashed it on different Firmwares... And also rebuild Recalbox OS... Also tried 4.0.0 beta 5... Same issue

    Sry for my bad english, but I hope you're able to read and understand it ;)

    Greets,
    Daniel


  • Team

    Use select or l3.



  • Ye, that should work, but I would like to use the Connect-Button....

    The strange thing is, that it worked, but after a few other problems and reinstalling recalbox the buttons mixed together...

    Maybe the controller is broken by flashing?!


  • Team

    Did not test the last firmware, i will take a look.



  • I already tried different firmwares, but since is occured the first time, nothing changed while I flashed the different firmwares.

    But it would be nice, if you could test if the behaviour is the same on your system.



  • Hmm,

    do you or someone else here got any further informations? Would be nice, if someone can test, whether he got the same, or its a failure by my controller...


  • Moderator
    Team
    Moderator
    Translator

    Afaik the connect button refreshes the bluetooth conection and isn't a 'button' itself. Do you get any response by jtest?
    https://github.com/recalbox/recalbox-os/wiki/Test-your-joystick-with-jstest-(EN)
    Why don't you just use L3 instead and spare you the trouble?



  • Hmm, didn't use test till now... Will try it while vacation at the end of the next week and tell you what test is responding.

    Yeah, maybe ur right and I should just use another button, but I thought maybe I just got an faulty controller and wanted to get this cleared for me ;)



Want to support us ?

Join us on :

161
Online

28852
Users

14651
Topics

110727
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.