API Restful



  • Hi,

    I'm trying to use the API of recalbox from a local server but I'm stucked.

    I have set the option system.api.enabled = 1 and reboot the Pi but I can't do any curl request from my local server (curl http://192.168.0.18:1337/ -> curl: (7) Failed to connect to 192.168.0.18 port 1337: Connexion refusée.

    Can I see some logs on the Pi?
    The developer environment is only needed if we want to modify the API and not used it, right?

    ping @MikaXII



  • I tried it 3 months ago, was working fine. Try 127.0.0.1eventually



  • What I want it's use the API through a local server, not the Pi itself. :)

    I tried the command on the Pi but same thing (with local and network IP).



  • I'll try lter today and tell you how it goes



  • Looks like the start of the recalbox-api is crashing ... I'll fill in a bug



  • Ok thank you! We close this thread?



  • @DjLeChuck no, seems like there is a fix ongoing that I'd like you to test. Can you edit /etc/init.d/S95api and replace PM2_HOME to /var/.pm2 , reboot and retry the curl ?



  • @subs : Sorry for the delay, I was mounting my bartop :D I can not edit the file, he his readonly. I can do something like that example for the config.txt file ? mount -o remount, rw /boot



  • Just replace /boot by / and you can edit+save it



  • @subs : It work's! Perfect thank you. \o/



  • Thanks for finding a bug ^^will be solved in the next beta



  • Thank you for allowing me to use the API on the Pi!

    P.S. : @subs Comment je marque un topic en résolu ? ^^'
    EDIT : Bon bah trouvé !


Log in to reply
 

Want to support us ?

Join us on :

261
Online

31040
Users

15113
Topics

113723
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.