Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

[Resolu] Emulateurs qui ne se lancent plus! 4.0.0 B4 partition Share sur disque dur externe



  • Bonjour,

    Pour la 3ème fois mon système a planté. Cela n'est pas très grave, c'est seulement pour informer que j'ai l'habitude des manips suivantes et qu'à chaques réinstalles, c'est toujours le même topo. J'ouvre ce topic dans l'espoir de trouver une solution moins contraignante.

    Voici l'histoire, après avoir changé de core sur un émulateur, le système a figé avec plus aucuns moyens de rebooter (WinCSP), j'ai donc était obligé de retirer l'alim. :/
    Depuis, plus aucuns émulateurs ne se lancent. Je précise que je ne peux plus mettre le système en FR mais que ma musique système perso et le thème sont toujours présents.
    J'ajoute également que ce problème apparait a chaque fois qu'on retire l'alimentation sans passer par la fermeture standard du système.

    Jusqu'à maintenant, je faisais une fresh installe mais le soucis c'est qu' une fois le nouveau système relancé, il ne capte pas l'ancienne arborescence sur mon disque dur externe.
    Première question, est-ce normal?

    Je suis donc obligé de renommer l'ancienne arborescence et d'en créer une nouvelle à l'aide du système, ensuite je rebalance toutes mes roms, sauvegardes, etc de l'ancienne vers la nouvelle arborescence. Ce qui représente un tout petit peu plus de boulot.

    La question que je me pose, le problème de base se situe sur le système, donc la sdcard ou sur le disque dur?

    Au final, aurait-il une solution plus simple pour réparer cette erreur d'émulateurs qui ne se lancent plus sans faire une fresh installe?

    Merci d'avance pour votre aide.



  • Bonsoir,

    J'ai avancé dans ma recherche de panne et je peux répondre à certaines de mes questions.
    Tout d'abord, je pensais avoir fait la maj vers la B4, ce qui n'était pas le cas. Une aubaine, car j'ai pu tester la maj mais celle-ci se coupait en pleine progression. Impossible de la faire avec le disque dur branché sur le pi.
    Du coup, en retirant le disque dur, j'ai pu faire la maj et j'ai également testé le fonctionnement des émulateurs en mettant des roms sur la sdcard.
    J'ai donc pensé que le souci venait d'un fichier se trouvant dans le dossier system sur le disque dur.

    Bingo!

    En créant une nouvelle partition share, j'ai récupéré le fichier recalbox.conf et j'ai remplacé celui de mon ancienne partition share en défaut.

    Au redémarrage du pi les émulateurs fonctionnent de nouveau!

    Au final, je garde le fichier recalbox.conf propre au cas ou je corrompe une nouvelle fois ma partition share.

    Information : WinSCP ne detecte plus rien dans la partition system du disque dur, là ou il faut copier le recalbox.conf (dans mon cas), il faut donc passer par un pc.
    Il nous affiche un joli petit message de ce type :

    text alternatif



  • Je reviens une dernière fois sur ce sujet.

    Du coup, il est préférable de refaire une arborescence propre sur le disque dur en cas de plantage comme expliqué plus haut.
    En effet, en remplacant seulement le recalbox.conf, j'ai eu une corruption de l'émulateur psx, celui ci était injouable. Les commandes de mon stick étaient complétement inversé dans les jeux mais fonctionnaient très bien dans le menu ES.
    En d'autres termes : c'était le bazar...:/

    PS : ne pas oublier de refaire ces 2 manips pour un bon fonctionnement du disque autoalimenté sur pi2
    -https://github.com/recalbox/recalbox-os/wiki/RPi2-:-Augmenter-le-courant-disponible-sur-les-ports-USB
    -https://forum.recalbox.com/topic/2611/disque-dur-version-4-00/8


  • Staff
    Moderator
    Team

    @daveheart
    ton pb avec winscp indique clairement un soucis quelque part.
    faut vraiment refaire ton arborescence sur ton disque dur.



  • L'avantage, c'est que je sais maintenant qu'en cas de plantage similaire, je refais seulement une arborescence sur le disque. Cela m'évitera une reinstalle complète du système.
    Au top recalbox! :)


  • Staff
    Moderator
    Team

    Tu as resolu ?



  • Oui, j'ai 2 sdcard, j'ai gardé celle qui était, à priori, en défaut et l'autre avait une installation propre en B4. Avec les 2 cartes, j'avais une corruption sur l'émulateur psx et les touches mals configurées.
    C'est vraiment dans le dossier système de l'arborescence sur le disque dur qui mettait le bazar.
    J'avais déjà eu plusieurs fois le problème d'émulateurs qui ne se lancent plus.
    Lorsque j'utilisais la sdcard seulement avec les jeux dessus je devais tous réinstaller maintenant que j'utilise un disque dur, je déplace le problème dessus et je dois donc, seulement, refaire une arborescence propre.
    Cela fait déjà moins de boulot ;)



Want to support us ?

189
Online

61448
Users

18626
Topics

139997
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.