probleme d'importation roms sur nas



  • coucou,
    j'ai lu le tuto pour coller le dossier roms sur un nas.
    https://github.com/recalbox/recalbox-os/wiki/Charger-ses-rom-depuis-un-partage-réseau-Samba-(par-exemple-un-NAS)-(FR)

    j'ai donc utiliser cette technique et je n'arrive a rien, ca fait 3 jours que je bidouille le soir et je ne vois pas trop de solution.
    j'ajoute que je peut lire les films par ce nas avec kodi en utilisant une adresse type smb.

    sur le tuto on peut voir une adresse telle:
    //192.168.0.1/roms /recalbox/share/roms cifs user=recalbox,password=recalbox,uid=0,gid=0,rw 0 0
    j'ai un doute sur ce "cifs", c'est un protocole avancé de smb?
    je suis plutot habitué a utilisé du ssh/sftp pour bidouiller sur le nas, serait-ce un probleme de protocole?
    y a t'il une facon de faire avec les protocoles citées?

    une options decouverte de reseau bien que peu utilisé pourrais etre utilisé au moment de la configuration non?



  • Cifs c'est une implémentation linux du protocole de Microsoft de partahe reseau, donc c'est juste.

    Arrive-tu au moins à monter manuellement ton nas ?



  • mmh, j'ai pas regarder, car je ne sait pas comment le verifier.

    dans /dev, j'ai le raccourci share, mais pas le raccourci roms comme j'imagine etre le cas dans cette config.
    il ne le monte sans doute pas.

    mmh ok, je suis en train de voir comment verifier si le syteme fonctionne correctement:
    on peut utiliser le dmesg pour verifier mais la c'est du charabia, je n'ai pas compris si il y a des messages d'erreurs.
    par contre et ca c'est interessant, je viens de tester par ssh un simple "mount-a" et j'ai un message d'erreur sur l'adresse.

    je vais continuer en ce sens et peut etre trouver mon probleme, merci!



  • tu as mis quoi comme ligne dans ton fstab ?



  • j'ai changer la ligne d'adresse, j'utilisais le chemin absolu (en partant de la racine) qui n'a pas l'air de fonctionner.
    j'ai donc utiliser le chemin tel que je le vois sur le reseau dans l'explorateur de fichier,
    avec la commande "mount -a" j'ai bien la liste du nas en mettant a jour la liste, mais ne fonctionne pas au demarrage.
    et de plus les jeux ne veulent pas se charger j'ai un ecran noir et il reviens au bout de quelques secondes au menu du choix des jeux.

    j'ai trouver ce tuto http://www.matthuisman.nz/2015/12/recalbox-network-roms-share-folder.html
    la on utilise le meme principe s'auf qu'on utilise un dossier temporaire.



  • mais tu peux quand même répondre à ma question ? ;)



  • pardon jj'etait dans mes test j'avais pas vu la reponse j'ai mis une ligne comme celle_ci:

    //192.168.x.x/dossier/roms /recalbox/share/roms cifs user=xxx,password=xxxx,uid=0,gid=0,rw 0 0

    voila donc la ligne, j'ai pas encore trouver de solution, je suis etonné de devoir faire un "mount -a" a la main par ssh pour qu'il voye la liste des jeux et ca ne se lance pas, je suis en wifi ca peut eventuellement jouer



  • Oui mais là ta ligne elle ne vaut rien, je veux la vraie moi !

    1. 192.168.x.x doit etre l'ip de ton NAS
    2. dossier doit etre le nom du aprtage
    3. roms c'est le chemin du partage vers les roms

    En gros, la premiere partie, si tu remplaces les / par des \, et que tu colles l'adresse dans l'explorateur windows, tu dois tomber sur ton répertoire partagé qui contient l'ensemble des répertoires des systèmes avec leurs roms dedans

    /recalbox/share/roms : à ne pas changer

    user et password : à toi de voir ce que tu as mis sur ton NAS

    La suite, tu ne touches pas

    Le wifi n'a pas d'importance, par contre je suspecte que tu n'as pas touché le S31emulationstation (1 modif à faire dedans) et le renommer en S92emulationstation

    Je dis ca au passage, mais ca devrait etre géré nativement dans la 4.1



  • c'est bien ca pour la ligne, j'ai remplacer les // par des \ mais ca ne se monte pas (invalid argument).
    et j'ai bien fait la manip pour le renommage du fichiers en S92emulationstation mais ca ne me monte pas l'adresse du nas.
    je vais faire quelques test mais la ligne semble bonne



  • alors avec l'adresse dns, le \nomdunas fonctionne dans fstab.
    mais je n'arrive toujours pas a lancer des jeux, donc je me demande si ce n'est pas le fait
    de le monter a la main qui pose probleme, car il n'est pas lancé au moment voulu comme dans le script



  • bon, je viens d'essayer avec un jeux non zippé et il fonctionne,
    mon probleme est lié a cela du coup, par contre je suis obliger de monter la partition a la main via ssh



  • un jeu zippé marcherait alors qu'un nom zipé ne marcherait pas ? le probleme est ailleurs dans ce cas

    Quand tu modifies pour S92, tu as du ajouter un mount -a si ma memoire est bonne. Tu es sur de l'adresse ip de ton nas ?



  • oui la ligne fonctionne
    et le mount -a ne prend pas, je vais surement copier le s31 original et refaire la manip car je pige pas pourquoi ca ne le monte pas.

    et pour le zip, je peut douter du fait qu'il veuille decompresser le fichier quelques part.



  • suite a la maj
    je me suis rendu compte qu'effectivement j'avais un soucis sur le s92emulatiionstation, une faute de frappe dans l'edition de mount-a

    ca demarre correctement depuis.
    mais je me demande l'interet de devoir changer la priorité des scripts, car a chaque maj j'aurai droit a faire un mv s31 en s92,
    si ce n'est que cela ce n'est pas bien grave c'est tellement cool de pouvoir tourner sur le nas.

    en ce qui concerne les zip je n'est pas exploré plus en detail le soucis, peut etre que quelques roms ne sont pas dans un format supporté.


  • Moderator
    Team

    Bonjour
    il faut changer la priorité des fichiers car l'accès vers un nas est plus long au niveau détecttion pour le réseau et emulationstation démarre avant lui, du coup ES ne peut pas lister le contenu des roms.


Log in to reply
 

Want to support us ?

Join us on :

306
Online

28985
Users

14707
Topics

111074
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.