Error: Resizing Existing FAT Partition



  • Hello All..

    I am trying to install Recalbox onto a 16GB micro SD memory card for my raspberry PI 2+.

    I downloaded the zip file on my Windows 10 (64 bit) computer, extracted it to a temporary folder.
    I used the SDFormatter tool to format my micro SD card using 'Full (Overwrite) and turning 'ON" the format size options. I tried all combinations as well for that matter.
    I copied the extracted files from the hard drive to to the microSD card and then put the card into the raspberry PI and turned it on.

    It begins to load and then a screen appears with an error message:
    "Error: Resizing existing FAT partition"
    "Error: The FAT don't match. If you don't know what this means, then select cancel, run scandisk on the file system, and then come back."

    when I close the "close" button..

    a second screen appears "Waiting for SD Card (settings partition)

    can someone give me pointers what I am doing wrong and does RecalBox have an IMG file that I can simply use the Win32DiskImager tool like all the other arcade emulators out there.

    thanks
    tom


  • Translation Master
    Team

    Hi @tdelios

    What kind of SD Card do you have and have you looked into this?
    https://github.com/recalbox/recalbox-os/wiki/Compatibility-(EN)


  • Moderator
    Team

    I guess you have a samsung sd ?



  • Its not a Samsung.. It's a SP 16GB micro SD card.

    I have tested it with Piplay and RetroPie using their IMG files and it works fine..

    I'm just having the problem with the Recalbox.. I'm assuming its the formatting that is the issue.

    Any ideas or does anybody know of a download link that has an IMG file that I can use Win32DiskImager to load the RecalBox image onto the micro SD card.


  • Moderator
    Team
    Creator
    Moderator

    try with partition wizard,

    erase all partitions on the card

    create a new one as primary and format in FAT32

    put the recalbox image, install.



  • @supernature2k Tried it.. still same problem..

    Are there any plans to create an IMG file similar to PiPlay and RetroPie and what is the target date?

    I really want to get my hands dirty with Recalbox, but i'm not willing to run to the store and try different brands of micro sd cards until one of them works. Restoring an IMG file onto a micro sd card increases my chances of it installing opposed to copy and pasting a directory structure from my windows 10 machine even though it does sound easy to do. All about consistency otherwise people will lose interest in the brand..

    When I have time in the upcoming months, I'll try another micro sd card from another manufacturer.. Hopefully by then an IMG file will pop up.


  • Moderator
    Team

    You can do it an other way, but it requires linux :

    • Create a first partition in Fat32 that is 60MB big ans extract boot.tar.xz on it
    • Create a second partition : 2GB in ext4 and extract root.tar.xz there

    I think you could even do it with a VM. These steps are explained in the development basics on the wiki

    Concerning building .IMG files, so far we couldn't make it in an automated process. But it seems that porting to xu4 made us discover some features of buildroot. But I can't tell you yet for sure if we will propose .img filed



  • hey @supernature2k and @subs .. i'm trying to use the Partition Wizard like you suggested..

    It created 2 partitions from my 16GB memory card. One that is 14.96GB and the other, a tiny unallocated 8MB..

    the 14.96GB was formatted FAT32 like you said and the 8MB is allocated and possibly not formatted as it doesn't give me the ability to do anything with it.

    I extracted Recalbox from the zip file into a temp directory on my windows 10 computer and then from that extracted folder, I copied and pasted all the files and their sub-folders structure into the micro SD card and put it into the raspberry pi..

    When I turn on the Raspberry pi, the green and red light are solid, but nothing comes up on the screen. Not sure how long I have to wait, but it didn't take this long the old way before I got any error message.

    any other suggestions for this Windows guy.. ?



  • Someone needs to put not only the 16GB SP on the incompatible list, but also the 8GB ADATA as well.

    Trying now with a 8GB SanDisk that came with my Raspberry Pi.



  • @supernature2k so I double checked my partition wizard and saw that I made a mistake, that I created a 'logical' instead of a 'primary' on any sizes of my micro SD cards.. That is the reason why why nothing came up on the screen and the red and green lights were solid.

    When I went back and removed the partition and re-created them as 'primary' and formatted as FAT32, I have the same "Resizing Existing FAT Partition" error as when I started.. so i'm at a loss why any size micro SD card from 3 different manufacturers is giving me this problem..



  • @subs and @supernature2k oh man.. I give up..

    I thoroughly went through the process:

    • used Partition Wizard to delete all partitions and create a new 'primary' with FAT32
    • used SD Formatter with the options of 'FULL OVERWRITE' and 'SIZE ADJUSTMENTS ON'
    • downloaded fresh copy of the installation and unzipped directly to the SD card..

    but once I popped it into the Pi and turned it on, the exact same error message occurred.


  • Moderator
    Team
    Creator
    Moderator

    Wow, strange that it happens on 3 different cards. Could it be the rpi that is faulty?


  • Moderator
    Team

    Need a microsd card in class 10 it s important
    You need use only partition wizard free with fat32 and primary option cluster size by default.
    No sdformatter doesn t work in windows 10 -> exfat format not supported.
    You need a good scandisk microsd.
    Try with an another microsd adapter.


  • Moderator
    Team

    @tdelios with your 8GB sandisk, try using sdformat rather. That tool is great for SDs strictly below 64GB



  • This won't probably be very help full but every time I got this error I fixed it by ejecting the SD card before removing it from my SD slot or USB. Try it it might work... No idea why tho. ,_,



  • Like others, I have been getting this same problem. I have tried formatting a new, good quality micro SD card using two computers with Windows 7 (64 bit and 32 bit); a combination of adapters as well as a native computer SD slot and a SD card holder. In every case, I have used the SD Formatter program as recommended, with various options set or not. None of them worked! Every time, when I tried to boot into the Raspberry Pi, I got the same error message 'Error resizing FAT partition'. It also didn't seem to matter if I extracted the NOOBS files to the SD card after formatting; if I extracted them to a separate directory and then copied them; if I safely removed the SD card and then reinserted it after formatting - generally, all of the so-called fixes mentioned here just did not work. However, the one trick that did work was to put the SD card in my camera; format it (it takes about 10 seconds!); put it back on to the computer and then copy the files from the previously extracted NOOBS directory. And it works! Not only that, it takes about 3 minutes from start to end instead of the 30 to 45 minutes using SD formatter. So my inescapable conclusion is that there is something wrong with the SD formatter program. Forget all the other 'solutions'. Grab a camera (mine is a Canon, but I'm sure any reasonable camera will do); format the card in it; extract the NOOB zipped files to a directory; copy them to the - now correctly formatted - SD card and all should be good.


  • Moderator
    Team
    Creator
    Moderator

    Hi @mikeinnc ,

    Thx for this workaround.
    Pb is of course not everybody got a camera to do this and it's not normal :/

    If you have several sd cards, could you please do a test and tell me if it works ?

    Use partition wizard, create primary fat32 partition, extract archive files on card and put it into rpi?



  • @subs @supernature2k @acris @Zelaf @mikeinnc

    So, I got good news and some bad news. The good news is I got it to work. I am fortunate enough that I hang in the same food court as engineers of Sun Micro systems (the Unix creators). I told them about my problem and they said that this has been an increased problem for a lot of Linux, Unix and other type of 'inux' operating systems directly due to Windows users. Users who have Linux/Unix operating systems to partition and to format any type of SD cards don't have this issue. They even said that having any type of Class card (Class 1 through 10) has no bearing. That is simply the data transfer speed it can handle to transfer roms in/out of the SD card and tiny processing time to run the roms. The problem with Windows is that from Version 7 to Windows 10 (in both 32 and 64 bit), the partition and formatting seems to be off when some of the windows patches are applied. Not sure which ones as Microsoft won't tell us and nobody has gone through every combination of windows 7-8.1 and Windows 10 automatically applies everything regardless if you want them or not. They said that when you format a hard drive or SD card in these ranges of operating systems, especially from 8.x-10, the SD won't work in other linux/unix devices as windows thinks you'll be using those storage devices for its own purpose. They said that not all users having windows 7-10 are having the same problem as me, but if they would accurately guess from their experiences hearing in their own world, that its between 75-90% of people they run into.

    Their suggestion is one of two. First, they said that if I have a Windows XP laying around to use it to partition, fat32 format and unzip the install files into the micro SD card. That actually worked!! and it worked for ALL my cards regardless of manufacturer and class and both Pi 2 and Pi 3

    The bad news is that the Windows XP computer was a friend's of mine as all my computers at home are Windows 10. I even took my SD cards and my Pis to one of the engineer's house (as he is familiar with Pis, emulators and such) to test their theory as they have both windows 10 (64 bit) and Windows XP and they experienced the exact same problem on windows 10, even with their own SD cards.. But once they partitioned and formatted his and my SD cards and unzipped the install file into them from a windows xp machine, they worked like a charm..

    They gave me advice which they suggested to pass onto whoever is creating RecalBox or give advice to the owner of Recalbox. This problem with SD cards is a dirty little secret that the world knows but a lot of people don't know how to truly fix as its a Windows issue. That is why the folks who created Raspberry, PiPay, RetroPie and other apps created their own IMG files so that people can simply use the Win32DiskImager tool to extract onto their SD cards regardless of Windows version. They said that if Recalbox wants to increase footprint of their product, they should create their own IMG files. New users who want to try out and use RecalBox and have little patience unlike myself will bail on the product on the first or second attempt out of frustration as googling the answer doesn't really help and asking forums for advice is a crap shoot unless they read this specific post.

    Now that I have a working installed vanilla version, they said that I should use Win32DiskImager to backup the image off of the SD card and store it in a safe. They said that this image can simply be restored on any micro SD card regardless if size and class. So I tested that theory and he was correct. I used my Windows 10 machine and saved one of the images using Win32DiskImager. On the same Windows 10 machine, I then used Partition Wizard to partition and FAT32 format all my micro SD cards(regardless of manufacturer, size and class), and then used Win32DiskImager to restore from my backed up IMG file. THEY ALL WORK after doing full regression testing on them regardless if the backup image was done on a Pi 2 and restored on a Pi 3 and vise versa.

    So not sure who is in charge of the forum to put the bug in the developer's ear, but a decision needs to be made to either create IMG install files or have a section in the forum where someone can drop their own vanilla IMG file installed version. The number of computers being upgraded to windows 10 is increasing and if the creators want to increase their footprint in this area, they need to address this request.

    peace out
    Tom


  • Moderator
    Team

    I'm part of the developer team, i'll strongly encourage my dear @digitaLumberjack to read this :)


  • Translation Master
    Team

    @tdelios I cannot second that. I am using 4 different PCs and Laptops running Windows 7, Wiindows 10 and Ubuntu. On ALL machines, I was able, with no problem at all, to format my SanDisk Ultra 32GB Class 10 with either SDFormatter (using a MicroSD to USB Stick) or Partition Creator on Linux. I did this 50+ times now (different and same cards) and all of my tries were successes. I am on the latest update states on all windows machines (no exceptions) and all of the Window Version are either Ultimate, or Pro 64bit. The SD cards were all brand new. No preformatting. I ieven used diskpart once to create the partitions for a SD Card and it worked like a charm as well.



Want to support us ?

Join us on :

244
Online

27406
Users

14109
Topics

107061
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.