Recalbox 7.0

My TP-Link TL-WN722N doesn`t work.



  • Hello. I`ve got RP2 + TP-Link WN722N. When I plug it in, nothing happens. Please, help me.

    Powe supply: 2A



  • I guess you need to add the firmware because the driver should upload it to the key at each boot. Some people my have faced the same problem. Have you searched through the forum or on github ?



  • When I used Raspbian, I just followed this instructions:

    http://barntek.net/simplemachinesforum/index.php?topic=190.0

    And it works great . But it isn`t helped me in Recalbox.
    I place htc_9271.fw firmware to /lib/firmware. Then I add adapter definition to network config - nano /etc/network/interfaces.base:

    auto lo

    iface lo inet loopback
    iface eth0 inet dhcp

    auto wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa.conf

    after reboot my Wi-Fi adapter still not working. LED indicator still off.

    I don`t know how can I solve this problem.



  • Have a look here. Almost the same dongle, you should check if it's the same chipset
    https://github.com/recalbox/recalbox-os/issues/93

    Anyway you should just add the firmware and then configure your wifi in emulationstation



  • @forgoty i guess it worked ? We may add the firmware then for a future release



  • @subs Yes, this works fine. I just need to click Wi-Fi On in EmulationStation and it is works fine.

    Firmware that i use is still htc_9271.fw.

    But, there is another problem: i can not connect via ssh to my recalbox and i have no idea why it is not working now. Wi-Fi is on, i see my recalbox in ip device list. But, when i try to connect - connection timed out.

    UPD: In Network settings I see NOT CONNECTED. Wi-FI SSID and KEY are wrote correctly. I try to ping my router - 100% loss. Green LED on my adapter is On. I still can see my recalbox via IP-devices list. Please, give me an advice.



  • 1st : know that lan and wifi can't work at the same time
    2nd : you will need to plug a keyboard, press F4 to quit es and then alt+f2 to reach a terminal

    Next : does wlan0 show in ifconfig ? Doest it have a valid mac address ? Does wlan have a valid ip IPv4 or not ? If it has no ip, then it didn't join your ssid



  • @subs said in My TP-Link TL-WN722N doesn`t work.:

    1st : know that lan and wifi can't work at the same time

    This is the solution of my problem that I have with ssh. I tried to assign the same static IP-address eth0 and wlan0 at the same time

    Anyway, i can not connect to internet. And I don`t know why that happens.

    ifconfig wlan0

    wlan0 Link encap:Ethernet HWaddr F8:1A:67:1B:26:0A
    inet addr:192.168.100.14 Bcast:0.0.0.0 Mask:255.255.255.0
    inet6 addr: fe80::fa1a:67ff:fe1b:260a/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:17425 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14583 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:21748738 (20.7 MiB) TX bytes:1418608 (1.3 MiB)

    I tried to ping Google DNS:

    ping 8.8.8.8

    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    64 bytes from 8.8.8.8: seq=0 ttl=46 time=41.627 ms
    64 bytes from 8.8.8.8: seq=1 ttl=46 time=40.581 ms
    64 bytes from 8.8.8.8: seq=2 ttl=46 time=39.053 ms
    64 bytes from 8.8.8.8: seq=3 ttl=46 time=39.160 ms
    64 bytes from 8.8.8.8: seq=4 ttl=46 time=38.874 ms
    ^C
    --- 8.8.8.8 ping statistics ---
    5 packets transmitted, 5 packets received, 0% packet loss
    round-trip min/avg/max = 38.874/39.859/41.627 ms

    In EmulationStation/Network Settings i can see that Wi-Fi is working on, but Status is NOT CONNECTED.

    By the way, data transfer rate through WinSCP is terrible. About 21 kb/s.

    Any ideas to help me with internet connection?
    Thanks for your patience



  • You're using static ip ? Or fixed dhcp ? Try not to assign the same ip to lan and wifi.

    If you could ping google, then you have a gateway, and your pi sees your router. Dunno what's wrong now ... And still, that bandwidth thing is not normal



  • After reinstalling recalbox, i have noticed that internet is working fine only when I use dhcp. With static IP-address i can ping anything I want, but in EmulationStation or Kodi connection does not exist.

    UPD: Adapter is working fine.



  • I wouldn't recommend you use a static ip. Rather set a fixed ip to the mac of your wifi dongle



Want to support us ?

132
Online

79.1k
Users

20.3k
Topics

149.0k
Posts