Recalbox 7.0

[Solved]Having issues with changing roms directory (hdd)



  • First of all,  good morning (yes it's still morning overhere).  I got some issues with changing the directory of the roms. I got all my  roms on an external 2TB drive that's connect (through usb)  with my Raspberry Pi3.  The first part of the tutorial on gifthub is no problem, but when i get to the part from press 'i'  i really get confused.



  • Sorry for all that text,  i tried to copy a part of gifthub,  that didn't work that well.  I'm trying to remove that.  I have a screenshot included from the part i got stuck



  • I can't seem to find the edit option (i'm on a smartphone at the moment).  So please forgive me.  This is the text (kinda)  from above.   First of all,  good day to you all.  I got some issues with changing the directory of the roms.   I got all my  roms on an external 2TB drive that’s connect (through usb)  with my Raspberry Pi3.  The first part of the tutorial on gifthub is no problem, but when i get to the part from press ‘i’  i really get confused   I press the ‘i’  on my keyboard,  but what do i have to do then?  I don’t have the line  /dev/mmcb1k0p7/  ... .  Do i have to write this line.  The only i can write is ‘#’  and nothing else.   I hope someone can help me with it. It sucks to be stuck at the last part


  • Global moderator
    Team

    Hi stephan, You 2TB hdd is a usb hard disk alimented by the usb or with a dedicated power ? If's a <span id="result_box" class="short_text" lang="en"><span class="">self-powered</span></span> DD, You need to use a usb hub with its own <span id="result_box" class="short_text" lang="en"><span class="">power supply. Raspberry pi usb is to light for power an dd. Only usb key is possible...</span> </span>  I tink your problem come with that and not a problem of mount of the hdd... The fonction for mount hdd on the menu only make what is explain in the wiki...


  • Banned

    My 1TB HDD works fine without any external power supply... Stephane the page you're following is obsolete you can now switch from sdcard to hdd directly from Emulation Station menu... (in system I think) So copy all your roms and bios into a directory on your hdd after having formatted it in FAT32 Reinstall completly Recalbox on your SD. Choose the option from in menu and let it reboot After reboot a share folder shoul be created on your hdd, all you have to do is move your roms/bios into their relevant folders and voilà ! If you have any custom configuration, save it before the reinstall step !


  • Global moderator
    Team

    Voljega, your are luky but Stephan say us on fb that doesn't work... For me it's a problem of power usb :s. Stephan your hdd makes noises as if the board was jumping? Can you watched if it is recognized in Kodi. We will set like that;)



  • @stephan-maat which wiki are you following ??? There is an option inside recalbox to just -add- a USB storage device without the need for editing files. If the hdd s not recalbox-ready, recalbox will just create the directory structure it needs (no data erased). You can then move all your roms easily on your PC then plug back the HDD on recalbox Dunno if your HDD is FAT, NTFS or EXT4, but i strongly recommend you do not use NTFS, it's pretty slow


  • Banned

    @reivaax Oh sorry, I wasn't aware of the facebook discussion



  • I think i may found the problem.  My usb thumb drive had issues too with the build in option (yes i found it,  stupid me) .  Every time i booted recalbox it got stuck on a black screen.  When i booted it without it,  everything was fine.   After i formated to fat32 it booted fine. So now gonna backup my hdd and format that again.  Sorry for being a noob (ask me something about Android and i probably know the answer.  Lol).   Thanks for your help so far.   Oow 1 more question (actually 2).  Does anyone know a good program that automatically renames roms and maybe a good rom scraper for pc (x86).  I got one for x64,  but using and older x86 laptop now.  Problem is i don't know where i got scraper_windows_amd64. It's very good and i hope there's an X86 version of itm   Thanks again


  • Banned

    You can find the very good softs  Universal Rom Scraper and Universal Rom Cleaner by Screech there : http://blog.recalbox.com/forums/topic/soft-universal-rom-cleaner-nettoyez-vos-romset-dune-main/ http://blog.recalbox.com/forums/topic/soft-universal-xml-scraper-scrappez-vos-roms-en-fr/ Ask for help in english there if you need it I think there are maybe also engligh topics on both subject too



  • there is a pinned topic for an inline scraping tool, fullscrape. It runs by itself on the pi, no need of any PC



  • Thanks will check it out tomorrow



  • If you want this is the english post about Universal XML Scraper It works in french and english with a lots of possibility and it's very simple to use. don't hesitate to ask if you have question.



  • Got 1 more question,  does anyone know s got tool or instructions on how to format a 2TB hdd to fat32.  Can't seem to find one.



  • Btw: i found my old scraper again.  So for the people who want to check it out them self.  Just put 'scraper.exe' on your rom directory and run it. https://gifthub.com/sselph/scraper/releases



  • try guiformat http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm there are some other recommended tools on the wiki, like mini tool. It's a partition manager that can do the job.



  • Thanks,  but i found the 1 used before but now for x86



  • Thanks guys.  I think i'm getting there ?



  • Everything works,  accept Atari lynx & Famicom Disk System. .   So i'm happy.  Thanks again


  • Banned

    You'll need BIOS for both of them



Want to support us ?

133
Online

79.1k
Users

20.3k
Topics

149.1k
Posts