Recalbox 7.0

BT Controller does not autoconnect



  • Hey all, Sorry if this is a repeat, but I cannot find the answer after searching high and low on google and this forum (a lot is in français.) I have no problem using a shanwan controller (or what I think is a shanwan controller) with a Plugable USB Bluetooth 4.0 Low Energy Micro Adapter. The problem is that it doesn't autoconnect. The steps I need to do to make it connect is: 1)Log into the virtual gamepad 2) navigate to controllers 3) Forget Bluetooth Controllers 4) Pair A Bluetooth Controller (which doesn't find any) 5) Hit connect button on controller, which sets as "Player 2" (Virtual Gamepad has "Player 1") There has to be a setting somewhere that is all jacked up. I can navigate myself around PuTTY/SSH and the config files. Can anyone assist? PS: Thanks everyone for all you do. If I knew just a little bit of the programming language, I would love to contribute.



  • Shanwan ? you mean a PS3 clone ? You should plug it on USB for 10 secs maybe, until it starts to rumble, unplug it (maybe press the P3 key) and it should be fine. You can't pair it the way you're trying, Dualshock-like pads don't work the same as any regular BT device Can you try and tell me if it's ok now ?



  • I have a shanwan controller and previously it worked fine (after initializing one time by plugging it in via USB and holding the P3 button). It would then automatically reconnect every time i started the recalbox and hit the p3 button (without cable connected) - just like it should. However for the last few days it has stayed in seek mode when I turn the controller on. I discovered that to fix it I need to pull the BT dongle out and reinsert it. The controller will then reconnect normally after P3 is pressed. This may be an issue with my particular BT dongle, as I have had one other identical unit die previously. I will be receiving several more newer dongles  in the next few weeks, so will test.



  • Received 4 of these today http://www.ebay.com/itm/401090361856?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT I then systematically inserted them one at a time, and using a USB cable sync'd them all to a single shanwan PS3 controller CECHZC2U BLUETOOTH DUALSHOCH III (yes, actually spelled with the typo) All dongles immediately worked with the new pairing. I did some other tinkering for a while, including numerous shutdown -r now But notably did not have a problem until I decided to test them and tried an actual power off. shutdown -h now The results of some fairly extensive testing were strange, and at first led me to think it was partially faulty dongles. However the more tests i did the more this became false. If a dongle is plugged in while the PI : 1) is powered: it will always work - assuming it has been previously paired with a controller. 2) is not powered: the ps3 controller will usually, if not always refuse to reconnect when the pi is later powered up. In all cases the dongle lights up at one second intervals until the ps3controller hotkey is pressed, then it flashes (presumably) in accordance with power output as it connects to the controller. However I noted that in all cases where the dongle/ps3controller failed to connect... the dongle was lit up and rapidly blinking exactly the same as if it were successfully connected/paired to the ps3controller. OF NOTE: If I left two dongles plugged in I had almost total success in subsequently reconnecting the ps3controller after a poweroff state, without getting up to physically re-plug the dongle. The simplest 'fix' is to re-plug the dongle while the pi is in a powered-up state, and then hit the controller hotkey as per usual (no USB cable required). After these tests I set: max_usb_current=1 So I'll continue running with two dongles for a while, but intend to eventually re-test similar with one dongle and poweroff states...and the higher current.



  • Also of note, and I think very handy: When using two dongles, a successful pi poweroff state causes the ps3 controller to rumble briefly. Possibly because it's being actually signaled to turn off... but I didn't check it's lights so I'm not sure of that last part.



  • Minor update: Increased current to USB seems to make no difference. So far. Powering off just now with two dongles attached failed to reconnect on reboot. One dongle was clearly attempting connection, and (as usual) looked to have succeeded and be actively communicating, but ps3 controller didnt rumble or stop blinking. Rather it eventually timed out and powered off. I removed the dongle that appeared to be connecting, and pressed the ps3 button again. Immediate successful connection to the other dongle that was still plugged in. There's something strange going on with the edge condition of physically plugging and unplugging dongles.



  • Got up this morning and turned Pi on. No bluetooth connection. Tried unplugging/replugging dongle(s). Total failure. So I set max_usb_current=0 and rebooted. Immediately it worked. Very strange, considering it worked fine the night before and now suddenly didnt work at all after a night powered down. Is it possible that the Pi is drawing current from the HDMI cable even when the Pi itself is off? The only difference between working (last night) and not working (today) was that overnight I physically remove power from my tv via a switch on a powerboard...that the Pi is also powered from. However while testing I generally only unplug the Pi, and do not kill power to the TV as well. Weird. In any case it's back to the usual: working on one dongle just fine across reboots, but not after powerdown/power disconnections. Re-plugging the dongle is still the 'easy' fix.



  • I did a fresh reinstall and used the "connect via USB and hit the button after 10 seconds" method and now see no issues. Not sure what the issue was before, but this stuff is too advanced for me to solve.

    Thanks for all your help!


Log in to reply
 

Want to support us ?

158
Online

79.1k
Users

20.3k
Topics

149.0k
Posts