Custom GPIO pin config



  • Hi everyone, Im new to retrobox, i was looking for an alternative to retropie and this looks like a far better os! I have a pi zero with a controller already soldered to the gpio so i want to have a custom pin config. I looked at the mk_arcade_joystick_rpi notes on https://github.com/Pinuct/mk_arcade_joystick_rpi and it says you can do this by runnning the following command: modprobe mk_arcade_joystick_rpi map=5 gpio=Y-,Y+,X-,X+,start,select,a,b,tr,y,x,tl (swapping these out for your pins) I tried putting this in the recalbox.conf file first with the following and the system fails to boot: # ------------ D3 - GPIO Controllers ------------ # ## GPIO Controllers ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1) controllers.gpio.enabled=0 ## mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2) controllers.gpio.args=map=5 gpio=3,2,4,17,10,9,27,22,-1,-1,-1,-1 I also tried every possible combination of the above before i noticed the following in the log file: [       10.87] : loading module mk_arcade_joystick_rpi args = map=5 so it looks like the extra arg is not getting through for some reason. I tried dissabling it in the config then manually running the following from ssh and this worked for map=1 but not for map=5 gpio=3,2,4,17,10,9,27,22,-1,-1,-1,-1 modprobe mk_arcade_joystick_rpi map=5 gpio=3,2,4,17,10,9,27,22,-1,-1,-1,-1 If anyone can help that would be ace, otherwise i have a painfull night of re-wiring ahead of me :( Thanks Malkie



  • ok, i just noticed that this code was written 19 days ago (10 days after 4.0.0-beta3 came out lol) so the reason it wasn't working is because i have the wrong version of mk_arcade_joystick_rpi installed i have read the instructions on how to install the latest version and they don't work on my recalbox install, i have some linux knowledge, mostly ubuntu for websites and raspbian for fun so please go easy on me: -firstly i am ssh as root but can't change anything on the drive becuase its read only? -secondly the instructions keep using commands that dont exist e.g. sudo and dkms? -thirdly all the repo links are out of date and point to an old location, i fixed this but it makes me feel that the instructions might be out of date? sorry for all the questions thanks adam



Want to support us ?

Join us on :

307
Online

31380
Users

15165
Topics

114020
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.