Recalbox 7.0

AdvancedSettings active after second start of Kodi?



  • Hi there, at the moment I've a OpenELEC system running on my rpi2, which is running perfect. Now I see, that RecalBoxOS supports also Kodi, so I planned the following situation -> Rpi2 starts with RecalBoxOS System directly into Kodi and afterwards I can exit Kodi to enter the emulationstation (cause in 90% of all cases I 'only' want to watch a movie). So I tried with copying my advancedsettings.xml to the RecalBoxOS (my database is on a NAS), but I've got the following problems: With first start the advancedsettings.xml is not active. After exiting Kodi and restarting it, the advancedsettings.xml is active?! I can also reproduce this situation with manual starting Kodi. On first start Kodi starts with default settings, and the second start loads the advancedsettings.xml Is this problem known and is there a solution? Next problem was the restart/shutdown action from Kodi. With this functions kodi will only be closed and emulationstation is active. Is there also a possibility to restart/shutdown the rpi2 from Kodi? Thanks for your help and best regards, DerDominik



  • I guess that's because kodi is not launched just with it's binary, but with /recalbox/scripts/kodilauncher.sh. this is how it is started from ES



  • OK, but is there any solution to fix this? Or am I the only person, who has his movie database on a NAS? 😄 edit: Today I tested the actual beta version 4.0.0-build-36, and here is the problem solved. Then I'll test the system with the newest beta 😉



Want to support us ?

118
Online

79.1k
Users

20.4k
Topics

149.2k
Posts