PS4 Dualshock no reconnect after reboot Pi4



  • Knock knock, its me, with the next controller-related topic.

    Sorry but I have no luck so far.

    My problem is described like this post from December.
    https://forum.recalbox.com/topic/21901/ps4-controller-not-automatic-pairing-after-boot/4?_=1616701963065

    In short, the BT-Controller is not connecting after rebooting the Pi4 4GB. Version of recalbox is 7.1.1. It is flashed on a SD-Card with 32GB. Image is distributed and flash by Raspberry Pi Imager. The sticker of the Controller I bought is showing CUH-ZCT2E as model-number. I´m quiet sure it not an original one.

    Here some info about the paired and actual connected controller given by bluetoothcli:

    [Wireless Controller]# info 2D:92:30:00:96:C9
    Device 2D:92:30:00:96:C9 (public)
    Name: Wireless Controller
    Alias: Wireless Controller
    Class: 0x00002508
    Icon: input-gaming
    Paired: yes
    Trusted: no
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v054Cp05C4d0100

    I´m able to force the issue without reboot by turning the BT off and on again by cli command power off/on

    When I try to connect then, the output looks like this:

    [Wireless Controller]# power off
    [CHG] Controller B8:27:EB:FF:08:35 Discoverable: no
    [CHG] Device 2D:92:30:00:96:C9 ServicesResolved: no
    [CHG] Device 2D:92:30:00:96:C9 Connected: no
    Changing power off succeeded
    [CHG] Controller B8:27:EB:FF:08:35 Powered: no
    [CHG] Controller B8:27:EB:FF:08:35 Discovering: no
    [bluetooth]# power on
    Changing power on succeeded
    [CHG] Controller B8:27:EB:FF:08:35 Powered: yes
    [CHG] Device 2D:92:30:00:96:C9 Connected: yes
    [CHG] Device 2D:92:30:00:96:C9 Connected: no

    First it tells Connected: yes (Controller keeps blinking)
    maybe 3 seconds later => no

    I have testet all options in the recalbox.conf for PS3 controller ( bluez 5 / official / shanwan )

    Am I doing something wrong?
    The post above is closed with the info the issue is fixed with version 7.0.1

    Thanks in advance

    Svart



  • If it could be caused by BlueZ, is it possible tu update the version manualy to 5.56?

    http://www.bluez.org


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @svartbart

    is it possible tu update the version manualy to 5.56?

    I believe that it is not possible.

    Sorry but I have no luck so far.

    Unfortunately I have to agree, you really seem to be unlucky, I researched your problem and there is an open issue, you can comment on it if you want:



  • Hey, a small hint for anybody looking analyzing the problem. It seems the issue in reconnecting is a Pi 4 related problem.
    I tried it with a pi zero w and the controller is reconnecting.

    I will also try the 3b+ I´m using for my 3D printer.

    Maybe this will help any developer to solve the problem for Pi 4.

    Happy Estern!



  • @svartbart na tela de configurações de controles coloque primeiro o do PS4 para que tenha prioridade sobre os demais controles. Assim quando reiniciar o sistema não terá esse problema de desconexã

    o.



Want to support us ?

219
Online

82.6k
Users

22.8k
Topics

164.4k
Posts