Rpi 4 Can't get correct EDID info nor use resolutions freely



  • Hi to all and thanks for your attention. First my specs:
    Raspberry Pi 4 8gb with 5v 3.1a power supply and micro hdmi to hdmi cable (nisuta, 4k capable).
    Tested with various microsd cards, Recalbox 7.1.1, fresh installed several times, with default config.txt. Also did test with overclocked settings, same results (absolutely stable by the way, with the oc sets).
    I'm connecting to a Samsung 1080p led tv through hdmi standard port, also tried with another tv of same specs TCL 1080p hdmi etc.

    The problem: i want to set different CEA modes for different systems, especially Commodore64, Amiga and others wich use 50hz refresh modes, and i can't get other modes than these:
    Mode 1 (vga 640x480p 60hz)
    Mode 4 (720p 60hz)
    Mode 16 (1080p 60hz)

    When I specify in Recalbox.conf c64.videomode=CEA 17 HDMI (576p 50hz) or
    CEA 31 HDMI (1080p 50hz) and then launch a game it goes back to ES every time or if I try specifying other modes sometimes games start but go into one of the mentioned 60hz modes. I tried several other modes but I seem to be stuck in 60hz world...

    My findings:
    I gain access to linux terminal with a nice app called Termux. Once I'm into Recalbox I do:

    tvservice -m CEA (or DMT)

    to get EDID info from my tvs (both same results). And here is the thing that gives a hint: instead of listing a set of "reasonable" available modes as seen on:
    https://www.raspberrypi.org/documentation/configuration/config-txt/video.md
    the list that I get (both for CEA and DMT) is very incomplete, with modes numbers all mixed up in incorrect order and ridiculously high or low and odd resolutions, timings and specs.
    Here's a shot of the CEA output
    alt text

    DMT is equally odd.

    The thing is, with my older Rpi 3B through hdmi to the same tvs blah blah, using tvservice gives a perfectly "normal" list of modes and I can change them as I like and they function properly (I have to say I have Recalbox 6.1.1 installed on my rpi3, but I suspect all of this may have nothing to do with Recalbox's version).
    So the tvs EDIDs are out of the question. Something else has to be broken.

    So my thoughts are: may it be RPI 4 fault? Can you get a normal edid modeslist? Or maybe a lacking firmware (rpi4 is still at a young stage compared to rpi3) or maybe the micro hdmi to hdmi cable? Tested two cables by the way, one i bought many years ago and one i bought this year, same strange tvservice output.

    As a last thing to say, it's not only killing my possibility to select proper 50hz modes but i'm also incapable of using interlaced modes (I need them to use the pi with a hdmi to yprbr adaptor to conect to crt through component, i can only get 240p which is cool enough but ES without 480i is unreadable. But this is a side story.. obviously the root of the problem resides in hdmi not being able to create such modes)

    Thanks in advance for any input on this
    Best wishes to all community and thanks one more time for Recalbox to the developers


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • @Zing said in Rpi 4 Can't get correct EDID info nor use resolutions freely:

    @Pol Another user has already reported the same bug, see:
    https://forum.recalbox.com/topic/23299/emulation-station-starts-fine-using-a-raspberry-pi-4-with-recalbox-7-1-1-reloaded-and-my-monitor-but-some-games-have-a-black-screen-with-audio/8

    Thank you very much, indeed it seems pretty much related, so maybe theres not much to do but wait and see if next kernel or firmware from the raspberry 4 devs fixes this. I' ve been reading quite a lot and seems to be that Rpi 4 handles video output very differently from older models, both HDMI and composite outs.
    Its also a major letdown for me that its composite out is not only more difficult to set than that of the older Pis but also forces the clocks to a lesser speed (not much they say but its no good news for me). One of the main reasons i got a pi is to connect it to crt... But well, thats another story.
    Thanks again for the info and perhaps some one else can confirm certain modes dont work regardless of tv and hdmi cable? Or, on the contrary, maybe someone CAN achive this on Rpi4? Best regards



Want to support us ?

288
Online

82.6k
Users

22.8k
Topics

164.3k
Posts